1. Change directory to where BRCMbnx.pkg resides.
2. pkgadd -d BRCMbnx.pkg
OR
( Copy BRCMbnx.tar.Z to /tmp.
cd /tmp
uncompress BRCMbnx.tar.Z
tar xvf BRCMbnx.tar
pkgadd -d /tmp)
2(!). If installing on a fresh install of Solaris you will have a conflict
with the inbox driver which must first be removed. The "check_install"
script in the BRCMbnx package will prevent installation over an existing
driver so examine the output from pkgadd carefully. The inbox driver
cannot be uninstalled with the pkgrm command since there are no package
remove scripts in the package directory under /var/sadm/pkg. Use the
following steps to remove the inbox driver before performing a pkgadd of
BRCMbnx:
a. Remove the inbox package directory:
rm -rf /var/sadm/pkg/BRCMbnx
[or]
mv /var/sadm/pkg/BRCMbnx /var/sadm/pkg/BRCMbnx.inbox
b. Remove the driver:
rem_drv bnx
c. Verify bnx is not running:
modinfo | grep bnx
d. If it is running then unplumb all bnx interfaces and try to unload it:
modunload -i `modinfo | grep bnx | awk '{ print $1; }'`
e. If it doesn't unload then reboot.
f. Now you can perform the pkgadd as normal in step 2 above.
3. Execute prtconf to determine instance number of the NIC.
4. ifconfig bnx[instance_number] plumb
5. ifconfig bnx[instance_number] ip_address netmask .... up
To make these changes permanent, follow these steps:
1. Use your favorite text editor (eg. vi) and create a file named
hostname.bnx[instance_number] in /etc directory. Add the
IP address of the interface to this file, save and exit.
2. Add a proper subnet mask to the file /etc/netmasks.]