免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
123下一页
最近访问板块 发新帖
查看: 6806 | 回复: 24

[系统安装] 请教:CentOS5.5 安装perl-Module-Install错误 [复制链接]

论坛徽章:
0
发表于 2012-07-24 13:56 |显示全部楼层
本帖最后由 wushuangri 于 2012-07-24 16:23 编辑

[root@localhost ~]# yum install perl-Module-Install
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.ustc.edu.cn
* extras: centos.ustc.edu.cn
* rpmforge: mirror.cpsc.ucalgary.ca
* updates: centos.ustc.edu.cn
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package perl-Module-Install.noarch 0:0.92-1.el5.rf set to be updated
--> Processing Dependency: perl(Module::CoreList) >= 2.17 for package: perl-Module-Install
--> Processing Dependency: perl(Parse::CPAN::Meta) >= 1.39 for package: perl-Module-Install
--> Processing Dependency: perl(ExtUtils:arseXS) >= 2.19 for package: perl-Module-Install
--> Processing Dependency: perl(Module::Build) >= 0.2804 for package: perl-Module-Install
--> Processing Dependency: perl(File::Remove) >= 1.42 for package: perl-Module-Install
--> Processing Dependency: perl(JSON) >= 2.14 for package: perl-Module-Install
--> Processing Dependency: perl >= 5.005 for package: perl-Module-Install
--> Processing Dependency: perl(Archive::Tar) >= 1.44 for package: perl-Module-Install
--> Processing Dependency: perl(Module::ScanDeps) >= 0.89 for package: perl-Module-Install
--> Processing Dependency: perl(PAR:ist) >= 0.29 for package: perl-Module-Install
--> Processing Dependency: perl(YAML::Tiny) >= 1.38 for package: perl-Module-Install
--> Processing Dependency: perl(ExtUtils::Install) for package: perl-Module-Install
--> Processing Dependency: perl(Devel:Port) for package: perl-Module-Install
--> Processing Dependency: perl(File::Spec) for package: perl-Module-Install
--> Running transaction check
---> Package perl.i386 4:5.8.8-38.el5 set to be updated
---> Package perl-ExtUtils-ParseXS.noarch 0:2.20.02-1.el5.rf set to be updated
---> Package perl-File-Remove.noarch 0:1.42-1.el5.rf set to be updated
---> Package perl-JSON.noarch 0:2.50-1.el5.rf set to be updated
---> Package perl-Module-Build.noarch 1:0.3607-1.el5.rf set to be updated
--> Processing Dependency: perl(ExtUtils::CBuilder) >= 0.27 for package: perl-Module-Build
---> Package perl-Module-CoreList.noarch 0:2.25-1.el5.rf set to be updated
---> Package perl-Module-Install.noarch 0:0.92-1.el5.rf set to be updated
--> Processing Dependency: perl(Archive::Tar) >= 1.44 for package: perl-Module-Install
---> Package perl-Module-ScanDeps.noarch 0:0.95-1.el5.rf set to be updated
--> Processing Dependency: perl(version) for package: perl-Module-ScanDeps
---> Package perl-PAR-Dist.noarch 0:0.46-1.el5.rf set to be updated
---> Package perl-Parse-CPAN-Meta.noarch 0:1.40-1.el5.rf set to be updated
---> Package perl-YAML-Tiny.noarch 0:1.40-1.el5.rf set to be updated
--> Running transaction check
---> Package perl-ExtUtils-CBuilder.noarch 0:0.2603.01-1.el5.rf set to be updated
---> Package perl-Module-Install.noarch 0:0.92-1.el5.rf set to be updated
--> Processing Dependency: perl(Archive::Tar) >= 1.44 for package: perl-Module-Install
---> Package perl-version.i386 0:0.91-1.el5.rf set to be updated
--> Finished Dependency Resolution
perl-Module-Install-0.92-1.el5.rf.noarch from rpmforge has depsolving problems
  --> Missing Dependency: perl(Archive::Tar) >= 1.44 is needed by package perl-Module-Install-0.92-1.el5.rf.noarch (rpmforge)
Error: Missing Dependency: perl(Archive::Tar) >= 1.44 is needed by package perl-Module-Install-0.92-1.el5.rf.noarch (rpmforge)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

请高手帮助,谢谢!!!

论坛徽章:
13
15-16赛季CBA联赛之同曦
日期:2016-01-28 19:52:032015亚冠之北京国安
日期:2015-10-07 14:28:19NBA常规赛纪念章
日期:2015-05-04 22:32:03处女座
日期:2015-01-15 19:45:44卯兔
日期:2014-10-28 16:17:14白羊座
日期:2014-05-24 15:10:46寅虎
日期:2014-05-10 09:50:35白羊座
日期:2014-03-12 20:52:17午马
日期:2014-03-01 08:37:27射手座
日期:2014-02-19 19:26:54子鼠
日期:2013-11-30 09:03:56狮子座
日期:2013-09-08 08:37:52
发表于 2012-07-24 14:04 |显示全部楼层
Missing Dependency: perl(Archive::Tar) >= 1.44 is needed by package perl-Module-Install-0.92-1.el5.rf.noarch (rpmforge)
Error: Missing Dependency: perl(Archive::Tar) >= 1.44 is needed by package perl-Module-Install-0.92-1.el5.rf.noarch (rpmforge)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.


照着说明 执行一下命令

论坛徽章:
21
白羊座
日期:2013-08-23 15:49:17金牛座
日期:2013-10-08 17:00:03处女座
日期:2013-10-12 11:54:11CU十二周年纪念徽章
日期:2013-10-24 15:41:34午马
日期:2013-11-27 14:07:21巨蟹座
日期:2013-12-04 10:56:03水瓶座
日期:2013-12-04 15:58:00亥猪
日期:2014-05-24 16:02:3115-16赛季CBA联赛之辽宁
日期:2016-11-07 13:52:53戌狗
日期:2013-08-23 16:15:31白羊座
日期:2013-08-24 21:59:24巨蟹座
日期:2013-08-25 16:34:24
发表于 2012-07-24 14:05 |显示全部楼层
你用最后面说的,试一下
The program package-cleanup is found in the yum-utils package.


You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

论坛徽章:
0
发表于 2012-07-24 14:11 |显示全部楼层
本帖最后由 wushuangri 于 2012-07-24 14:21 编辑

按照上面提示:
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

做了。再次安装问题依旧!请高手帮助

论坛徽章:
13
15-16赛季CBA联赛之同曦
日期:2016-01-28 19:52:032015亚冠之北京国安
日期:2015-10-07 14:28:19NBA常规赛纪念章
日期:2015-05-04 22:32:03处女座
日期:2015-01-15 19:45:44卯兔
日期:2014-10-28 16:17:14白羊座
日期:2014-05-24 15:10:46寅虎
日期:2014-05-10 09:50:35白羊座
日期:2014-03-12 20:52:17午马
日期:2014-03-01 08:37:27射手座
日期:2014-02-19 19:26:54子鼠
日期:2013-11-30 09:03:56狮子座
日期:2013-09-08 08:37:52
发表于 2012-07-24 14:27 |显示全部楼层
回复 4# wushuangri


    perl 版本是不是太低了 升级一下! 提示说少个module

论坛徽章:
0
发表于 2012-07-24 15:55 |显示全部楼层
本帖最后由 wushuangri 于 2012-07-24 15:57 编辑

perl 升级到 5.16了还是会报错
perl-Module-Install-0.92-1.el5.rf.noarch from rpmforge has depsolving problems
  --> Missing Dependency: perl(Archive::Tar) >= 1.44 is needed by package perl-Module-Install-0.92-1.el5.rf.noarch (rpmforge)
Error: Missing Dependency: perl(Archive::Tar) >= 1.44 is needed by package perl-Module-Install-0.92-1.el5.rf.noarch (rpmforge)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
继续求教!!!请高手帮忙!!

论坛徽章:
0
发表于 2012-07-25 09:10 |显示全部楼层
哪位大侠能够帮助一下呢?? 等待!

论坛徽章:
13
15-16赛季CBA联赛之同曦
日期:2016-01-28 19:52:032015亚冠之北京国安
日期:2015-10-07 14:28:19NBA常规赛纪念章
日期:2015-05-04 22:32:03处女座
日期:2015-01-15 19:45:44卯兔
日期:2014-10-28 16:17:14白羊座
日期:2014-05-24 15:10:46寅虎
日期:2014-05-10 09:50:35白羊座
日期:2014-03-12 20:52:17午马
日期:2014-03-01 08:37:27射手座
日期:2014-02-19 19:26:54子鼠
日期:2013-11-30 09:03:56狮子座
日期:2013-09-08 08:37:52
发表于 2012-07-25 09:16 |显示全部楼层
本帖最后由 ulovko 于 2012-07-25 09:30 编辑

http://comments.gmane.org/gmane.linux.rpm.rpmforge.user/2791

论坛徽章:
0
发表于 2012-07-25 09:49 |显示全部楼层
非常感谢。 这个没弄清楚。哈哈。
我先做个测试看看能不能解决。

论坛徽章:
0
发表于 2012-07-25 10:11 |显示全部楼层
非常感谢! 我做个测试,看看结果怎么样。
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP