忘记密码   免费注册 查看新帖 | 论坛精华区

ChinaUnix.net

  平台 论坛 博客 认证专区 大话IT HPC论坛 徽章 文库 沙龙 自测 下载 频道自动化运维 虚拟化 储存备份 C/C++ PHP MySQL 嵌入式 Linux系统
最近访问板块 发新帖
查看: 3372 | 回复: 6

急!求助:redhat enterprise 5 + sybase的安装问题 [复制链接]

论坛徽章:
1
数据库技术版块每日发帖之星
日期:2016-07-09 06:20:00
发表于 2008-05-22 10:38 |显示全部楼层
操作系统:rehat enterprise 5
数据库:sybase ase 12.5.3(rpm包)

sybase的rpm包安装完成后,做:./srvbuild -r ./srvbuild.adaptive_server.rs时报错:
./srvbuild: relocation error: ./srvbuild: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

提示:glibc_2.0未定义,但用
[root@dbsrc lib]# nm /lib/libc.so.6|grep 'A GLIBC_2'|more
00000000 A GLIBC_2.0
00000000 A GLIBC_2.1
00000000 A GLIBC_2.1.1
...........
可以看到glibc_2.0

这是为什么?难道是glibc的版本太高的原因吗?

急!在线等,谢谢大家的帮助。

论坛徽章:
1
2017金鸡报晓
日期:2017-01-10 15:19:56
发表于 2008-05-22 10:56 |显示全部楼层
set LD_ASSUME_KERNEL=2.4.1

export LD_ASSUME_KERNEL

试试

论坛徽章:
1
数据库技术版块每日发帖之星
日期:2016-07-09 06:20:00
发表于 2008-05-22 11:12 |显示全部楼层

回复 #2 chuxu 的帖子

不行,还是一样的报错。

论坛徽章:
1
2015年辞旧岁徽章
日期:2015-03-03 16:54:15
发表于 2008-05-22 12:40 |显示全部楼层
原帖由 hellojan 于 2008-5-22 11:12 发表
不行,还是一样的报错。


别干了,

我试了 N 多次后放弃的。

用 15。0.2 吧

论坛徽章:
1
2017金鸡报晓
日期:2017-01-10 15:19:56
发表于 2008-05-22 14:39 |显示全部楼层
12.5.3 要求Linux x 86
Red Hat Enterprise Linux 4.0 update: 0
kernel -2.6.9-5.EL
glibc-2.3.4-2
你的glibc版本是否高了?

论坛徽章:
1
2015年辞旧岁徽章
日期:2015-03-03 16:54:15
发表于 2008-05-22 17:22 |显示全部楼层
原帖由 chuxu 于 2008-5-22 14:39 发表
12.5.3 要求Linux x 86
Red Hat Enterprise Linux 4.0 update: 0
kernel -2.6.9-5.EL
glibc-2.3.4-2
你的glibc版本是否高了?



12.5.x 的版本根本就不支持 i386 系列的 RHES 5.x

论坛徽章:
1
数据库技术版块每日发帖之星
日期:2016-07-09 06:20:00
发表于 2008-05-24 14:07 |显示全部楼层

回复 #6 snow888 的帖子

是的,最后没法子,操作系统的版降到rhes3,然后所有问题都迎刃而解。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号 北京市公安局海淀分局网监中心备案编号:11010802020122
广播电视节目制作经营许可证(京) 字第1234号 中国互联网协会会员  联系我们:
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP