免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 2280 | 回复: 0

[VMware] [Note] VMWARE+GNS3模拟EasyVPN实现 [复制链接]

论坛徽章:
0
发表于 2008-07-30 09:31 |显示全部楼层

               
v\:* {behavior:url(#default#VML);}
o\:* {behavior:url(#default#VML);}
w\:* {behavior:url(#default#VML);}
.shape {behavior:url(#default#VML);}

  Normal
  0
  
  
  false
  false
  false
  
   
   
   
   
   
   
  
  MicrosoftInternetExplorer4



/* Style Definitions */
table.MsoNormalTable
        {mso-style-name:"Table Normal";
        mso-tstyle-rowband-size:0;
        mso-tstyle-colband-size:0;
        mso-style-noshow:yes;
        mso-style-parent:"";
        mso-padding-alt:0in 5.4pt 0in 5.4pt;
        mso-para-margin:0in;
        mso-para-margin-bottom:.0001pt;
        mso-pagination:widow-orphan;
        font-size:10.0pt;
        font-family:"Times New Roman";
        mso-fareast-font-family:"Times New Roman";
        mso-ansi-language:#0400;
        mso-fareast-language:#0400;
        mso-bidi-language:#0400;}
1>VMWARE端配置
vmware应使用local-only类型的网卡链接到本地PC。

2>GNS3链接VMWARE配置
GNS3以NIO Ethernet方式链接到Vmware的local-only网卡。


  
  
  
  
  
  
  
  
  
  
  
  











3>实现原理及实验环境




因为VMWARE虚拟一个网卡的同时也虚拟了一个交换机,从而实现了左测的VMWARE虚拟网络。
GNS3使用NIO
Ethernet方式将其一个接口绑定到本地PC链接VMWARE的local-only接口,在系统实现时,它是以并行的方式发包的,就是本机PC和GNS3发送的包被从同一个虚拟接口发送(VMWARE的),但是相互间是分隔的,就好像是两个接口一样。

最终可以实现虚拟PC,本地PC,EzVPNServer_GNS3的相互通信。



4> EasyVPN Server配置
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
!
//定义认证及授权配置。
aaa authentication login authen local
aaa authorization network sense local
aaa authorization network autho local
!
aaa session-id common
!
resource policy
!
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip host a2 192.168.1.101
!
!
!
!
//定义XAUTH账号密码
username cisco password 0 cisco
!
!
!
crypto isakmp policy 10
encr 3des
authentication
pre-share
group 2
!
//定义用户组账号,密码及属性
crypto isakmp client configuration group sense
key cisco
pool sense-pool
acl split-acl
!
!
crypto ipsec transform-set mytrans esp-3des esp-sha-hmac
!
crypto dynamic-map dynmap 10
set transform-set
mytrans
//反向路由注入,强烈推荐配置,否则可能导致VPN链接后不能PING。即本地没有反回路由。
reverse-route   
!
!
crypto map mymap client authentication list authen
crypto map mymap isakmp authorization list autho
crypto map mymap client configuration address respond
crypto map mymap 10 ipsec-isakmp dynamic dynmap
!
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
ip address
10.10.10.254 255.255.255.0
duplex auto
speed auto
crypto map mymap
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address
192.168.1.1 255.255.255.0
serial restart-delay
0
no
dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay
0
no
dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay
0
no
dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay
0
no dce-terminal-timing-enable
!
router ospf 100
router-id 1.1.1.1
log-adjacency-changes
network 192.168.1.0
0.0.0.255 area 0
!
//定义远程连接用户被分配的IP地址池
ip local pool sense-pool 192.168.1.200 192.168.1.203
!
!
ip http server
no ip http secure-server
!
//split-acl定义哪些到远程客户端的流量需要被加密。用于VPN Server端。注意acl的源,目的顺序为反。
ip access-list extended split-acl
permit ip
192.168.1.200 0.0.0.3 any
deny   ip any any
!
!
!
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
End




5>VPN Client端配置


               
               
               
               
               

本文来自ChinaUnix博客,如果查看原文请点:http://blog.chinaunix.net/u/27493/showart_1096555.html
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

SACC2019中国系统架构师大会

【数字转型 架构演进】SACC2019中国系统架构师大会,8.5折限时优惠重磅来袭!
2019年10月31日~11月2日第11届中国系统架构师大会(SACC2019)将在北京隆重召开。四大主线并行的演讲模式,1个主会场、20个技术专场、超千人参与的会议规模,100+来自互联网、金融、制造业、电商等领域的嘉宾阵容,将为广大参会者提供一场最具价值的技术交流盛会。

限时8.5折扣期:2019年9月30日前


----------------------------------------

大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP