免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
12下一页
最近访问板块 发新帖
查看: 5348 | 回复: 11

地址池里只有一个IP能否NAT多台内网机器 [复制链接]

论坛徽章:
0
发表于 2009-01-09 11:27 |显示全部楼层
CISCO1841,地址池里只有一个外部IP,
做了静态NAT,只能有一个内部机器出去
Router(config)#ip nat inside source static 192.168.1.15 172.16.1.10
怎么配置可以让多台机器都NAT出去呢?

论坛徽章:
4
技术图书徽章
日期:2014-02-07 08:37:30摩羯座
日期:2014-02-13 14:33:55处女座
日期:2014-02-21 08:27:48NBA常规赛纪念章
日期:2015-05-04 22:32:03
发表于 2009-01-09 11:31 |显示全部楼层
做个地址池,然后动态nat

论坛徽章:
5
IT运维版块每日发帖之星
日期:2015-08-06 06:20:00IT运维版块每日发帖之星
日期:2015-08-10 06:20:00IT运维版块每日发帖之星
日期:2015-08-23 06:20:00IT运维版块每日发帖之星
日期:2015-08-24 06:20:00IT运维版块每日发帖之星
日期:2015-11-12 06:20:00
发表于 2009-01-09 11:33 |显示全部楼层
不过静态一对一NAT,做服务器发布。

论坛徽章:
5
IT运维版块每日发帖之星
日期:2015-08-06 06:20:00IT运维版块每日发帖之星
日期:2015-08-10 06:20:00IT运维版块每日发帖之星
日期:2015-08-23 06:20:00IT运维版块每日发帖之星
日期:2015-08-24 06:20:00IT运维版块每日发帖之星
日期:2015-11-12 06:20:00
发表于 2009-01-09 11:33 |显示全部楼层
不做。

论坛徽章:
0
发表于 2009-01-09 11:40 |显示全部楼层
Router(config)#access-list 15 permit 192.168.0.0 0.0.255.255
Router(config)#ip nat pool NATPOOL 172.16.4.10 172.16.4.10 netmask 255.255.255.0
Router(config)#ip nat inside source list 15 pool NATPOOL
Router(config)#interface FastEthernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#exit
Router(config)#interface FastEthernet 0/1
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#exit
Router(config)#interface Ethernet1/0
Router(config-if)#ip address 172.16.1.2 255.255.255.0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#end
Router#

NAT池中的IP和出口的IP不在同一网段上,只有一个IP.

按这样做动态NAT的时候,也是同时只能一台机器出去.

论坛徽章:
3
辰龙
日期:2013-11-20 23:03:57子鼠
日期:2014-05-26 14:46:482015年亚洲杯之伊拉克
日期:2015-01-30 14:29:38
发表于 2009-01-09 11:41 |显示全部楼层
原帖由 jxfhp 于 2009-1-9 11:31 发表
做个地址池,然后动态nat

对了,然后你那个镜头的是服务器吗,是的话就做个静态端口映射

论坛徽章:
3
辰龙
日期:2013-11-20 23:03:57子鼠
日期:2014-05-26 14:46:482015年亚洲杯之伊拉克
日期:2015-01-30 14:29:38
发表于 2009-01-09 11:42 |显示全部楼层
原帖由 xiaojao 于 2009-1-9 11:40 发表
Router(config)#access-list 15 permit 192.168.0.0 0.0.255.255
Router(config)#ip nat pool NATPOOL 172.16.4.10 172.16.4.10 netmask 255.255.255.0
Router(config)#ip nat inside source list 15 pool  ...

要overload

论坛徽章:
0
发表于 2009-01-09 11:46 |显示全部楼层
没有发现Overload选项,倒是 type rotary的选项
version 12.4

论坛徽章:
0
发表于 2009-01-09 11:47 |显示全部楼层
原帖由 seven007 于 2009-1-9 11:41 发表

对了,然后你那个镜头的是服务器吗,是的话就做个静态端口映射



内网没有服务器,是客户端

论坛徽章:
3
辰龙
日期:2013-11-20 23:03:57子鼠
日期:2014-05-26 14:46:482015年亚洲杯之伊拉克
日期:2015-01-30 14:29:38
发表于 2009-01-09 11:53 |显示全部楼层
ip nat inside source list 15 pool NATPOOL overload
我12.3都可以
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

DTCC2020中国数据库技术大会

【架构革新 高效可控】2020年12月21日-23日第十一届中国数据库技术大会将在北京隆重召开。

大会设置2大主会场,20+技术专场,将邀请超百位行业专家,重点围绕数据架构、AI与大数据、传统企业数据库实践和国产开源数据库等内容展开分享和探讨,为广大数据领域从业人士提供一场年度盛会和交流平台。

http://dtcc.it168.com


大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP