免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 2501 | 回复: 5

apt报错 [复制链接]

论坛徽章:
0
发表于 2009-08-03 16:50 |显示全部楼层
系统Debian lenny
错误信息如下:
E: 软件包 adobe-flashplugin 需要重新安装,但是我无法找到相应的安装文件。
我不是问怎么安装adobe-flashplugin的,只是想问下,怎么别让apt包管理程序宕在这里,不干事情了。
例如:
arnk@debian4arnk:~/bak$ sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 软件包 adobe-flashplugin 需要重新安装,但是我无法找到相应的安装文件。

宕在这里
又例如:
arnk@debian4arnk:~/bak$ sudo apt-get install netbeans
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 软件包 adobe-flashplugin 需要重新安装,但是我无法找到相应的安装文件。

又宕在这里
这样apt就不能用了呀!能不能不让它管这个软件的事了,然后照常工作,不能因为这个错误影响到全局阿!
但是事实上我已经安装好了adobe-flashplugin,是通过下载官网的.gz文件,然后解压到指定目录安装好的,iceweasel也已经显示了。

kao
我发现这还不是最要命的,
如:
arnk@debian4arnk:~$ sudo dpkg -l | grep flash
iFR adobe-flashplugin                    10.0.32.18-1                 Adobe Flash Player plugin version 10
arnk@debian4arnk:~$ sudo apt-get --purge remove adobe-flashplugin
正在读取软件包列表... 完成
正在分析软件包的依赖关系树     
正在读取状态信息... 完成     
E: 软件包 adobe-flashplugin 需要重新安装,但是我无法找到相应的安装文件。

想将其卸载也不行了。我该怎么办?

[ 本帖最后由 arnk 于 2009-8-3 16:56 编辑 ]

论坛徽章:
0
发表于 2009-08-03 16:53 |显示全部楼层
借shell版的人气问个问题哈

论坛徽章:
0
发表于 2009-08-03 18:23 |显示全部楼层
Some times you might see the following error message when you try to install any package using apt-get or synaptic
E: The package webmin needs to be reinstalled, but I can’t find an archive for it.

E: The package mfc8500lpr needs to be reinstalled, but I can’t find an archive for it.

This error might be with any package in the above examples webmin and mfc8500lpr packages this error mostly occour when you try to install a debian package in to ubuntu system

Error

E: The package package name needs to be reinstalled, but I can’t find an archive for it.

Package name in the above error could be any package

Solution

Run the following command

For webmin Pakage

dpkg --remove --force-remove-reinstreq webmin

You can replace webmin to any of your package name which is giving the error
上面所说的似乎和我的情况类似,但我执行dpkg --remove --force-remove-reinstreq adobe-flashplugin后依然让我崩溃。问题的原因是我在我的debian系统上安装了一个用于ubuntu系统的flashplugin的deb包,导致了这个问题。
dpkg:警告:由于开启了 --force 选项,以下问题被忽略:该软件包现在的状态极为不妥 - 您最好能在删除它之前再重新安装一次。(正在读取数据库 ... 系统当前总共安装有 93095 个文件和目录。)正在删除 adobe-flashplugin ...update-alternatives: error: 无 iceape-flashplugin 的替换项。update-alternatives: error: 无 iceape-flashplugin 的替换项。dpkg:处理 adobe-flashplugin (--purge)时出错:子进程 已安装的 pre-removal 脚本 返回了错误号 2postinst called with argument `abort-remove'dpkg: 作下列清理工作时发生错误:子进程 已安装的 post-installation 脚本 返回了错误号 1在处理时有错误发生:adobe-flashplugin

论坛徽章:
0
发表于 2009-08-03 19:02 |显示全部楼层
该软件包既不能重装又不能删除,但是apt非得重装它才能继续工作,而我只有删除它才能让apt正常工作。
于是我妥协去重装它,cao!这个包是用于ubuntu的,它是默认去找firefox,debian上没有firefox,只有替代物iceweasel,我再想为什么apt你不妥协呢?

论坛徽章:
0
发表于 2009-08-03 19:49 |显示全部楼层
终于在一个国外论坛上找到了解决方法
rm -rf /var/lib/info/adobe-flashplugin*
然后在执行
sudo dpkg --remove --force-remove-reinstreq adobe-flashplugin
求人不如求己!

论坛徽章:
1
巨蟹座
日期:2014-06-04 13:33:30
发表于 2009-08-03 23:05 |显示全部楼层
有空试一下aptitude
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

SACC2019中国系统架构师大会

【数字转型 架构演进】SACC2019中国系统架构师大会,7折限时优惠重磅来袭!
2019年10月31日~11月2日第11届中国系统架构师大会(SACC2019)将在北京隆重召开。四大主线并行的演讲模式,1个主会场、20个技术专场、超千人参与的会议规模,100+来自互联网、金融、制造业、电商等领域的嘉宾阵容,将为广大参会者提供一场最具价值的技术交流盛会。

限时七折期:2019年8月31日前


----------------------------------------

大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP