免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 6121 | 回复: 9

郁闷的一天 arcsde93 for oracle10204安装 [复制链接]

论坛徽章:
0
发表于 2010-07-13 19:51 |显示全部楼层
今天真郁闷,试了很多次了!还是报这个错。


以下是在hp   dl580上的redhat as 5.5 x64上安装arcgis9.3.1 时的报错。找了很久解决不了,有空帮我看看。谢谢!

[arcsde@szdb1 ~]$ sdesetup -o install -d ORACLE10G -p sde

ESRI ArcSDE Server Setup Utility Fri Aug 21 19:11:58 2009
----------------------------------------------------------------
Install or update ArcSDE, GDB schema objects:
  Are you sure? (Y/N): y
Creating ArcSde schema.....
Error: Underlying DBMS error (-51).
Error: SDE release install not completed.
        Check SDEHOME\etc\sde_setup.log for more details.

这是sde_setup.log日志内容:
[Fri Aug 21 19:12:00 2009] DB_open_instance()::db_connect (OCI error: -1
[Fri Aug 21 19:12:00 2009] Error: Underlying DBMS error (-51).
[Fri Aug 21 19:12:00 2009] Error: Unable to connect
[Fri Aug 21 19:12:00 2009] DBMS error (-1)
[Fri Aug 21 19:12:00 2009] ERROR installing/upgrading ArcSDE, Error = -51

   以前在solaris10u9上安装过,没有出现过这个问题。希望知道的人,不吝赐教,多谢!!

论坛徽章:
59
2015七夕节徽章
日期:2015-08-24 11:17:25ChinaUnix专家徽章
日期:2015-07-20 09:19:30每周论坛发贴之星
日期:2015-07-20 09:19:42ChinaUnix元老
日期:2015-07-20 11:04:38荣誉版主
日期:2015-07-20 11:05:19巳蛇
日期:2015-07-20 11:05:26CU十二周年纪念徽章
日期:2015-07-20 11:05:27IT运维版块每日发帖之星
日期:2015-07-20 11:05:34操作系统版块每日发帖之星
日期:2015-07-20 11:05:36程序设计版块每日发帖之星
日期:2015-07-20 11:05:40数据库技术版块每日发帖之星
日期:2015-07-20 11:05:432015年辞旧岁徽章
日期:2015-07-20 11:05:44
发表于 2010-07-13 20:26 |显示全部楼层
帮你顶,这个东西我没有接触啊。

论坛徽章:
3
CU大牛徽章
日期:2013-09-18 15:16:55CU大牛徽章
日期:2013-09-18 15:18:22CU大牛徽章
日期:2013-09-18 15:18:43
发表于 2010-07-14 08:24 |显示全部楼层
这是oracle版   哥们儿是不是弄错地方了

论坛徽章:
0
发表于 2010-07-15 00:16 |显示全部楼层
显然美错,这个是在oracle10g_x64下的环境。

论坛徽章:
3
CU大牛徽章
日期:2013-09-18 15:16:55CU大牛徽章
日期:2013-09-18 15:18:22CU大牛徽章
日期:2013-09-18 15:18:43
发表于 2010-07-15 08:35 |显示全部楼层
哦   那就是俺弄错了  呵呵呵

论坛徽章:
59
2015七夕节徽章
日期:2015-08-24 11:17:25ChinaUnix专家徽章
日期:2015-07-20 09:19:30每周论坛发贴之星
日期:2015-07-20 09:19:42ChinaUnix元老
日期:2015-07-20 11:04:38荣誉版主
日期:2015-07-20 11:05:19巳蛇
日期:2015-07-20 11:05:26CU十二周年纪念徽章
日期:2015-07-20 11:05:27IT运维版块每日发帖之星
日期:2015-07-20 11:05:34操作系统版块每日发帖之星
日期:2015-07-20 11:05:36程序设计版块每日发帖之星
日期:2015-07-20 11:05:40数据库技术版块每日发帖之星
日期:2015-07-20 11:05:432015年辞旧岁徽章
日期:2015-07-20 11:05:44
发表于 2010-07-15 08:44 |显示全部楼层
arcgis9.3.1是个什么东西。是不是他的数据库需要的是ORACLE。你得看看这个软件对数据库版本有没有特殊要求。

论坛徽章:
59
2015七夕节徽章
日期:2015-08-24 11:17:25ChinaUnix专家徽章
日期:2015-07-20 09:19:30每周论坛发贴之星
日期:2015-07-20 09:19:42ChinaUnix元老
日期:2015-07-20 11:04:38荣誉版主
日期:2015-07-20 11:05:19巳蛇
日期:2015-07-20 11:05:26CU十二周年纪念徽章
日期:2015-07-20 11:05:27IT运维版块每日发帖之星
日期:2015-07-20 11:05:34操作系统版块每日发帖之星
日期:2015-07-20 11:05:36程序设计版块每日发帖之星
日期:2015-07-20 11:05:40数据库技术版块每日发帖之星
日期:2015-07-20 11:05:432015年辞旧岁徽章
日期:2015-07-20 11:05:44
发表于 2010-07-15 08:46 |显示全部楼层
ESRI ArcSDE Server Setup Utility Thu Mar 04 18:18:39 2010
----------------------------------------------------------------
Creating ArcSde schema.....
Successfully created ArcSde schema.

Installing locators.....
Successfully installed locators.

Creating geodatabase schema.....
Error: Underlying DBMS error (-51).
Error: Error installing GDB schema.
Error: Underlying DBMS error (-51).
Error: Geodatabase schema object install not completed.
Check SDEHOME\etc\sde_setup.log or
SDEHOME\etc\sde_dc<rdbms>.log for more details..

*******************************************

说以上问题是由于版本不兼容问题引起。oracle要10g r2的。不过sde的post程序确实明明白白的说了 for oracle r2(我用的是arcSDE9.3)


本文来自CSDN博客,转载请标明出处:http://blog.csdn.net/zzh_my/archive/2010/03/04/5346890.aspx

论坛徽章:
0
发表于 2010-11-18 18:03 |显示全部楼层
哦 这个问题早解决了!

不是版本的问题,后来再折腾了几把,就好了,找不出原因!

论坛徽章:
0
发表于 2015-04-08 16:11 |显示全部楼层
你好,我遇到了和你一样的问题,你现在会不会解决?

论坛徽章:
0
发表于 2015-04-08 16:12 |显示全部楼层
回复 8# lq2003


    你好,我遇到了和你一样的问题,你现在会不会解决?
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP