免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 3016 | 回复: 8

mpg123编译问题 [复制链接]

论坛徽章:
0
发表于 2011-01-04 11:24 |显示全部楼层
源码编译mpg123的过程中出现了这样的问题:

$ ./configure --prefix=/usr --with-audio=alsa

error: ALSA is not available for audio output subsystem

论坛徽章:
0
发表于 2011-01-05 21:59 |显示全部楼层
查了下./configure  --help ,根本没有--with-alsa这个命令

论坛徽章:
0
发表于 2011-01-06 09:55 |显示全部楼层
在ubuntu下有俩中音频驱动,一种是OSS,另一种就是alsa,系统默认的是OSS,我想应该是mpg123需要的是alsa音频驱动,所以才会需要指定。
   configure报错,显然是因为少装了有关alsa的lib了把

论坛徽章:
0
发表于 2011-01-06 10:15 |显示全部楼层
回复 3# kenzo_zhu


    那我們之前装madplay時,可以指定configure --with-alsa的呀。

论坛徽章:
0
发表于 2011-01-06 14:02 |显示全部楼层
回复 2# 0602_hua


    --with-audio这是一个参数选项,不是一个命令!

论坛徽章:
0
发表于 2011-01-06 14:08 |显示全部楼层
在ubuntu下有俩中音频驱动,一种是OSS,另一种就是alsa,系统默认的是OSS,我想应该是mpg123需要的是alsa音 ...
kenzo_zhu 发表于 2011-01-06 09:55



    应该说是Linux系统中有二种音频驱动。其中alsa驱动,需要alsa库,即libasound.   

./configure若未指定输出设备,则自动检测;若存在alsa库,则默认输出设备为ALSA设备,若alsa库不存在,则为OSS设备。

论坛徽章:
0
发表于 2011-01-06 14:19 |显示全部楼层
回复 6# taoxie17

这个好,受用了。

论坛徽章:
0
发表于 2011-01-06 14:22 |显示全部楼层
回复 5# taoxie17

嗯,没有这个参数,所以,不能用./configure --with-alsa这个命令。

论坛徽章:
0
发表于 2013-10-10 20:55 |显示全部楼层
了解了解、、、、、
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP