免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 3021 | 回复: 5

Ubuntu 安装emacs23的一个问题:(五岳之颠请进) [复制链接]

论坛徽章:
0
发表于 2010-03-27 11:52 |显示全部楼层
本帖最后由 tsyj2007 于 2010-03-27 11:57 编辑

第一次安装的emacs22,卸载后又装的emacs23,安装出错,不知道咋回事???

论坛徽章:
0
发表于 2010-03-27 14:15 |显示全部楼层
不是用包管理器安装的吗?

论坛徽章:
0
发表于 2010-03-27 21:55 |显示全部楼层
回复 2# emmoblin


    是阿。。。用新立德安装的阿....

论坛徽章:
2
IT运维版块每日发帖之星
日期:2015-06-26 22:20:00IT运维版块每日发帖之星
日期:2015-06-29 22:20:00
发表于 2010-03-28 19:31 |显示全部楼层
回复 1# tsyj2007


    贴出详细错误吧。大家都来看看。

论坛徽章:
0
发表于 2010-03-28 21:57 |显示全部楼层
本帖最后由 tsyj2007 于 2010-03-28 22:10 编辑

错误如下:
  1. installArchives() failed: 选中了曾被取消选择的软件包 emacsen-common。

  2. (正在读取数据库 ...
  3. (正在读取数据库 ... 5%
  4. (正在读取数据库 ... 10%
  5. (正在读取数据库 ... 15%
  6. (正在读取数据库 ... 20%
  7. (正在读取数据库 ... 25%
  8. (正在读取数据库 ... 30%
  9. (正在读取数据库 ... 35%
  10. (正在读取数据库 ... 40%
  11. (正在读取数据库 ... 45%
  12. (正在读取数据库 ... 50%
  13. (正在读取数据库 ... 55%
  14. (正在读取数据库 ... 60%
  15. (正在读取数据库 ... 65%
  16. (正在读取数据库 ... 70%
  17. (正在读取数据库 ... 75%
  18. (正在读取数据库 ... 80%
  19. (正在读取数据库 ... 85%
  20. (正在读取数据库 ... 90%
  21. (正在读取数据库 ... 95%
  22. (正在读取数据库 ... 100%
  23. (正在读取数据库 ... 系统当前总共安装有 156125 个文件和目录。)

  24. 正在解压缩 emacsen-common (从 .../emacsen-common_1.4.19ubuntu1_all.deb) ...

  25. 选中了曾被取消选择的软件包 emacs23-common。

  26. 正在解压缩 emacs23-common (从 .../emacs23-common_23.1+1-4ubuntu3.1_all.deb) ...

  27. 选中了曾被取消选择的软件包 emacs23-bin-common。

  28. 正在解压缩 emacs23-bin-common (从 .../emacs23-bin-common_23.1+1-4ubuntu3.1_i386.deb) ...

  29. 选中了曾被取消选择的软件包 emacs23。

  30. 正在解压缩 emacs23 (从 .../emacs23_23.1+1-4ubuntu3.1_i386.deb) ...

  31. 正在处理用于 install-info 的触发器...

  32. install-info:警告: “/usr/share/info/menu.info.gz”中没有 info 目录条目

  33. 正在处理用于 man-db 的触发器...

  34. 正在处理用于 desktop-file-utils 的触发器...

  35. 正在处理用于 hicolor-icon-theme 的触发器...

  36. 正在处理用于 menu 的触发器...

  37. 正在设置 emacsen-common (1.4.19ubuntu1) ...

  38. emacsen-common: Handling install of emacsen flavor emacs

  39. Ignoring install-info called from maintainer script

  40. The package emacsen-common should be rebuild with new debhelper to get trigger support



  41. 正在设置 emacs23-common (23.1+1-4ubuntu3.1) ...

  42. Ignoring install-info called from maintainer script

  43. The package emacs23-common should be rebuild with new debhelper to get trigger support

  44. Ignoring install-info called from maintainer script

  45. The package emacs23-common should be rebuild with new debhelper to get trigger support

  46. Ignoring install-info called from maintainer script

  47. The package emacs23-common should be rebuild with new debhelper to get trigger support

  48. Ignoring install-info called from maintainer script

  49. The package emacs23-common should be rebuild with new debhelper to get trigger support

  50. Ignoring install-info called from maintainer script

  51. The package emacs23-common should be rebuild with new debhelper to get trigger support

  52. Ignoring install-info called from maintainer script

  53. The package emacs23-common should be rebuild with new debhelper to get trigger support

  54. Ignoring install-info called from maintainer script

  55. The package emacs23-common should be rebuild with new debhelper to get trigger support

  56. Ignoring install-info called from maintainer script

  57. The package emacs23-common should be rebuild with new debhelper to get trigger support

  58. Ignoring install-info called from maintainer script

  59. The package emacs23-common should be rebuild with new debhelper to get trigger support

  60. Ignoring install-info called from maintainer script

  61. The package emacs23-common should be rebuild with new debhelper to get trigger support

  62. Ignoring install-info called from maintainer script

  63. The package emacs23-common should be rebuild with new debhelper to get trigger support

  64. Ignoring install-info called from maintainer script

  65. The package emacs23-common should be rebuild with new debhelper to get trigger support

  66. Ignoring install-info called from maintainer script

  67. The package emacs23-common should be rebuild with new debhelper to get trigger support

  68. Ignoring install-info called from maintainer script

  69. The package emacs23-common should be rebuild with new debhelper to get trigger support

  70. Ignoring install-info called from maintainer script

  71. The package emacs23-common should be rebuild with new debhelper to get trigger support

  72. Ignoring install-info called from maintainer script

  73. The package emacs23-common should be rebuild with new debhelper to get trigger support

  74. Ignoring install-info called from maintainer script

  75. The package emacs23-common should be rebuild with new debhelper to get trigger support

  76. Ignoring install-info called from maintainer script

  77. The package emacs23-common should be rebuild with new debhelper to get trigger support

  78. Ignoring install-info called from maintainer script

  79. The package emacs23-common should be rebuild with new debhelper to get trigger support

  80. Ignoring install-info called from maintainer script

  81. The package emacs23-common should be rebuild with new debhelper to get trigger support

  82. Ignoring install-info called from maintainer script

  83. The package emacs23-common should be rebuild with new debhelper to get trigger support

  84. Ignoring install-info called from maintainer script

  85. The package emacs23-common should be rebuild with new debhelper to get trigger support

  86. Ignoring install-info called from maintainer script

  87. The package emacs23-common should be rebuild with new debhelper to get trigger support

  88. Ignoring install-info called from maintainer script

  89. The package emacs23-common should be rebuild with new debhelper to get trigger support

  90. Ignoring install-info called from maintainer script

  91. The package emacs23-common should be rebuild with new debhelper to get trigger support

  92. Ignoring install-info called from maintainer script

  93. The package emacs23-common should be rebuild with new debhelper to get trigger support

  94. Ignoring install-info called from maintainer script

  95. The package emacs23-common should be rebuild with new debhelper to get trigger support

  96. Ignoring install-info called from maintainer script

  97. The package emacs23-common should be rebuild with new debhelper to get trigger support

  98. Ignoring install-info called from maintainer script

  99. The package emacs23-common should be rebuild with new debhelper to get trigger support

  100. Ignoring install-info called from maintainer script

  101. The package emacs23-common should be rebuild with new debhelper to get trigger support

  102. Ignoring install-info called from maintainer script

  103. The package emacs23-common should be rebuild with new debhelper to get trigger support

  104. Ignoring install-info called from maintainer script

  105. The package emacs23-common should be rebuild with new debhelper to get trigger support

  106. Ignoring install-info called from maintainer script

  107. The package emacs23-common should be rebuild with new debhelper to get trigger support

  108. Ignoring install-info called from maintainer script

  109. The package emacs23-common should be rebuild with new debhelper to get trigger support

  110. Ignoring install-info called from maintainer script

  111. The package emacs23-common should be rebuild with new debhelper to get trigger support

  112. Ignoring install-info called from maintainer script

  113. The package emacs23-common should be rebuild with new debhelper to get trigger support

  114. Ignoring install-info called from maintainer script

  115. The package emacs23-common should be rebuild with new debhelper to get trigger support

  116. Ignoring install-info called from maintainer script

  117. The package emacs23-common should be rebuild with new debhelper to get trigger support

  118. Ignoring install-info called from maintainer script

  119. The package emacs23-common should be rebuild with new debhelper to get trigger support

  120. Ignoring install-info called from maintainer script

  121. The package emacs23-common should be rebuild with new debhelper to get trigger support

  122. Ignoring install-info called from maintainer script

  123. The package emacs23-common should be rebuild with new debhelper to get trigger support

  124. Ignoring install-info called from maintainer script

  125. The package emacs23-common should be rebuild with new debhelper to get trigger support

  126. Ignoring install-info called from maintainer script

  127. The package emacs23-common should be rebuild with new debhelper to get trigger support

  128. Ignoring install-info called from maintainer script

  129. The package emacs23-common should be rebuild with new debhelper to get trigger support

  130. Ignoring install-info called from maintainer script

  131. The package emacs23-common should be rebuild with new debhelper to get trigger support

  132. Ignoring install-info called from maintainer script

  133. The package emacs23-common should be rebuild with new debhelper to get trigger support

  134. Ignoring install-info called from maintainer script

  135. The package emacs23-common should be rebuild with new debhelper to get trigger support

  136. Ignoring install-info called from maintainer script

  137. The package emacs23-common should be rebuild with new debhelper to get trigger support

  138. Ignoring install-info called from maintainer script

  139. The package emacs23-common should be rebuild with new debhelper to get trigger support

  140. Ignoring install-info called from maintainer script

  141. The package emacs23-common should be rebuild with new debhelper to get trigger support



  142. 正在设置 emacs23-bin-common (23.1+1-4ubuntu3.1) ...

  143. update-alternatives: 使用 /usr/bin/b2m.emacs23 来提供 /usr/bin/b2m (b2m),于 自动模式 中。

  144. update-alternatives: 使用 /usr/bin/ebrowse.emacs23 来提供 /usr/bin/ebrowse (ebrowse),于 自动模式 中。

  145. update-alternatives: 使用 /usr/bin/emacsclient.emacs23 来提供 /usr/bin/emacsclient (emacsclient),于 自动模式 中。

  146. update-alternatives: 使用 /usr/bin/grep-changelog.emacs23 来提供 /usr/bin/grep-changelog (grep-changelog),于 自动模式 中。

  147. update-alternatives: 使用 /usr/bin/rcs-checkin.emacs23 来提供 /usr/bin/rcs-checkin (rcs-checkin),于 自动模式 中。



  148. 正在设置 emacs23 (23.1+1-4ubuntu3.1) ...

  149. update-alternatives: 使用 /usr/bin/emacs23-x 来提供 /usr/bin/emacs (emacs),于 自动模式 中。

  150. emacs-install emacs23

  151. install/cscope: Byte-compiling for emacs23

  152. cp: 无法 stat “xscope.el”: 没有该文件或目录

  153. >>Error occurred processing xscope.el: File error (("Opening input file" "没有该文件或目录" "/usr/share/emacs23/site-lisp/cscope/xscope.el"))

  154. install/dictionaries-common: Byte-compiling for emacsen flavour emacs23

  155. >>Error occurred processing debian-ispell.el: File error (("Opening input file" "没有该文件或目录" "/usr/share/emacs23/site-lisp/dictionaries-common/debian-ispell.el"))

  156. >>Error occurred processing ispell.el: File error (("Opening input file" "没有该文件或目录" "/usr/share/emacs23/site-lisp/dictionaries-common/ispell.el"))

  157. >>Error occurred processing flyspell.el: File error (("Opening input file" "没有该文件或目录" "/usr/share/emacs23/site-lisp/dictionaries-common/flyspell.el"))

  158. emacs-install: /usr/lib/emacsen-common/packages/install/dictionaries-common emacs23 failed at /usr/lib/emacsen-common/emacs-install line 28, <TSORT> line 4.

  159. dpkg:处理 emacs23 (--configure)时出错:

  160. 子进程 已安装的 post-installation 脚本 返回了错误号 1

  161. 在处理时有错误发生:

  162. emacs23

复制代码

论坛徽章:
0
发表于 2010-03-28 21:59 |显示全部楼层
回复 4# 五岳之巅
  1. installArchives() failed: 选中了曾被取消选择的软件包 emacsen-common。

  2. (正在读取数据库 ...
  3. (正在读取数据库 ... 5%
  4. (正在读取数据库 ... 10%
  5. (正在读取数据库 ... 15%
  6. (正在读取数据库 ... 20%
  7. (正在读取数据库 ... 25%
  8. (正在读取数据库 ... 30%
  9. (正在读取数据库 ... 35%
  10. (正在读取数据库 ... 40%
  11. (正在读取数据库 ... 45%
  12. (正在读取数据库 ... 50%
  13. (正在读取数据库 ... 55%
  14. (正在读取数据库 ... 60%
  15. (正在读取数据库 ... 65%
  16. (正在读取数据库 ... 70%
  17. (正在读取数据库 ... 75%
  18. (正在读取数据库 ... 80%
  19. (正在读取数据库 ... 85%
  20. (正在读取数据库 ... 90%
  21. (正在读取数据库 ... 95%
  22. (正在读取数据库 ... 100%
  23. (正在读取数据库 ... 系统当前总共安装有 156125 个文件和目录。)

  24. 正在解压缩 emacsen-common (从 .../emacsen-common_1.4.19ubuntu1_all.deb) ...

  25. 选中了曾被取消选择的软件包 emacs23-common。

  26. 正在解压缩 emacs23-common (从 .../emacs23-common_23.1+1-4ubuntu3.1_all.deb) ...

  27. 选中了曾被取消选择的软件包 emacs23-bin-common。

  28. 正在解压缩 emacs23-bin-common (从 .../emacs23-bin-common_23.1+1-4ubuntu3.1_i386.deb) ...

  29. 选中了曾被取消选择的软件包 emacs23。

  30. 正在解压缩 emacs23 (从 .../emacs23_23.1+1-4ubuntu3.1_i386.deb) ...

  31. 正在处理用于 install-info 的触发器...

  32. install-info:警告: “/usr/share/info/menu.info.gz”中没有 info 目录条目

  33. 正在处理用于 man-db 的触发器...

  34. 正在处理用于 desktop-file-utils 的触发器...

  35. 正在处理用于 hicolor-icon-theme 的触发器...

  36. 正在处理用于 menu 的触发器...

  37. 正在设置 emacsen-common (1.4.19ubuntu1) ...

  38. emacsen-common: Handling install of emacsen flavor emacs

  39. Ignoring install-info called from maintainer script

  40. The package emacsen-common should be rebuild with new debhelper to get trigger support



  41. 正在设置 emacs23-common (23.1+1-4ubuntu3.1) ...

  42. Ignoring install-info called from maintainer script

  43. The package emacs23-common should be rebuild with new debhelper to get trigger support

  44. Ignoring install-info called from maintainer script

  45. The package emacs23-common should be rebuild with new debhelper to get trigger support

  46. Ignoring install-info called from maintainer script

  47. The package emacs23-common should be rebuild with new debhelper to get trigger support

  48. Ignoring install-info called from maintainer script

  49. The package emacs23-common should be rebuild with new debhelper to get trigger support

  50. Ignoring install-info called from maintainer script

  51. The package emacs23-common should be rebuild with new debhelper to get trigger support

  52. Ignoring install-info called from maintainer script

  53. The package emacs23-common should be rebuild with new debhelper to get trigger support

  54. Ignoring install-info called from maintainer script

  55. The package emacs23-common should be rebuild with new debhelper to get trigger support

  56. Ignoring install-info called from maintainer script

  57. The package emacs23-common should be rebuild with new debhelper to get trigger support

  58. Ignoring install-info called from maintainer script

  59. The package emacs23-common should be rebuild with new debhelper to get trigger support

  60. Ignoring install-info called from maintainer script

  61. The package emacs23-common should be rebuild with new debhelper to get trigger support

  62. Ignoring install-info called from maintainer script

  63. The package emacs23-common should be rebuild with new debhelper to get trigger support

  64. Ignoring install-info called from maintainer script

  65. The package emacs23-common should be rebuild with new debhelper to get trigger support

  66. Ignoring install-info called from maintainer script

  67. The package emacs23-common should be rebuild with new debhelper to get trigger support

  68. Ignoring install-info called from maintainer script

  69. The package emacs23-common should be rebuild with new debhelper to get trigger support

  70. Ignoring install-info called from maintainer script

  71. The package emacs23-common should be rebuild with new debhelper to get trigger support

  72. Ignoring install-info called from maintainer script

  73. The package emacs23-common should be rebuild with new debhelper to get trigger support

  74. Ignoring install-info called from maintainer script

  75. The package emacs23-common should be rebuild with new debhelper to get trigger support

  76. Ignoring install-info called from maintainer script

  77. The package emacs23-common should be rebuild with new debhelper to get trigger support

  78. Ignoring install-info called from maintainer script

  79. The package emacs23-common should be rebuild with new debhelper to get trigger support

  80. Ignoring install-info called from maintainer script

  81. The package emacs23-common should be rebuild with new debhelper to get trigger support

  82. Ignoring install-info called from maintainer script

  83. The package emacs23-common should be rebuild with new debhelper to get trigger support

  84. Ignoring install-info called from maintainer script

  85. The package emacs23-common should be rebuild with new debhelper to get trigger support

  86. Ignoring install-info called from maintainer script

  87. The package emacs23-common should be rebuild with new debhelper to get trigger support

  88. Ignoring install-info called from maintainer script

  89. The package emacs23-common should be rebuild with new debhelper to get trigger support

  90. Ignoring install-info called from maintainer script

  91. The package emacs23-common should be rebuild with new debhelper to get trigger support

  92. Ignoring install-info called from maintainer script

  93. The package emacs23-common should be rebuild with new debhelper to get trigger support

  94. Ignoring install-info called from maintainer script

  95. The package emacs23-common should be rebuild with new debhelper to get trigger support

  96. Ignoring install-info called from maintainer script

  97. The package emacs23-common should be rebuild with new debhelper to get trigger support

  98. Ignoring install-info called from maintainer script

  99. The package emacs23-common should be rebuild with new debhelper to get trigger support

  100. Ignoring install-info called from maintainer script

  101. The package emacs23-common should be rebuild with new debhelper to get trigger support

  102. Ignoring install-info called from maintainer script

  103. The package emacs23-common should be rebuild with new debhelper to get trigger support

  104. Ignoring install-info called from maintainer script

  105. The package emacs23-common should be rebuild with new debhelper to get trigger support

  106. Ignoring install-info called from maintainer script

  107. The package emacs23-common should be rebuild with new debhelper to get trigger support

  108. Ignoring install-info called from maintainer script

  109. The package emacs23-common should be rebuild with new debhelper to get trigger support

  110. Ignoring install-info called from maintainer script

  111. The package emacs23-common should be rebuild with new debhelper to get trigger support

  112. Ignoring install-info called from maintainer script

  113. The package emacs23-common should be rebuild with new debhelper to get trigger support

  114. Ignoring install-info called from maintainer script

  115. The package emacs23-common should be rebuild with new debhelper to get trigger support

  116. Ignoring install-info called from maintainer script

  117. The package emacs23-common should be rebuild with new debhelper to get trigger support

  118. Ignoring install-info called from maintainer script

  119. The package emacs23-common should be rebuild with new debhelper to get trigger support

  120. Ignoring install-info called from maintainer script

  121. The package emacs23-common should be rebuild with new debhelper to get trigger support

  122. Ignoring install-info called from maintainer script

  123. The package emacs23-common should be rebuild with new debhelper to get trigger support

  124. Ignoring install-info called from maintainer script

  125. The package emacs23-common should be rebuild with new debhelper to get trigger support

  126. Ignoring install-info called from maintainer script

  127. The package emacs23-common should be rebuild with new debhelper to get trigger support

  128. Ignoring install-info called from maintainer script

  129. The package emacs23-common should be rebuild with new debhelper to get trigger support

  130. Ignoring install-info called from maintainer script

  131. The package emacs23-common should be rebuild with new debhelper to get trigger support

  132. Ignoring install-info called from maintainer script

  133. The package emacs23-common should be rebuild with new debhelper to get trigger support

  134. Ignoring install-info called from maintainer script

  135. The package emacs23-common should be rebuild with new debhelper to get trigger support

  136. Ignoring install-info called from maintainer script

  137. The package emacs23-common should be rebuild with new debhelper to get trigger support

  138. Ignoring install-info called from maintainer script

  139. The package emacs23-common should be rebuild with new debhelper to get trigger support

  140. Ignoring install-info called from maintainer script

  141. The package emacs23-common should be rebuild with new debhelper to get trigger support



  142. 正在设置 emacs23-bin-common (23.1+1-4ubuntu3.1) ...

  143. update-alternatives: 使用 /usr/bin/b2m.emacs23 来提供 /usr/bin/b2m (b2m),于 自动模式 中。

  144. update-alternatives: 使用 /usr/bin/ebrowse.emacs23 来提供 /usr/bin/ebrowse (ebrowse),于 自动模式 中。

  145. update-alternatives: 使用 /usr/bin/emacsclient.emacs23 来提供 /usr/bin/emacsclient (emacsclient),于 自动模式 中。

  146. update-alternatives: 使用 /usr/bin/grep-changelog.emacs23 来提供 /usr/bin/grep-changelog (grep-changelog),于 自动模式 中。

  147. update-alternatives: 使用 /usr/bin/rcs-checkin.emacs23 来提供 /usr/bin/rcs-checkin (rcs-checkin),于 自动模式 中。



  148. 正在设置 emacs23 (23.1+1-4ubuntu3.1) ...

  149. update-alternatives: 使用 /usr/bin/emacs23-x 来提供 /usr/bin/emacs (emacs),于 自动模式 中。

  150. emacs-install emacs23

  151. install/cscope: Byte-compiling for emacs23

  152. cp: 无法 stat “xscope.el”: 没有该文件或目录

  153. >>Error occurred processing xscope.el: File error (("Opening input file" "没有该文件或目录" "/usr/share/emacs23/site-lisp/cscope/xscope.el"))

  154. install/dictionaries-common: Byte-compiling for emacsen flavour emacs23

  155. >>Error occurred processing debian-ispell.el: File error (("Opening input file" "没有该文件或目录" "/usr/share/emacs23/site-lisp/dictionaries-common/debian-ispell.el"))

  156. >>Error occurred processing ispell.el: File error (("Opening input file" "没有该文件或目录" "/usr/share/emacs23/site-lisp/dictionaries-common/ispell.el"))

  157. >>Error occurred processing flyspell.el: File error (("Opening input file" "没有该文件或目录" "/usr/share/emacs23/site-lisp/dictionaries-common/flyspell.el"))

  158. emacs-install: /usr/lib/emacsen-common/packages/install/dictionaries-common emacs23 failed at /usr/lib/emacsen-common/emacs-install line 28, <TSORT> line 4.

  159. dpkg:处理 emacs23 (--configure)时出错:

  160. 子进程 已安装的 post-installation 脚本 返回了错误号 1

  161. 在处理时有错误发生:

  162. emacs23

复制代码
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

DTCC2020中国数据库技术大会

【架构革新 高效可控】2020年12月21日-23日第十一届中国数据库技术大会将在北京隆重召开。

大会设置2大主会场,20+技术专场,将邀请超百位行业专家,重点围绕数据架构、AI与大数据、传统企业数据库实践和国产开源数据库等内容展开分享和探讨,为广大数据领域从业人士提供一场年度盛会和交流平台。

http://dtcc.it168.com


大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP