免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 2624 | 回复: 0

`gcry_cipher_setkey@GCRYPT_1.2' 两个版本错误 [复制链接]

论坛徽章:
0
发表于 2009-12-17 15:13 |显示全部楼层
编译完成后,在链接阶段出现如下链接错误:
/usr/local/lib/libgnuttls.so: undefined reference to  `gcry_cipher_setkey@GCRYPT_1.2'网上搜了半天也没找到相关中文的,只有一篇英文文章
链接地址
文章核心内容是libgcrypt.so存在两个版本,在链接时出现问题,
在/usr/local/lib和/usr/lib下存在两个版本,仔细看了一下,果然有这个
问题。
修改方法:
(1)直接将/usr/local/lib下的libgcrypt.so覆盖/usr/lib下的,这个办法不帅。
(2) 在/usr/lib下面,做/usr/local/lib下libgcrypt.so的软链接即可。
我用的这种办法解决的。


本文来自ChinaUnix博客,如果查看原文请点:http://blog.chinaunix.net/u3/93789/showart_2123988.html
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP