免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 3330 | 回复: 6

[WebServer] BOA服务器 [复制链接]

论坛徽章:
0
发表于 2011-05-14 15:56 |显示全部楼层
boa: /lib/libc.so.6: version `GLIBC_2.4' not found (required by boa)

我将做好的boa服务器移植到开发板后运行boa出现上面提示
请问大侠上面是怎么回事   应该怎么解决阿?

论坛徽章:
0
发表于 2011-05-14 16:19 |显示全部楼层
这个你的libc.so.6和boa所要求的不匹配,因为你两个东西使用不同的交叉工具链来编译,需要更换成同一样的。

论坛徽章:
0
发表于 2011-05-14 21:11 |显示全部楼层
回复 2# nazily2150


    我刚开始学的 不是很懂请问 怎样改才可以是 他们相互匹配呢 能不能详细说一下

论坛徽章:
0
发表于 2011-05-14 21:15 |显示全部楼层
你需要用同一个交叉编译(arm-linux-gcc/arm-none-linux-gnueabi-gcc),通过arm-linux-gcc -v来查看,接着复制其目录下相应的libc.so.6(交叉工具的目录),一般在/usr/local/arm/arm-linux/lib/libc.so.6,把这个复制过去,不要把主机的或者别的复制到开发板的/lib下。

祝成功。

论坛徽章:
0
发表于 2011-05-14 21:44 |显示全部楼层
回复 4# nazily2150


    您的意思是说用这个交叉编译 进行编译boa 然后再把相应的libc.so.6复制到开发板的lib目录下吗

论坛徽章:
0
发表于 2011-05-15 15:19 |显示全部楼层
是的

论坛徽章:
0
发表于 2011-05-15 21:55 |显示全部楼层
谢啦
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

SACC2019中国系统架构师大会

【数字转型 架构演进】SACC2019中国系统架构师大会
2019年10月31日~11月2日第11届中国系统架构师大会(SACC2019)将在北京隆重召开。四大主线并行的演讲模式,1个主会场、20个技术专场、超千人参与的会议规模,100+来自互联网、金融、制造业、电商等领域的嘉宾阵容,将为广大参会者提供一场最具价值的技术交流盛会。




----------------------------------------

大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP