忘记密码   免费注册 查看新帖 | 论坛精华区

ChinaUnix.net

  平台 论坛 博客 认证专区 大话IT 视频 徽章 文库 沙龙 自测 下载 频道自动化运维 虚拟化 储存备份 C/C++ PHP MySQL 嵌入式 Linux系统
1234下一页
最近访问板块 发新帖
查看: 18457 | 回复: 31

【推荐】路由器10M端口做Trunk-----ZT [复制链接]

论坛徽章:
1
荣誉版主
日期:2011-11-23 16:44:17
发表于 2004-06-07 23:18 |显示全部楼层
2610上使用IOS (tm) C2600 Software (C2600-IS-M), Version 12.0(3)T3, RELEASE SOFTWARE (fc1),以太口支持VLAN Trunk,采用802.1Q封装,不能采用ISL封装
以下是2610路由器通过10M以太网口做vlan路由的证明,由于在上面运行企业版IOS,与以后要安装2cE1,所以升级了flash与内存,不过由以下信息可见8M flash与32M内存,完全可以做vlan路由(dot1q),我试了几个带ip plus功能集的IOS都可以做,当然也包括企业版IOS(见最后部份)

BAISE-NM-ROUTER#sh version
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-IS-M), Version 12.1(6), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Wed 27-Dec-00 20:52 by kellythw
Image text-base: 0x80008088, data-base: 0x80CB43D0

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

BAISE-NM-ROUTER uptime is 7 minutes
System returned to ROM by reload
System image file is "flash:c2600-is-mz.121-6.bin"

cisco 2610 (MPC860) processor (revision 0x203) with 53248K/12288K bytes of memor
y.
Processor board ID JAD05080HTZ (3375544961)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

BAISE-NM-ROUTER#sh flash

System flash directory:
File Length Name/status
1 7595252 c2600-is-mz.121-6.bin
[7595316 bytes used, 9181900 available, 16777216 total]
16384K bytes of processor board System flash (Read/Write)

BAISE-NM-ROUTER#sh run
Building configuration...

Current configuration : 1228 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname BAISE-NM-ROUTER
!
enable secret 5 $1$nK1s$4LGXrw/baBAx4bq74u//J0
!
!
!
!
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
!
!
!
!
!
interface Ethernet0/0
no ip address
!
interface Ethernet0/0.1
!
interface Ethernet0/0.2
description OMC1
encapsulation dot1Q 2
ip address 10.184.6.30 255.255.255.224
!
interface Ethernet0/0.3
description HuaWei-OMC-S
encapsulation dot1Q 3
ip address 10.184.6.46 255.255.255.240
!
interface Ethernet0/0.4
description OMC3
encapsulation dot1Q 4
ip address 10.184.6.62 255.255.255.240
!
interface Ethernet0/0.5
description OMC4
encapsulation dot1Q 5
ip address 10.184.6.94 255.255.255.224
!
interface Ethernet0/0.6
description OMC5
encapsulation dot1Q 6
ip address 10.184.6.110 255.255.255.240
!
interface Ethernet0/0.7
description OMC5
encapsulation dot1Q 7
ip address 10.184.6.126 255.255.255.240
!
interface Serial0/0
description to nms7206
ip address 10.184.6.129 255.255.255.252
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.184.6.130
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end

BAISE-NM-ROUTER#sh flash

System flash directory:
File Length Name/status
1 11613328 c2600-js-mz.122.bin
[11613392 bytes used, 5163824 available, 16777216 total]
16384K bytes of processor board System flash (Read/Write)

BAISE-NM-ROUTER#conf t
Enter configuration commands, one per line. End with CNTL/Z.
BAISE-NM-ROUTER(config)#int e0/0.1
BAISE-NM-ROUTER(config-subif)#encap ?
dot1Q IEEE 802.1Q Virtual LAN
sde IEEE 802.10 Virtual LAN - Secure Data Exchange


This feature is supported on these platforms:

Cisco 1710 router

Cisco 1751 router

Cisco 2600 series

Cisco 3600 series

Cisco 4000-M series (Cisco 4000-M, 4500-M, 4700-M)

Cisco 7200 series

RSP1Cisco 7505

RSP2Cisco 7507 and Cisco 7513

RSP4Cisco 7505, Cisco 7507, Cisco 7513, and Cisco 7576

25系列暂时还不支持!

论坛徽章:
1
荣誉版主
日期:2011-11-23 16:44:17
发表于 2004-06-08 09:54 |显示全部楼层

【推荐】路由器10M端口做Trunk-----ZT

标题太迷惑人了。好像100m的端口也能吧   

论坛徽章:
1
荣誉版主
日期:2011-11-23 16:44:17
发表于 2004-06-08 10:19 |显示全部楼层

【推荐】路由器10M端口做Trunk-----ZT

[quote]原帖由 "我爱臭豆腐"] 标题太迷惑人了。好像100m的端口也能吧   [/quote 发表:


100M端口做TRUNK很正常,10M端口实现就不一般了      

论坛徽章:
1
荣誉版主
日期:2011-11-23 16:44:17
发表于 2004-06-08 14:27 |显示全部楼层

【推荐】路由器10M端口做Trunk-----ZT

原帖由 "mazu" 发表:


100M端口做TRUNK很正常,10M端口实现就不一般了      



原则上感觉只要软件支持在那个接口下面能够划分子接口的话就可以做。没有什么不一般的。   

论坛徽章:
0
发表于 2004-06-08 15:49 |显示全部楼层

【推荐】路由器10M端口做Trunk-----ZT

呵呵 学CISCO的时候 书上总说100M的才能TRUNK
MAZU给个特例啊      支持

论坛徽章:
1
荣誉版主
日期:2011-11-23 16:44:17
发表于 2004-06-08 16:21 |显示全部楼层

【推荐】路由器10M端口做Trunk-----ZT

刚才又查了查cisco的网站,基本上所有的ethernet接口都可以支持trunk (除了部分中高端switch的10ge不支持isl),看来书上说的也不能完全相信  

论坛徽章:
1
荣誉版主
日期:2011-11-23 16:44:17
发表于 2004-06-08 16:32 |显示全部楼层

【推荐】路由器10M端口做Trunk-----ZT

[quote]原帖由 "mazu"]刚才又查了查cisco的网站,基本上所有的ethernet接口都可以支持trunk (除了部分中高端switch的10ge不支持isl),看来书上说的也不能完全相信  [/quote 发表:

读过书的人就是不一样啊

论坛徽章:
0
发表于 2004-06-08 16:46 |显示全部楼层

【推荐】路由器10M端口做Trunk-----ZT

关于为什么做TRUNK必须是百兆端口的问题,记得一本讲网络原理的书中有过详细的讲解,并不是人为规定那么简单的,是经过系列的换算之后,通过得到的数值来确定的!具体记不得了,大家可以查看相关书籍

论坛徽章:
1
荣誉版主
日期:2011-11-23 16:44:17
发表于 2004-06-08 16:48 |显示全部楼层

【推荐】路由器10M端口做Trunk-----ZT

原帖由 "我爱臭豆腐" 发表:

读过书的人就是不一样啊


  
拉出去,狠扁      

论坛徽章:
1
荣誉版主
日期:2011-11-23 16:44:17
发表于 2004-06-08 16:50 |显示全部楼层

【推荐】路由器10M端口做Trunk-----ZT

原帖由 "mazu" 发表:


  
拉出去,狠扁      


有本事你来啊。我现在在知春路卫星大厦10层。有本事你倒是来啊 :em11:
您需要登录后才可以回帖 登录 | 注册

本版积分规则

  

北京皓辰网域网络信息技术有限公司. 版权所有 京ICP证:060528号 北京市公安局海淀分局网监中心备案编号:1101082001
广播电视节目制作经营许可证(京) 字第1234号 中国互联网协会会员  联系我们:
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP