免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 5784 | 回复: 3

本地 Xorg 上运行远端 Xclient 问题:Can't open display: 192.168.0.10:0.0 [复制链接]

论坛徽章:
0
发表于 2012-02-12 17:49 |显示全部楼层
本帖最后由 自由狼-台风0 于 2012-02-12 18:21 编辑

问题:试图在 A 计算机(192.168.0.10)上运行 B 计算机(192.168.0.20)的 X 程序(xclock 、xterm 等),不成功。

提示信息:Can't open display: 192.168.0.10:0.0

求助项:
1. 请指点问题排查方向。
2. 如果这个问题不合适发布在这一版面,请转移到合适的版面,但请通知我。

谢谢。

论坛徽章:
0
发表于 2012-02-12 18:13 |显示全部楼层
本帖最后由 自由狼-台风0 于 2012-02-12 18:35 编辑

A 机信息:
发行版 = CentOS 6.0
Xserver = xorg-x11-server-Xorg-1.7.7-26.el6.i686
KDE = 4.3.4-x.el6
IP = 192.168.0.10
使用 KDM 。


B 机信息:
发行版 = Everest Linux 0.6
Xserver = xorg-x11-server-Xorg-1.5.3-3
KDE = 3.5.10-X
IP = 192.168.0.10
使用 GDM  。


正方向,试图在 A 计算机(192.168.0.10)的 Xorg 上运行 B 计算机(192.168.0.20)的 X 程序(xclock 、xterm 等),
配置步骤:
1. 在 A 计算机(192.168.0.10)修改 /etc/X11/xdm/xdm-config ,用感叹号注释掉最后一行(“DisplayManager.requestPort:    0”)。
2. 在 A 计算机(192.168.0.10)修改 vi /etc/X11/xdm/Xaccess,取消“#*       #any host can get a login window”行前端的“#”。
3. 在 A 计算机(192.168.0.10)修改 vi /etc/kde/kdm/kdmrc,将文件底部“[Xdmcp]”段中的“Enable=false”改为“Enable=true”。
4. 关闭 A 计算机(192.168.0.10)的防火墙:[root@TFW-CENT6-LT ~]# service iptables stop 。
操作步骤:
1. 在 A 计算机(192.168.0.10)重新启动 Xserver 。
2. 允许任何主机使用  A 计算机(192.168.0.10)的 Xserver :[guest@TFW-CENT6-LT ~]$ xhost+
2. 从 A 计算机(192.168.0.10)登录 B 计算机(192.168.0.20):[guest@TFW-CENT6-LT ~]$ ssh guest@192.168.0.20 -p 1022
3. 将 B 计算机(192.168.0.20)计算机的显示定向到 A 计算机(192.168.0.10):[guest@TFW-EVL06-LT ~]$ export DISPLAY=192.168.0.10:0.0
4. 执行  B 计算机(192.168.0.20)的 xclock :[guest@TFW-EVL06-LT ~]$ xclock
提示:
Can't open display: 192.168.0.10:0.0

反方向,在 B 计算机(192.168.0.20)的 Xorg 运行 A 计算机(192.168.0.10)的 X 程序(xclock 、xterm 、kcalc 、konqueror 、firefox 等)均成功,说明路由器没有做相应的端口限制,网络无问题。

以上操作步骤主要由 google 搜索‘而来。但针对这一特别问题,不清处搜索时如何选取关键字。
目前对如何解决这一问题毫无头绪。特此求助。

谢谢。

论坛徽章:
0
发表于 2012-02-14 19:38 |显示全部楼层
问题解决。正在总结。

论坛徽章:
0
发表于 2012-02-20 01:04 |显示全部楼层
其实一开始就发现 X 没有监听网络(ps 的时候发现 X 的启动参数里有“nolisten”)。
也知道肯定是在哪个不起眼的地方有个小配置改一下就好。
一直在找如何开启网络监听,但找的办法都不对路。

最后,忽然想到用“KDM”和“nolisten”作为关键字去搜索了一下,发现还是在“/etc/kde/kdm/kdmrc”里。
把“nolisten”所在的行注释掉,再重启 X ,就 OK 了。

只改这一处就可以了。
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

SACC2019中国系统架构师大会

【数字转型 架构演进】SACC2019中国系统架构师大会,8.5折限时优惠重磅来袭!
2019年10月31日~11月2日第11届中国系统架构师大会(SACC2019)将在北京隆重召开。四大主线并行的演讲模式,1个主会场、20个技术专场、超千人参与的会议规模,100+来自互联网、金融、制造业、电商等领域的嘉宾阵容,将为广大参会者提供一场最具价值的技术交流盛会。

限时8.5折扣期:2019年9月30日前


----------------------------------------

大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP