免费注册 查看新帖 |

ChinaUnix.net

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 1631 | 回复: 6

linux软路由问题 [复制链接]

论坛徽章:
0
发表于 2012-03-14 14:15 |显示全部楼层
linux做路由,smartbit测试打不通,请问是哪设置错了


linux:
echo "1" > /proc/sys/net/ipv4/ip_forward
ifconfig eth0 192.168.2.22 netmask 255.255.255.0
ifconfig eth1 192.168.1.22 netmask 255.255.255.0

smartapp
port1:192.168.2.11
port2:192.168.1.11

连接port1-->eth0-eth1-->port2

smartapplication做吞吐量测试时,报错说收不到学习帧

论坛徽章:
5
IT运维版块每日发帖之星
日期:2015-08-06 06:20:00IT运维版块每日发帖之星
日期:2015-08-10 06:20:00IT运维版块每日发帖之星
日期:2015-08-23 06:20:00IT运维版块每日发帖之星
日期:2015-08-24 06:20:00IT运维版块每日发帖之星
日期:2015-11-12 06:20:00
发表于 2012-03-14 14:22 |显示全部楼层
防火墙关了吗?

论坛徽章:
0
发表于 2012-03-14 14:30 |显示全部楼层
防护墙没设任何规则啊,linux两边接两个终端,两边是可以ping通的,但是用smartbit测试却不行
回复 2# ssffzz1


   

论坛徽章:
0
发表于 2012-03-14 14:45 |显示全部楼层
这个应该是哪设置出问题了,用两个pc测linux路由,可以ping通,说明linux路由没问题,但是smartbit,application设置也正是设置源、目的Mac、ip,也应该没错啊

论坛徽章:
5
IT运维版块每日发帖之星
日期:2015-08-06 06:20:00IT运维版块每日发帖之星
日期:2015-08-10 06:20:00IT运维版块每日发帖之星
日期:2015-08-23 06:20:00IT运维版块每日发帖之星
日期:2015-08-24 06:20:00IT运维版块每日发帖之星
日期:2015-11-12 06:20:00
发表于 2012-03-14 17:13 |显示全部楼层
你直接抓smartbit出来的报文看下对否。

论坛徽章:
0
发表于 2012-03-15 02:05 |显示全部楼层
ROS听说挺好用的,楼主可以试试……

论坛徽章:
0
发表于 2012-03-15 10:18 |显示全部楼层
回复 6# c2shield
谢谢,不过我的目的并不是做路由,我是在数据层写了一个与linux包交互的程序,本来想验证这个的性能,结果smartbit打不通,为了找出原因,发现只测linux也有问题


   
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

基于案例的 SQL 优化实战训练营

讲师:中电福富特级专家梁敬彬,参与本次课程培训,你将收获:
1. 能编写出较为高效的 SQL;
2. 能解决70%以上的数据库常见优化问题;
3. 能得到老师提供的高效的相关工具和解决方案;
4. 能举一反三,收获不仅仅是 SQL 优化。
现在购票享受8.8折优惠!
----------------------------------------
优惠时间:2019年3月20日前

大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP