免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
12下一页
最近访问板块 发新帖
查看: 3485 | 回复: 10

[备份软件] TSM5.4备份ORACLE数据库故障求助! [复制链接]

论坛徽章:
1
2015年亚洲杯之科威特
日期:2015-03-25 15:56:45
发表于 2012-09-20 22:14 |显示全部楼层

TSM版本5.4
服务器WINDOWS2003
节点AIX系统
带库是TS3200,两个driver

最近在rman的备份日志中查看备份不成功,在TSM服务器端日志中查看,备份时会有下图中的报错:
无法找到与为库TS3200中的驱动器DRIVE1和2定义的序列号相匹配的路径
HBAAPI供应商库未能装入或丢失.

TSM>q mount命令查看,是正在等待装入VOLUME的状态
q path和q drive看都正常
网上看到有人说setopt sandiscovery off,然后重启TSM服务器能恢复,但试了不行,
求大侠们都出宝贵意见谢谢了.

TSM ERROR

TSM ERROR

论坛徽章:
0
发表于 2012-09-20 22:22 |显示全部楼层
顶一下,期待高手回答

论坛徽章:
1
2015年亚洲杯之科威特
日期:2015-03-25 15:56:45
发表于 2012-09-21 12:19 |显示全部楼层
今天用update path命令更新DRIVER路径,但报访问DRIVER是IO错误,两个驱动器一样,在带库中看是正常的READY状态

论坛徽章:
0
发表于 2012-09-21 12:43 |显示全部楼层
如果不会重新定义,重启带库就解决了

论坛徽章:
1
2015年亚洲杯之科威特
日期:2015-03-25 15:56:45
发表于 2012-09-21 13:06 |显示全部楼层
重启过了,日志中还是报路径不匹配,更新路径时还是IO错误,和以前一样,还有更好的建议吗?回复 4# eastaix


   

论坛徽章:
1
2015年亚洲杯之科威特
日期:2015-03-25 15:56:45
发表于 2012-09-26 15:59 |显示全部楼层
重新将DRIVE和路径都删除了重新配置了下,果然是路径名变了,由mt0.0.0.2/3就成了mt1.0.0.2/3,重新按错误新路径配置后正常了,但是第二天又报了相同错误,再次重新配置后恢复正常,第三天又有了相同错误,交换机和带库都是正常的,会是什么原因引起的问题?求救啊

论坛徽章:
0
发表于 2012-09-27 16:36 |显示全部楼层
也遇到过 windows 下面是存在这样一个问题

论坛徽章:
0
发表于 2012-10-16 23:32 |显示全部楼层
把带库路径都删除掉,重新定义即可。

论坛徽章:
1
2015年亚洲杯之科威特
日期:2015-03-25 15:56:45
发表于 2012-10-26 10:17 |显示全部楼层
带库路径都能删除?重建后磁带要重新加标签初始化的,那我以前备份的数据岂不是要丢了? 回复 8# 花泽类


   

论坛徽章:
1
2015年亚洲杯之科威特
日期:2015-03-25 15:56:45
发表于 2012-10-26 10:20 |显示全部楼层
结个帖,删除DRIVE路径后重新建时,用的是WINDOWS中识别到的那个永久性名称,而不是mt0.1.0.2这个名,现在已经恢复正常.
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP