免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
12下一页
最近访问板块 发新帖
查看: 3095 | 回复: 10

[RAID与磁盘阵列] 咨询个RAID 1问题,不知道发这合适不 [复制链接]

论坛徽章:
0
发表于 2012-11-27 09:41 |显示全部楼层
我联想万全T350服务器(很旧了啊),两块SCSI硬盘做了RAID 1,装SCO 506系统,现在系统启动不了了,连引导界面都不出现,系统自检时能找到两块硬盘,可能是系统引导区坏了,现在我如果用另外两块硬盘重装一个系统,怎么能把原来硬盘中的数据替换出来?另外两块硬盘如果型号跟原来的不同的话能不能行?

论坛徽章:
13
技术图书徽章
日期:2014-04-29 14:15:42IT运维版块每日发帖之星
日期:2015-12-12 06:20:00IT运维版块每日发帖之星
日期:2015-08-30 06:20:00IT运维版块每日发帖之星
日期:2015-08-24 06:20:00IT运维版块每日发帖之星
日期:2015-08-02 06:20:002015年亚洲杯之澳大利亚
日期:2015-04-03 15:03:12申猴
日期:2015-03-20 09:00:292015年迎新春徽章
日期:2015-03-04 09:54:452015年辞旧岁徽章
日期:2015-03-03 16:54:15季节之章:冬
日期:2015-01-20 17:08:47双子座
日期:2014-11-21 16:30:31技术图书徽章
日期:2014-07-11 16:29:08
发表于 2012-11-27 09:54 |显示全部楼层
也有可能是RAID卡坏了,更换RAID重新引导看看。

或者拔下一块硬盘,启动看看,看看是否可以启动的。

论坛徽章:
0
发表于 2012-11-27 09:56 |显示全部楼层
回复 2# dengbao2001


    谢谢,我试试

论坛徽章:
13
技术图书徽章
日期:2014-04-29 14:15:42IT运维版块每日发帖之星
日期:2015-12-12 06:20:00IT运维版块每日发帖之星
日期:2015-08-30 06:20:00IT运维版块每日发帖之星
日期:2015-08-24 06:20:00IT运维版块每日发帖之星
日期:2015-08-02 06:20:002015年亚洲杯之澳大利亚
日期:2015-04-03 15:03:12申猴
日期:2015-03-20 09:00:292015年迎新春徽章
日期:2015-03-04 09:54:452015年辞旧岁徽章
日期:2015-03-03 16:54:15季节之章:冬
日期:2015-01-20 17:08:47双子座
日期:2014-11-21 16:30:31技术图书徽章
日期:2014-07-11 16:29:08
发表于 2012-11-27 10:05 |显示全部楼层
不客气。

如果硬盘是物理故障,也是无法读取的。如果硬盘可以读取,可以用你这个服务器,用单独一个硬盘,不要用RAID卡,安装系统进去,然后识别RAID卡,这样就可以识别RAID连接的硬盘呢。

可能你的服务器是集成的RAID卡,没法拆下来,估计只有这样的办法。

论坛徽章:
0
发表于 2012-11-27 10:17 |显示全部楼层
本帖最后由 xxhe 于 2012-11-27 10:21 编辑

回复 4# dengbao2001

我刚试了,单用任意一块启动都不行,我的是集成的RAID卡,然后我把两块同时插上,又出现问题,不出现检测软驱、光驱的界面了,在检测硬盘时出现了一个新提示:unresolved configuration mismatch betwwen disk(s) and NVRAM on the adapter。

还有,我装的是sco 506系统,不知道按你的说法单一个硬盘装操作系统能不能行

论坛徽章:
13
技术图书徽章
日期:2014-04-29 14:15:42IT运维版块每日发帖之星
日期:2015-12-12 06:20:00IT运维版块每日发帖之星
日期:2015-08-30 06:20:00IT运维版块每日发帖之星
日期:2015-08-24 06:20:00IT运维版块每日发帖之星
日期:2015-08-02 06:20:002015年亚洲杯之澳大利亚
日期:2015-04-03 15:03:12申猴
日期:2015-03-20 09:00:292015年迎新春徽章
日期:2015-03-04 09:54:452015年辞旧岁徽章
日期:2015-03-03 16:54:15季节之章:冬
日期:2015-01-20 17:08:47双子座
日期:2014-11-21 16:30:31技术图书徽章
日期:2014-07-11 16:29:08
发表于 2012-11-27 13:43 |显示全部楼层
单一硬盘,不用RAID来工作,安装好系统,到系统加载RAID卡驱动,尝试识别RAID上的磁盘

论坛徽章:
0
发表于 2012-11-27 16:19 |显示全部楼层
回复 6# dengbao2001


    谢谢老兄,问题基本解决了,没有用其他的方法,目前看来估计是我服务器RAID中主盘坏了,另一块盘不知是接触不好呢还是其他原因,当时也找不到了,后来重新插拔重启了N次,终于启动起来了,现在正在备份数据。

论坛徽章:
13
技术图书徽章
日期:2014-04-29 14:15:42IT运维版块每日发帖之星
日期:2015-12-12 06:20:00IT运维版块每日发帖之星
日期:2015-08-30 06:20:00IT运维版块每日发帖之星
日期:2015-08-24 06:20:00IT运维版块每日发帖之星
日期:2015-08-02 06:20:002015年亚洲杯之澳大利亚
日期:2015-04-03 15:03:12申猴
日期:2015-03-20 09:00:292015年迎新春徽章
日期:2015-03-04 09:54:452015年辞旧岁徽章
日期:2015-03-03 16:54:15季节之章:冬
日期:2015-01-20 17:08:47双子座
日期:2014-11-21 16:30:31技术图书徽章
日期:2014-07-11 16:29:08
发表于 2012-11-27 21:19 |显示全部楼层
别客气,你手气好,我也遇到这样的问题,没办法,单块硬盘搞起来再说

论坛徽章:
0
发表于 2012-11-30 16:34 |显示全部楼层
幸亏是raid1   这要是raid0现在估计已经哭了很多次了

论坛徽章:
0
发表于 2012-12-09 19:57 |显示全部楼层
搞raid10
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP