免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 1732 | 回复: 1

跨版本兼容问题 [复制链接]

论坛徽章:
0
发表于 2013-04-21 17:19 |显示全部楼层
python 2.4.x上运行正常。在python 2.6.x上如不加参数运行正常,加参数后报错,脚本相关部分如下

# cat aa.py

.........

try:
    sql = "SELECT USER_NAME FROM USERS ORDER BY USER_NAME"
    if(len(sys.argv)>1):
        sql = "SELECT USER_NAME FROM USERS AND USER_NAME='"+sys.argv[1]+"'"
    cur = conn.cursor()
    cur.execute (sql)
    while(1):
        rec = cur.fetchone()
        if(rec == None):
            break
        gen_conf(rec[0])
    cur.close()
except:
    print "Error: Generate config file list failed!"
    sys.exit(1)



# ./aa.py username                                     //加参数不正常
Error: Generate config file list failed!"

论坛徽章:
0
发表于 2013-04-21 17:44 |显示全部楼层
晕,解决了,粗心SQL语句写错了"AND"改为"WHERE"就行了,我还以为是兼容问题呢。版主可以删了这贴。
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

SACC2019中国系统架构师大会

【数字转型 架构演进】SACC2019中国系统架构师大会,7折限时优惠重磅来袭!
2019年10月31日~11月2日第11届中国系统架构师大会(SACC2019)将在北京隆重召开。四大主线并行的演讲模式,1个主会场、20个技术专场、超千人参与的会议规模,100+来自互联网、金融、制造业、电商等领域的嘉宾阵容,将为广大参会者提供一场最具价值的技术交流盛会。

限时七折期:2019年8月31日前


----------------------------------------

大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP