免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 2223 | 回复: 0

[服务应用] libpng版本导致的一个错误 [复制链接]

论坛徽章:
0
发表于 2013-04-25 22:33 |显示全部楼层
因为要生成png格式的验证码,所以调用了imagepng函数,没想到以前运行正常的函数,居然导致php-cgi程序挂掉了,报出的错误是:
libpng warning: Application was compiled with png.h from libpng-1.4.0
libpng warning: Application  is  running with png.c from libpng-1.2.49
gd-png:  fatal libpng error: Incompatible libpng version in application and library

我在编译gd-2.0.33和php的时候,都是使用了相同参数:--with-png-dir=/home/XXX/lib,按理说应该只会把我自己编译的libpng-1.2.49给链接进来,请问如何解决,多谢!
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP