免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
12
最近访问板块 发新帖
楼主: hqyus

XSLoder.pm报错,求助! [复制链接]

论坛徽章:
46
15-16赛季CBA联赛之四川
日期:2018-03-27 11:59:132015年亚洲杯之沙特阿拉伯
日期:2015-04-11 17:31:45天蝎座
日期:2015-03-25 16:56:49双鱼座
日期:2015-03-25 16:56:30摩羯座
日期:2015-03-25 16:56:09巳蛇
日期:2015-03-25 16:55:30卯兔
日期:2015-03-25 16:54:29子鼠
日期:2015-03-25 16:53:59申猴
日期:2015-03-25 16:53:29寅虎
日期:2015-03-25 16:52:29羊年新春福章
日期:2015-03-25 16:51:212015亚冠之布里斯班狮吼
日期:2015-07-13 10:44:56
发表于 2013-11-04 11:43 |显示全部楼层
回复 9# 104359176


    大的版本升级用C写的模块需要重新编译安装,因为虽然 API 没变化但基础的数据结构都可能变化,有的API可能改写成了宏之类的。但是由于API的兼容需要的也仅仅是重新编译而已,Python Ruby 也是这样吧

    用 libffi 之类的工具可以部分解决这个问题,但是因为 Perl 的 API 全是宏想调用 Perl 的功能就几乎不可能了,ruby python 还有救

论坛徽章:
0
发表于 2013-11-04 13:25 |显示全部楼层
不愧是版主啊! 学到不少不东西。
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP