免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 1374 | 回复: 4

[求助] 安装Pyqt时 make出错 [复制链接]

论坛徽章:
0
发表于 2014-04-08 15:14 |显示全部楼层
具体错误信息如下:

/usr/bin/ld: cannot find -lpython2.7m
collect2: error: ld returned 1 exit status
make[1]: *** [libpyqt4.so] Error 1
make[1]: Leaving directory `/maxwit/build/ExtractDir/PyQt-x11-gpl-4.10.4/designer'
make: *** [all] Error 2

自己google过第二条,但网友都说: 1.后台有程序运行。   2. 槽函数    3.在头文件中定义了函数但却没有函数体
看完之后还是不明白, 请大家帮忙分析下错误原因, 谢谢!

论坛徽章:
0
发表于 2014-04-08 16:27 |显示全部楼层
看错误应该是链接时出错。看看你系统上有没有安装python2.7m这个库,即libpython2.7m.so
1. 如果没有,需要安装相应的包
2. 如果有,看地址是否在/etc/ld.so.conf列表里

论坛徽章:
0
发表于 2014-04-08 16:28 |显示全部楼层
或者库名写错了?不是libpython2.7m.so,而是libpython2.7.so?

论坛徽章:
0
发表于 2014-04-08 19:14 |显示全部楼层
谢谢 sandy!

我有看了下我的系统中  没有libpython2.7m.so  而有libpython2.7.so   于是我把libpython2.7.so这个库的路径 加入到/etc/ld.so.conf中 格式如下:

include /etc/ld.so.conf.d/*.conf
include /usr/bin/i386-linux-gnu/libpython2.7.so
include /usr/bin/python2.7/config-i386-linux-gnu/libpython2.7.so

然后我再次Make   结果还是一样的错,  我现在认为是链接时库的名字写错了  我想把他改成libpython2.7.so  可是我不知道该去改哪里? 是在Makefile里面改库名吗?还是在别的地方呢?

论坛徽章:
0
发表于 2014-04-08 22:22 |显示全部楼层
本帖最后由 MWSandy 于 2014-04-08 22:28 编辑

首先,路径不需要再加入ld.so.conf文件了,因为其中的第一条已经包含了/usr/bin/i386-linux-gnu目录,并且你写的方法是错误的:)
其次,修改链接库的名字一般是在Makefile里,你可以在源码目录下搜索一下,将错误的库名统一修改掉

Good luck
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP