免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
12下一页
最近访问板块 发新帖
查看: 2454 | 回复: 12

[系统管理] 请教个关于CentOS的问题 [复制链接]

求职 : 系统工程师等
论坛徽章:
5
技术图书徽章
日期:2014-04-19 22:01:05天蝎座
日期:2014-05-09 13:49:28双子座
日期:2014-06-16 15:08:042015年辞旧岁徽章
日期:2015-03-03 16:54:152015年迎新春徽章
日期:2015-03-04 09:55:28
发表于 2014-07-18 16:15 |显示全部楼层
我在window上使用virtual box中安装的CentOS 5.10虚拟机。
1、使用桥接上网,ifconfig eth0配置的IP地址,但是复位之后IP地址就变了,能否固定呢?
2、安装完之后,打算使用samba功能,但是setup里没有smb这个服务,无法安装。怎么破?
(注:我的虚拟机无法上网,只有CentOS的iso的包。)最好可以直接使用iso里的程序,而不是新下载一个安装。

谢谢!




论坛徽章:
32
处女座
日期:2013-11-20 23:41:20双子座
日期:2014-06-11 17:20:43戌狗
日期:2014-06-16 11:05:00处女座
日期:2014-07-22 17:30:47狮子座
日期:2014-07-28 15:38:17金牛座
日期:2014-08-05 16:34:01亥猪
日期:2014-08-18 13:34:25白羊座
日期:2014-09-02 15:03:55金牛座
日期:2014-11-10 10:23:58处女座
日期:2014-12-02 09:17:52程序设计版块每日发帖之星
日期:2015-06-16 22:20:002015亚冠之塔什干火车头
日期:2015-06-20 23:28:22
发表于 2014-07-18 16:33 |显示全部楼层
1.我的虚拟机无论是用DHCP还是静态IP,每次开机都是原来的IP;
2.CentOS的安装盘里应该有samba的包,你可以用rpm,也可以用yum来安装,前提是你已经将yum源指向安装盘。

论坛徽章:
12
技术图书徽章
日期:2014-07-11 16:27:5215-16赛季CBA联赛之山西
日期:2016-01-08 16:10:11操作系统版块每日发帖之星
日期:2015-08-01 06:20:002015亚冠之武里南联
日期:2015-06-11 01:12:162015年亚洲杯之阿联酋
日期:2015-03-20 11:41:462015年亚洲杯纪念徽章
日期:2015-03-18 18:08:422015年辞旧岁徽章
日期:2015-03-03 16:54:15丑牛
日期:2015-01-10 22:23:32天秤座
日期:2014-08-20 15:53:35水瓶座
日期:2014-08-11 12:08:51午马
日期:2014-07-23 23:03:38IT运维版块每日发帖之星
日期:2016-02-18 06:20:00
发表于 2014-07-18 16:43 |显示全部楼层
回复 1# qxhgd


    修改 /etc/sysconfig/network-script/ifcfg-eth0 这个文件,


BOOTPROTO=dhcp 改成  BOOTPROTO=none
然后添加
IPADDR=x.x.x.x
NETMASK=255.255.x.x
GATEWAY=x.x.x.y


以上内容根据你需要配置。


地址就不会变了。


第二个,去ISO里面找 samba 开头的包。 装上即可。 安装包不叫smb 叫 samba XXXX。

求职 : 系统工程师等
论坛徽章:
5
技术图书徽章
日期:2014-04-19 22:01:05天蝎座
日期:2014-05-09 13:49:28双子座
日期:2014-06-16 15:08:042015年辞旧岁徽章
日期:2015-03-03 16:54:152015年迎新春徽章
日期:2015-03-04 09:55:28
发表于 2014-07-18 17:10 |显示全部楼层
感谢两位大侠。
使用yum太烦了,我直接使用rpm。但是会报错:
[root@192 CentOS]# rpm -ivh samba*.rpm
warning: samba-3.0.33-3.39.el5_8.i386.rpm: Header V3 DSA signature: NOKEY, key ID e8562897
error: Failed dependencies:
        perl(Convert::ASN1) is needed by samba-3.0.33-3.39.el5_8.i386
        libtalloc.so.2 is needed by samba3x-3.6.6-0.136.el5.i386
        libtalloc.so.2(TALLOC_2.0.2) is needed by samba3x-3.6.6-0.136.el5.i386
        libtdb.so.1 is needed by samba3x-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.1) is needed by samba3x-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.2) is needed by samba3x-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.5) is needed by samba3x-3.6.6-0.136.el5.i386
        libtevent.so.0 is needed by samba3x-3.6.6-0.136.el5.i386
        libtevent.so.0(TEVENT_0.9.9) is needed by samba3x-3.6.6-0.136.el5.i386
        samba < 0:3.6.6-0.136.el5 conflicts with samba3x-3.6.6-0.136.el5.i386
        samba-client < 0:3.6.6-0.136.el5 conflicts with samba3x-3.6.6-0.136.el5.i386
        samba-common < 0:3.6.6-0.136.el5 conflicts with samba3x-3.6.6-0.136.el5.i386
        libtalloc.so.2 is needed by samba3x-client-3.6.6-0.136.el5.i386
        libtalloc.so.2(TALLOC_2.0.2) is needed by samba3x-client-3.6.6-0.136.el5.i386
        libtdb.so.1 is needed by samba3x-client-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.1) is needed by samba3x-client-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.2) is needed by samba3x-client-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.5) is needed by samba3x-client-3.6.6-0.136.el5.i386
        libtevent.so.0 is needed by samba3x-client-3.6.6-0.136.el5.i386
        libtevent.so.0(TEVENT_0.9.9) is needed by samba3x-client-3.6.6-0.136.el5.i386
        samba < 0:3.6.6-0.136.el5 conflicts with samba3x-client-3.6.6-0.136.el5.i386
        samba-client < 0:3.6.6-0.136.el5 conflicts with samba3x-client-3.6.6-0.136.el5.i386
        libtalloc >= 2.0.1 is needed by samba3x-common-3.6.6-0.136.el5.i386
        libtalloc.so.2 is needed by samba3x-common-3.6.6-0.136.el5.i386
        libtalloc.so.2(TALLOC_2.0.2) is needed by samba3x-common-3.6.6-0.136.el5.i386
        libtdb >= 1.2.6 is needed by samba3x-common-3.6.6-0.136.el5.i386
        libtdb.so.1 is needed by samba3x-common-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.1) is needed by samba3x-common-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.2) is needed by samba3x-common-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.5) is needed by samba3x-common-3.6.6-0.136.el5.i386
        libtevent >= 0.9.18 is needed by samba3x-common-3.6.6-0.136.el5.i386
        libtevent.so.0 is needed by samba3x-common-3.6.6-0.136.el5.i386
        libtevent.so.0(TEVENT_0.9.9) is needed by samba3x-common-3.6.6-0.136.el5.i386
        samba-common < 0:3.6.6-0.136.el5 conflicts with samba3x-common-3.6.6-0.136.el5.i386
        samba < 0:3.6.6-0.136.el5 conflicts with samba3x-common-3.6.6-0.136.el5.i386
        samba-client < 0:3.6.6-0.136.el5 conflicts with samba3x-common-3.6.6-0.136.el5.i386
        samba < 0:3.6.6-0.136.el5 conflicts with samba3x-doc-3.6.6-0.136.el5.i386
        libtalloc.so.2 is needed by samba3x-domainjoin-gui-3.6.6-0.136.el5.i386
        libtdb.so.1 is needed by samba3x-domainjoin-gui-3.6.6-0.136.el5.i386
        libtalloc.so.2 is needed by samba3x-swat-3.6.6-0.136.el5.i386
        libtalloc.so.2(TALLOC_2.0.2) is needed by samba3x-swat-3.6.6-0.136.el5.i386
        libtdb.so.1 is needed by samba3x-swat-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.1) is needed by samba3x-swat-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.2) is needed by samba3x-swat-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.5) is needed by samba3x-swat-3.6.6-0.136.el5.i386
        libtevent.so.0 is needed by samba3x-swat-3.6.6-0.136.el5.i386
        libtevent.so.0(TEVENT_0.9.9) is needed by samba3x-swat-3.6.6-0.136.el5.i386
        xinetd is needed by samba3x-swat-3.6.6-0.136.el5.i386
        samba-swat < 0:3.6.6-0.136.el5 conflicts with samba3x-swat-3.6.6-0.136.el5.i386
        libtalloc.so.2 is needed by samba3x-winbind-3.6.6-0.136.el5.i386
        libtalloc.so.2(TALLOC_2.0.2) is needed by samba3x-winbind-3.6.6-0.136.el5.i386
        libtdb.so.1 is needed by samba3x-winbind-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.1) is needed by samba3x-winbind-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.2) is needed by samba3x-winbind-3.6.6-0.136.el5.i386
        libtdb.so.1(TDB_1.2.5) is needed by samba3x-winbind-3.6.6-0.136.el5.i386
        libtevent.so.0 is needed by samba3x-winbind-3.6.6-0.136.el5.i386
        libtevent.so.0(TEVENT_0.9.9) is needed by samba3x-winbind-3.6.6-0.136.el5.i386
        samba-common < 0:3.6.6-0.136.el5 conflicts with samba3x-winbind-3.6.6-0.136.el5.i386
        xinetd is needed by samba-swat-3.0.33-3.39.el5_8.i386

这个什么情况?

论坛徽章:
12
技术图书徽章
日期:2014-07-11 16:27:5215-16赛季CBA联赛之山西
日期:2016-01-08 16:10:11操作系统版块每日发帖之星
日期:2015-08-01 06:20:002015亚冠之武里南联
日期:2015-06-11 01:12:162015年亚洲杯之阿联酋
日期:2015-03-20 11:41:462015年亚洲杯纪念徽章
日期:2015-03-18 18:08:422015年辞旧岁徽章
日期:2015-03-03 16:54:15丑牛
日期:2015-01-10 22:23:32天秤座
日期:2014-08-20 15:53:35水瓶座
日期:2014-08-11 12:08:51午马
日期:2014-07-23 23:03:38IT运维版块每日发帖之星
日期:2016-02-18 06:20:00
发表于 2014-07-18 18:05 |显示全部楼层
这是安装依赖的问题,你最好配置一个本地YUM源。 其实很简单。 就把 /etc/yum.repos.d/rhel-source.repo 改一下。 路径改成 file:///xxx/xxxx/ 指向你ISO mount的路径就可以了。 把 enable改成1 gpg_check改成0.
然后用yum来安装 yum install -y samba 就可以了,自动解决依赖问题。

论坛徽章:
32
处女座
日期:2013-11-20 23:41:20双子座
日期:2014-06-11 17:20:43戌狗
日期:2014-06-16 11:05:00处女座
日期:2014-07-22 17:30:47狮子座
日期:2014-07-28 15:38:17金牛座
日期:2014-08-05 16:34:01亥猪
日期:2014-08-18 13:34:25白羊座
日期:2014-09-02 15:03:55金牛座
日期:2014-11-10 10:23:58处女座
日期:2014-12-02 09:17:52程序设计版块每日发帖之星
日期:2015-06-16 22:20:002015亚冠之塔什干火车头
日期:2015-06-20 23:28:22
发表于 2014-07-18 19:19 |显示全部楼层
回复 4# qxhgd

rpm安装很蛋疼,建议你还是用yum,如果不会配置本地光盘yum源的话可以看一下我下面这篇博文:
http://blog.sina.com.cn/s/blog_63c8c46401014q3n.html
   

论坛徽章:
30
ChinaUnix元老
日期:2015-02-02 08:55:39CU十四周年纪念徽章
日期:2019-08-20 08:30:3719周年集字徽章-19
日期:2019-08-27 13:31:2619周年集字徽章-CU
日期:2019-09-08 23:26:25
发表于 2014-07-18 22:23 |显示全部楼层
使用yum太烦了,我直接使用rpm

这个观点好新颖

论坛徽章:
1
2015年辞旧岁徽章
日期:2015-03-03 16:54:15
发表于 2014-07-19 22:17 |显示全部楼层
兄弟,看看鸟哥私房菜基础篇吧,或者linux基础之类的书,再研究这个吧!要不各种问题。

求职 : 系统工程师等
论坛徽章:
5
技术图书徽章
日期:2014-04-19 22:01:05天蝎座
日期:2014-05-09 13:49:28双子座
日期:2014-06-16 15:08:042015年辞旧岁徽章
日期:2015-03-03 16:54:152015年迎新春徽章
日期:2015-03-04 09:55:28
发表于 2014-07-22 09:09 |显示全部楼层
感谢各位,终于搞定了!
1、mount光盘
2、修改yum本地源
3、yum安装

论坛徽章:
218
2022北京冬奥会纪念版徽章
日期:2015-08-10 16:30:3215-16赛季CBA联赛之上海
日期:2019-09-20 12:29:32操作系统版块每日发帖之星
日期:2016-03-02 06:20:00操作系统版块每日发帖之星
日期:2016-03-01 06:20:00操作系统版块每日发帖之星
日期:2016-02-18 06:20:00操作系统版块每日发帖之星
日期:2016-05-10 19:22:58操作系统版块每日发帖之星
日期:2016-05-10 19:22:58操作系统版块每日发帖之星
日期:2016-05-10 19:22:58月度论坛发贴之星
日期:2016-01-31 22:25:02操作系统版块每日发帖之星
日期:2016-05-10 19:22:58操作系统版块每日发帖之星
日期:2016-05-10 19:22:58操作系统版块每日发帖之星
日期:2016-05-10 19:22:58
发表于 2014-07-22 09:26 |显示全部楼层
使用yum太烦了,我直接使用rpm
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

SACC2019中国系统架构师大会

【数字转型 架构演进】SACC2019中国系统架构师大会,8.5折限时优惠重磅来袭!
2019年10月31日~11月2日第11届中国系统架构师大会(SACC2019)将在北京隆重召开。四大主线并行的演讲模式,1个主会场、20个技术专场、超千人参与的会议规模,100+来自互联网、金融、制造业、电商等领域的嘉宾阵容,将为广大参会者提供一场最具价值的技术交流盛会。

限时8.5折扣期:2019年9月30日前


----------------------------------------

大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP