免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 13106 | 回复: 3

[系统安装] centos7 64位操作系统安装32位程序问题 [复制链接]

论坛徽章:
0
发表于 2014-10-23 17:29 |显示全部楼层
[root@localhost opt]# rpm -ivh xxx1.i386.rpm
准备中...                          ################################# [100%]
The 32bit support is missing. Please install the x86 compatibility
packages required by your distribution and retry the installation.
See the installation guide for more details.
错误:%pre(xxx-1.i386) 脚本执行失败,退出状态码为 8
错误:xxx-1.i386: 安裝 已失败

请问要安装那些组件才能支持安装32位程序

论坛徽章:
13
技术图书徽章
日期:2014-04-29 14:15:42IT运维版块每日发帖之星
日期:2015-12-12 06:20:00IT运维版块每日发帖之星
日期:2015-08-30 06:20:00IT运维版块每日发帖之星
日期:2015-08-24 06:20:00IT运维版块每日发帖之星
日期:2015-08-02 06:20:002015年亚洲杯之澳大利亚
日期:2015-04-03 15:03:12申猴
日期:2015-03-20 09:00:292015年迎新春徽章
日期:2015-03-04 09:54:452015年辞旧岁徽章
日期:2015-03-03 16:54:15季节之章:冬
日期:2015-01-20 17:08:47双子座
日期:2014-11-21 16:30:31技术图书徽章
日期:2014-07-11 16:29:08
发表于 2014-10-23 19:19 |显示全部楼层
Search on "glibc". Choose the "i686" version of the package and install it. That should pull in most of the 32-bit libraries.

论坛徽章:
381
CU十二周年纪念徽章
日期:2014-01-04 22:46:58CU大牛徽章
日期:2013-03-13 15:32:35CU大牛徽章
日期:2013-03-13 15:38:15CU大牛徽章
日期:2013-03-13 15:38:52CU大牛徽章
日期:2013-03-14 14:08:55CU大牛徽章
日期:2013-04-17 11:17:19CU大牛徽章
日期:2013-04-17 11:17:32CU大牛徽章
日期:2013-04-17 11:17:37CU大牛徽章
日期:2013-04-17 11:17:42CU大牛徽章
日期:2013-04-17 11:17:47CU大牛徽章
日期:2013-04-17 11:17:52CU大牛徽章
日期:2013-04-17 11:17:56
发表于 2014-10-23 19:32 |显示全部楼层
试试yum localinstall xxx1.i386.rpm

论坛徽章:
0
发表于 2014-10-24 15:29 |显示全部楼层
又有新问题了。哎
[root@localhost opt]# rpm -ivh libXp-devel-1.0.2-2.1.el7.i686.rpm
错误:依赖检测失败:
        libXau-devel 被 libXp-devel-1.0.2-2.1.el7.i686 需要
        libXp = 1.0.2-2.1.el7 被 libXp-devel-1.0.2-2.1.el7.i686 需要
        libXp.so.6 被 libXp-devel-1.0.2-2.1.el7.i686 需要
        pkgconfig(x11) 被 libXp-devel-1.0.2-2.1.el7.i686 需要
        pkgconfig(xau) 被 libXp-devel-1.0.2-2.1.el7.i686 需要
        pkgconfig(xext) 被 libXp-devel-1.0.2-2.1.el7.i686 需要
[root@localhost opt]# rpm -ivh  libXp-1.0.2-2.1.el7.i686.rpm
错误:依赖检测失败:
        libX11.so.6 被 libXp-1.0.2-2.1.el7.i686 需要
        libXau.so.6 被 libXp-1.0.2-2.1.el7.i686 需要
        libXext.so.6 被 libXp-1.0.2-2.1.el7.i686 需要
[root@localhost opt]#
我用 yum install来更新libX也更新不了,哪位能给解决一下
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

SACC2021中国系统架构师大会

【数字转型 架构重塑】2021年5月20日-22日第十三届中国系统架构师大会将在云端进行网络直播。

大会为期3天的议程,涉及20+专场,近120个主题,完整迁移到线上进行网络直播对会议组织来说绝非易事;但考虑到云端会议的直播形式可以实现全国各地技术爱好者的参与,也使ITPUB作为技术共享交流平台得到更好的普及,我们决定迎难而上。
http://sacc.it168.com/


大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP