免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 1851 | 回复: 2

mysql开发库安装问题 [复制链接]

论坛徽章:
0
发表于 2014-11-26 14:33 |显示全部楼层
本帖最后由 eveson 于 2014-11-26 14:33 编辑

linux下安装mysql环境,服务器处于公司内网,无法上网,因此只能手动去rpm -i 安装。目前在C语言和mysql库进行链接的时候出问题了,因为安装的mysql devel库版本不对,导致链接出错。后来发现必须安装X86-64版本的,但是安装时出了以下问题:

[root@A22996318 temp]# rpm -ivh MySQL-devel-5.6.21-1.el6.i686.rpm
error: Failed dependencies:
        rpmlib(FileDigests) <= 4.6.0-1 is needed by MySQL-devel-5.6.21-1.el6.i686
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by MySQL-devel-5.6.21-1.el6.i686


我在网上找了两天都没找到缺少的这两个库,谁碰到过这个问题,怎么解决呢?好久不来chinaunix了,遇到无法解决的问题,最终还是回到这里求救。

论坛徽章:
218
2022北京冬奥会纪念版徽章
日期:2015-08-10 16:30:3215-16赛季CBA联赛之上海
日期:2019-09-20 12:29:32操作系统版块每日发帖之星
日期:2016-03-02 06:20:00操作系统版块每日发帖之星
日期:2016-03-01 06:20:00操作系统版块每日发帖之星
日期:2016-02-18 06:20:00操作系统版块每日发帖之星
日期:2016-05-10 19:22:58操作系统版块每日发帖之星
日期:2016-05-10 19:22:58操作系统版块每日发帖之星
日期:2016-05-10 19:22:58月度论坛发贴之星
日期:2016-01-31 22:25:02操作系统版块每日发帖之星
日期:2016-05-10 19:22:58操作系统版块每日发帖之星
日期:2016-05-10 19:22:58操作系统版块每日发帖之星
日期:2016-05-10 19:22:58
发表于 2014-11-26 16:17 |显示全部楼层
你这个是什么情况??首先简单说一下情况,

比如系统,mysql安装方式,打算做什么开发??

论坛徽章:
1
2015年亚洲杯之阿联酋
日期:2015-03-11 18:03:25
发表于 2014-11-27 23:33 |显示全部楼层
更新rpm
rpmfind.net//linux/RPM
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

DTCC2020中国数据库技术大会 限时9.5折

【架构革新 高效可控】2020年8月17日~19日第十一届中国数据库技术大会将在北京隆重召开。

大会设置2大主会场,20+技术专场,将邀请超百位行业专家,重点围绕数据架构、AI与大数据、传统企业数据库实践和国产开源数据库等内容展开分享和探讨,为广大数据领域从业人士提供一场年度盛会和交流平台。

http://dtcc.it168.com


大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP