免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 2260 | 回复: 5

[BootLoader] S3C2410开发板u-boot启动问题 [复制链接]

论坛徽章:
0
发表于 2015-06-29 10:26 |显示全部楼层
直接进入u-boot命令行.png

如图
我的S3C2410开发板u-boot启动异常如下:
1、通电后直接进入u-boot命令行模式,没有3-2-1倒计时。
2、键盘不论按那个键都不能控制,或者说根本不能控制。

我用H-JTAG擦除后重新烧写,现象依旧是那个样子。串口等硬件正常,u-boot烧写文件正常,板子是固定nand flash启动(也就没有什么nor和nand切换)

请问是什么原因?

论坛徽章:
0
发表于 2015-06-30 12:05 |显示全部楼层
uboot 烧成砖了吧,砖才不响应按键的

论坛徽章:
0
发表于 2015-07-01 09:03 |显示全部楼层
你看一下include/configs/板级相关的那个配置文件里,CONFIG_BOOTDELAY 这个变量的值是不是被定义为0了,修改一下就可以了。

论坛徽章:
0
发表于 2015-07-03 10:36 |显示全部楼层
solomon2009 发表于 2015-06-30 12:05
uboot 烧成砖了吧,砖才不响应按键的


不好意思,请问砖是什么?烧成砖为什么就不响应按键了?
我用其同样的u-boot烧写其他的板子都好好的呀!

论坛徽章:
0
发表于 2015-07-03 10:41 |显示全部楼层
lazyrose 发表于 2015-07-01 09:03
你看一下include/configs/板级相关的那个配置文件里,CONFIG_BOOTDELAY 这个变量的值是不是被定义为0了,修 ...


是查看烧写进板子后的include/configs/.....还是烧写之前配置移植源码的include/configs/.......?
如果是前者,u-boot启动都异常了,所以根本就不能查看.
如果是后者,我看了写资料,也看了源码配置,CONFIG_BOOTDELAY正常,显示为3.
在这问一下,是否可能是硬件问题导致以上的现象?

论坛徽章:
0
发表于 2015-07-25 17:22 |显示全部楼层
我说的是u-boot源码中的config.h配置文件,你仔细看一下源码的common/main.c文件中main_loop函数的实现,里面的bootdelay变量的值,如果是0的话,就会导致开机直接进引导内核。
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

DTCC2020中国数据库技术大会

【架构革新 高效可控】2020年12月21日-23日第十一届中国数据库技术大会将在北京隆重召开。

大会设置2大主会场,20+技术专场,将邀请超百位行业专家,重点围绕数据架构、AI与大数据、传统企业数据库实践和国产开源数据库等内容展开分享和探讨,为广大数据领域从业人士提供一场年度盛会和交流平台。

http://dtcc.it168.com


大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP