免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 1874 | 回复: 9

[系统管理] 请教一个yum指令安装的问题 [复制链接]

论坛徽章:
2
操作系统版块每日发帖之星
日期:2015-08-06 06:20:00IT运维版块每日发帖之星
日期:2015-08-15 06:20:00
发表于 2015-08-03 12:20 |显示全部楼层
已经配置了本地yum,配置方法为/etc/yum.repos.d下建立一个local.repo,内如如下
[myyum]
name=olinux Myyum
#baseurl=file:///mnt/Server
baseurl=file:///mnt
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-oracle

已经把光盘mount到/mnt下了,
# ll /mnt
总用量 1301
drwxr-xr-x 3 root root   2048 11月 26 2013 EFI
-rw-r--r-- 1 root root   8529 11月 26 2013 EULA
-rw-r--r-- 1 root root   8529 11月 26 2013 eula.en_US
-rw-r--r-- 1 root root   3334 11月 26 2013 eula.py
-rw-r--r-- 1 root root  18390 11月 26 2013 GPL
drwxr-xr-x 3 root root   2048 11月 26 2013 HighAvailability
drwxr-xr-x 3 root root   2048 11月 26 2013 images
drwxr-xr-x 2 root root   2048 11月 26 2013 isolinux
drwxr-xr-x 3 root root   2048 11月 26 2013 LoadBalancer
-rw-r--r-- 1 root root     98 11月 26 2013 media.repo
drwxr-xr-x 2 root root 679936 11月 26 2013 Packages

# yum list |grep gcc
gcc.x86_64                              4.4.7-4.el6                    @anaconda-OracleLinuxServer-201311252058.x86_64/6.5
gcc-c++.x86_64                          4.4.7-4.el6                    installed
libgcc.x86_64                           4.4.7-4.el6                    @anaconda-OracleLinuxServer-201311252058.x86_64/6.5
compat-gcc-34.x86_64                    3.4.6-19.el6                   myyum   
compat-gcc-34-c++.x86_64                3.4.6-19.el6                   myyum   
compat-gcc-34-g77.x86_64                3.4.6-19.el6                   myyum   
gcc-gfortran.x86_64                     4.4.7-4.el6                    myyum   
gcc-gnat.x86_64                         4.4.7-4.el6                    myyum   
gcc-java.x86_64                         4.4.7-4.el6                    myyum   
gcc-objc.x86_64                         4.4.7-4.el6                    myyum   
gcc-objc++.x86_64                       4.4.7-4.el6                    myyum   
libgcc.i686                             4.4.7-4.el6                    myyum

本地yum好像正常了啊。可是执行下面的指令,安装ricci、rgmanager、cman的时候,却报找不到相应的包,如下

[root@dataguard yum.repos.d]# yum install ricci rgmanager cman
Loaded plugins: refresh-packagekit, security
Setting up Install Process
No package ricci available.
No package rgmanager available.
No package cman available.
Error: Nothing to do
[root@dataguard yum.repos.d]#

安装光盘是包含有ricci、rgmanager、cman的,如下指令可验证
[root@dataguard yum.repos.d]# cd /mnt/Packages/
[root@dataguard Packages]# ll ricci* rgmanager* cman*
-rw-r--r-- 1 root root 455688 11月 22 2013 cman-3.0.12.1-59.el6.x86_64.rpm
-rw-rw-r-- 1 root root 189728 10月 19 2013 rgmanager-3.0.12.1-19.el6.x86_64.rpm
-rw-r--r-- 1 root root 641480 11月 22 2013 ricci-0.16.2-69.el6.x86_64.rpm

本人初用yum指令和红帽集群,好多东西都不懂,弄了两天都没有用弄好,还请各位高手援手啊。

论坛徽章:
12
技术图书徽章
日期:2014-07-11 16:27:5215-16赛季CBA联赛之山西
日期:2016-01-08 16:10:11操作系统版块每日发帖之星
日期:2015-08-01 06:20:002015亚冠之武里南联
日期:2015-06-11 01:12:162015年亚洲杯之阿联酋
日期:2015-03-20 11:41:462015年亚洲杯纪念徽章
日期:2015-03-18 18:08:422015年辞旧岁徽章
日期:2015-03-03 16:54:15丑牛
日期:2015-01-10 22:23:32天秤座
日期:2014-08-20 15:53:35水瓶座
日期:2014-08-11 12:08:51午马
日期:2014-07-23 23:03:38IT运维版块每日发帖之星
日期:2016-02-18 06:20:00
发表于 2015-08-03 12:44 |显示全部楼层
本帖最后由 phanx 于 2015-08-03 12:45 编辑

回复 1# 草中宝

看看你的/mnt下面有HighAvailability这个目录吧,有的话在你YUM repos文件中增加一段

[myyum-ha]
name=olinux Myyum HA
baseurl=file:///mnt/HighAvailability
enabled=1
gpgcheck=0

评分

参与人数 1信誉积分 +5 收起 理由
nokiatao + 5 很给力!

查看全部评分

论坛徽章:
2
操作系统版块每日发帖之星
日期:2015-08-06 06:20:00IT运维版块每日发帖之星
日期:2015-08-15 06:20:00
发表于 2015-08-03 14:40 |显示全部楼层
果然然可以了,感谢楼上的这位通过了 思科、IBM、oracle数据库、红帽认证的全能高手。

论坛徽章:
2
操作系统版块每日发帖之星
日期:2015-08-06 06:20:00IT运维版块每日发帖之星
日期:2015-08-15 06:20:00
发表于 2015-08-03 17:16 |显示全部楼层
phanx 发表于 2015-08-03 12:44
回复 1# 草中宝

看看你的/mnt下面有HighAvailability这个目录吧,有的话在你YUM repos文件中增加一段



按照 phanx 高手的指导,我把 cman、ricci、rgmanger 装上去了,但是在装 gfs2 的时候,报错
# yum install gfs2-utils
Loaded plugins: refresh-packagekit, security
Setting up Install Process
No package gfs2-utils available.
Error: Nothing to do

# yum search gfs2
Loaded plugins: refresh-packagekit, security
Warning: No matches found for: gfs2
No Matches found

但 gfs2-utils 是存在的啊,如下
# ls -l /mnt/Packages/gfs*
-rw-r--r-- 1 root root 305888 11月 22 2013 /mnt/Packages/gfs2-utils-3.0.12.1-59.el6.x86_64.rpm

再请教下phanx和其他的各位高手,这是咋回事呢?

论坛徽章:
2
操作系统版块每日发帖之星
日期:2015-08-06 06:20:00IT运维版块每日发帖之星
日期:2015-08-15 06:20:00
发表于 2015-08-03 17:29 |显示全部楼层
可以了,还是按照 phanx 高手的方法,照样画葫芦,把 /mnt/ResilientStorage 加上去就可以了。

论坛徽章:
136
2022北京冬奥会纪念版徽章
日期:2015-08-07 17:10:5719周年集字徽章-庆
日期:2019-08-27 13:28:5615-16赛季CBA联赛之福建
日期:2019-09-10 11:43:25
发表于 2015-08-04 12:22 |显示全部楼层
很多词汇都没见过啊,感觉高大上的样子

论坛徽章:
0
发表于 2015-08-04 19:05 |显示全部楼层
你用的是什么版本的?感觉你的yum源配置的不完整啊, 装软件的时候很容易导致缺少某个包。
凡是目录中包含了XXX.repo的文件,都可以作为yum的安装目录, 只是需求的软件包不一样而已。

论坛徽章:
381
CU十二周年纪念徽章
日期:2014-01-04 22:46:58CU大牛徽章
日期:2013-03-13 15:32:35CU大牛徽章
日期:2013-03-13 15:38:15CU大牛徽章
日期:2013-03-13 15:38:52CU大牛徽章
日期:2013-03-14 14:08:55CU大牛徽章
日期:2013-04-17 11:17:19CU大牛徽章
日期:2013-04-17 11:17:32CU大牛徽章
日期:2013-04-17 11:17:37CU大牛徽章
日期:2013-04-17 11:17:42CU大牛徽章
日期:2013-04-17 11:17:47CU大牛徽章
日期:2013-04-17 11:17:52CU大牛徽章
日期:2013-04-17 11:17:56
发表于 2015-08-05 13:36 |显示全部楼层
默认安装完成之后就有一个Centos_media的repo文件,修改里面的enable=1应该就可以用了吧

论坛徽章:
2
操作系统版块每日发帖之星
日期:2015-08-06 06:20:00IT运维版块每日发帖之星
日期:2015-08-15 06:20:00
发表于 2015-08-07 17:54 |显示全部楼层
回复 7# hclqfn


是Oracle Linux 6.5
谢谢指导

论坛徽章:
2
操作系统版块每日发帖之星
日期:2015-08-06 06:20:00IT运维版块每日发帖之星
日期:2015-08-15 06:20:00
发表于 2015-08-07 17:55 |显示全部楼层
回复 8# chenyx


    谢谢指导
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

SACC2019中国系统架构师大会

【数字转型 架构演进】SACC2019中国系统架构师大会
2019年10月31日~11月2日第11届中国系统架构师大会(SACC2019)将在北京隆重召开。四大主线并行的演讲模式,1个主会场、20个技术专场、超千人参与的会议规模,100+来自互联网、金融、制造业、电商等领域的嘉宾阵容,将为广大参会者提供一场最具价值的技术交流盛会。




----------------------------------------

大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP