免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
12下一页
最近访问板块 发新帖
查看: 1633 | 回复: 13

snort安装出问题了,大虾进来看看 [复制链接]

论坛徽章:
0
发表于 2004-10-11 14:59 |显示全部楼层
系统是redhat as3,已经装好了mysql-3.23.58,libpcap-0.8.3,openssl-0.9.7d,没出什么问题一切正常,
当装snort-2.2.0进行./configure --enable-flexresp --with-mysql=/usr/local/mysql --with-openssl=/usr/local/ssl操作时提示了ERROR! Libpcre header not found, go get it from ,
按提示下了一个pcre-4.3装上了,继续装又提示
ERROR! Libnet header not found  如果已经安装,可以用--with-libnet-* 选项,
按提示有下了一个libnet.tar.gz装上了,继续./configure --enable-flexresp --with-mysql=/usr/local/mysql --with-openssl=/usr/local/ssl装提示
./configure: line 1: libnet-config: command not found
./configure: line 1: libnet-config: command not found
./configure: line 1: libnet-config: command not found
./configure: line 1: libnet-config: command not found
checking libnet.h usability... yes
checking libnet.h presence... yes
checking for libnet.h... yes
checking for libnet version 1.0.2a... ./configure: line 1: libnet-config: command not found
no


**********************************************
  ERROR: unable to find libnet 1.0.2a (libnet.h)
  checked in the following places
**********************************************
我有试了用--with-libnet-* 选项装可是提示
configure: error: invalid package name: libnet-*
大虾们帮帮忙吧!!!!!!!

论坛徽章:
0
发表于 2004-10-11 15:58 |显示全部楼层

snort安装出问题了,大虾进来看看

顶一下

论坛徽章:
0
发表于 2004-10-11 16:42 |显示全部楼层

snort安装出问题了,大虾进来看看

再顶一下

论坛徽章:
0
发表于 2004-10-11 16:57 |显示全部楼层

snort安装出问题了,大虾进来看看

安装libnet

论坛徽章:
0
发表于 2004-10-12 11:42 |显示全部楼层

snort安装出问题了,大虾进来看看

libnet我装了呀!就是看到提示才装的呀!文件名是libnet.tar.gz版本是最新的1.1.21,为什么呀!!!!!!!!!!

论坛徽章:
0
发表于 2004-10-12 11:58 |显示全部楼层

snort安装出问题了,大虾进来看看

libnet怎么装的?
snort-2.2.0编译参数里libnet又是怎么设置的?
你提供的资料太少了

论坛徽章:
0
发表于 2004-10-12 13:41 |显示全部楼层

snort安装出问题了,大虾进来看看

libnet就是./configure 然后make,然后make install呀!
snort-2.2.0编译参数里按提示如果装了libnet就用--with-libnet-*参数,但是我用了不好使呀!提示configure: error: invalid package name: libnet-*
我是用./configure --enable-flexresp --with-mysql=/usr/local/mysql --with-openssl=/usr/local/ssl --with-libnet-*命令装的。

论坛徽章:
0
发表于 2004-10-13 08:08 |显示全部楼层

snort安装出问题了,大虾进来看看

顶一下

论坛徽章:
0
发表于 2004-10-13 08:16 |显示全部楼层

snort安装出问题了,大虾进来看看

有这两个参数
 --with-libnet-includes=DIR   libnet include directory
 --with-libnet-libraries=DIR  libnet library directory
你指定路径了吗?你知道你的libnet被安装在哪里了吗?指定的路径对吗?

论坛徽章:
0
发表于 2004-10-13 08:24 |显示全部楼层

snort安装出问题了,大虾进来看看

--enable-flexresp 的话要就有
checking for libnet version 1.0.2a    (版本)
安装完libnet.tar.gz,就会有 libnet-config这个命令。
自己测试一下吧。
另外 --with-mysql=应该是:
--with-mysql=/usr
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP