忘记密码   免费注册 查看新帖 |

ChinaUnix.net

  平台 论坛 博客 文库 频道自动化运维 虚拟化 储存备份 C/C++ PHP MySQL 嵌入式 Linux系统
最近访问板块 发新帖
查看: 1680 | 回复: 9

[系统管理] 为何使用了yum仍然会被要求解决依赖关系 [复制链接]

论坛徽章:
1
2015年迎新春徽章
日期:2015-03-04 09:51:16
发表于 2016-09-07 15:57 |显示全部楼层
想装个mariadb,使用了yum进行安装,源用的mariadb官网提供的源,结果还是提示依赖关系解决不了
[root@nginx_S yum.repos.d]# yum install MariaDB
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package MariaDB-server.x86_64 0:10.1.17-1.el7.centos will be installed
--> Processing Dependency: libsystemd-daemon.so.0(LIBSYSTEMD_DAEMON_31)(64bit) for package: MariaDB-server-10.1.17-1.el7.centos.x86_64
--> Processing Dependency: MariaDB-common for package: MariaDB-server-10.1.17-1.el7.centos.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: MariaDB-server-10.1.17-1.el7.centos.x86_64
--> Processing Dependency: galera for package: MariaDB-server-10.1.17-1.el7.centos.x86_64
--> Processing Dependency: MariaDB-client for package: MariaDB-server-10.1.17-1.el7.centos.x86_64

。。。。。省略部分
Error: Package: MariaDB-server-10.1.17-1.el7.centos.x86_64 (mariadb)
           Requires: libsystemd-daemon.so.0()(64bit)
Error: Package: galera-25.3.17-1.rhel7.el7.centos.x86_64 (mariadb)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: galera-25.3.17-1.rhel7.el7.centos.x86_64 (mariadb)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

论坛徽章:
15
巨蟹座
日期:2014-11-20 23:04:5215-16赛季CBA联赛之四川
日期:2016-11-21 00:16:50操作系统版块每日发帖之星
日期:2016-07-28 06:20:0015-16赛季CBA联赛之吉林
日期:2016-05-25 15:36:04操作系统版块每日发帖之星
日期:2016-02-12 06:20:002015亚冠之西悉尼流浪者
日期:2015-08-28 14:48:322015亚冠之平阳省
日期:2015-08-19 14:54:162015亚冠之武里南联
日期:2015-07-07 10:49:112015亚冠之城南
日期:2015-06-22 10:15:002015亚冠之山东鲁能
日期:2015-06-18 18:03:442015亚冠之阿尔萨德
日期:2015-06-18 08:04:59操作系统版块每日发帖之星
日期:2015-06-10 22:20:00
发表于 2016-09-07 19:34 |显示全部楼层
因为yum尝试帮你解决依赖问题,但是失败,因为只是程序罢了,不是啥情况都能解决

求职 : Linux运维
论坛徽章:
203
拜羊年徽章
日期:2015-03-03 16:15:432015年辞旧岁徽章
日期:2015-03-03 16:54:152015年迎新春徽章
日期:2015-03-04 09:57:092015小元宵徽章
日期:2015-03-06 15:58:182015年亚洲杯之约旦
日期:2015-04-05 20:08:292015年亚洲杯之澳大利亚
日期:2015-04-09 09:25:552015年亚洲杯之约旦
日期:2015-04-10 17:34:102015年亚洲杯之巴勒斯坦
日期:2015-04-10 17:35:342015年亚洲杯之日本
日期:2015-04-16 16:28:552015年亚洲杯纪念徽章
日期:2015-04-27 23:29:17操作系统版块每日发帖之星
日期:2015-06-06 22:20:00操作系统版块每日发帖之星
日期:2015-06-09 22:20:00
发表于 2016-09-07 20:43 |显示全部楼层
编译安装把         

1人打赏

论坛徽章:
379
CU十二周年纪念徽章
日期:2014-01-04 22:46:58CU大牛徽章
日期:2013-03-13 15:32:35CU大牛徽章
日期:2013-03-13 15:38:15CU大牛徽章
日期:2013-03-13 15:38:52CU大牛徽章
日期:2013-03-14 14:08:55CU大牛徽章
日期:2013-04-17 11:17:19CU大牛徽章
日期:2013-04-17 11:17:32CU大牛徽章
日期:2013-04-17 11:17:37CU大牛徽章
日期:2013-04-17 11:17:42CU大牛徽章
日期:2013-04-17 11:17:47CU大牛徽章
日期:2013-04-17 11:17:52CU大牛徽章
日期:2013-04-17 11:17:56
发表于 2016-09-09 08:58 |显示全部楼层
不应该啊,按道理,Mariadb现在已经集成到Centos里面了,用自己本身的源,也能安装上.
楼主还是检查下,看看有没有别的原因吧

1人打赏

论坛徽章:
210
2022北京冬奥会纪念版徽章
日期:2015-08-10 16:30:322015亚冠之全北现代
日期:2016-05-11 17:05:27操作系统版块每日发帖之星
日期:2016-05-10 19:23:04操作系统版块每日发帖之星
日期:2016-05-10 19:23:04操作系统版块每日发帖之星
日期:2016-05-10 19:23:04操作系统版块每日发帖之星
日期:2016-05-10 19:23:04操作系统版块每日发帖之星
日期:2016-05-10 19:22:58数据库技术版块每日发帖之星
日期:2016-05-10 19:23:04数据库技术版块每日发帖之星
日期:2016-05-10 19:23:04操作系统版块每日发帖之星
日期:2016-05-10 19:22:58操作系统版块每日发帖之星
日期:2016-05-10 19:22:58操作系统版块每日发帖之星
日期:2016-05-10 19:22:58
发表于 2016-12-04 22:16 |显示全部楼层
源用的mariadb官网提供的源



这话什么意思??我没看明白

论坛徽章:
0
发表于 2017-01-02 10:47 |显示全部楼层
yum源里面没有报错的那三个包。所以无法安装

论坛徽章:
0
发表于 2017-01-02 15:21 |显示全部楼层
yum源安装巨坑   
来自安卓客户端来自客户端

论坛徽章:
34
亥猪
日期:2015-03-20 13:55:11戌狗
日期:2015-03-20 13:57:01酉鸡
日期:2015-03-20 14:03:56未羊
日期:2015-03-20 14:18:30子鼠
日期:2015-03-20 14:20:14丑牛
日期:2015-03-20 14:20:31辰龙
日期:2015-03-20 14:35:34巳蛇
日期:2015-03-20 14:35:56操作系统版块每日发帖之星
日期:2015-11-06 06:20:00操作系统版块每日发帖之星
日期:2015-11-08 06:20:00操作系统版块每日发帖之星
日期:2015-11-19 06:20:00黄金圣斗士
日期:2015-11-24 10:43:13
发表于 2017-01-03 16:12 |显示全部楼层
yum update ?

论坛徽章:
0
发表于 2018-02-26 09:19 |显示全部楼层
因为你要安装的这个程序所需要的某个包在当前的Yum源里没有

论坛徽章:
0
发表于 2018-03-06 10:56 |显示全部楼层
可以尝试使用yum reinstall将报错的包重新安装下,然后再使用Yum安装maridb。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号 北京市公安局海淀分局网监中心备案编号:11010802020122
广播电视节目制作经营许可证(京) 字第1234号 中国互联网协会会员  联系我们:wangnan@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP