忘记密码   免费注册 查看新帖 | 论坛精华区

ChinaUnix.net

  平台 论坛 博客 认证专区 大话IT 视频 徽章 文库 沙龙 自测 下载 频道自动化运维 虚拟化 储存备份 C/C++ PHP MySQL 嵌入式 Linux系统
最近访问板块 发新帖
查看: 251 | 回复: 3

[FreeBSD] 升级pkg失败, 安装低版本pkg失败。 [复制链接]

论坛徽章:
1
IT运维版块每日发帖之星
日期:2016-03-01 06:20:00
发表于 2017-03-12 18:18 |显示全部楼层
今天为服务器: FreeBSD 10.1-RELEASE-p35  安装php的bzip2模块,提示可以升级pkg至pkg-1.10.0_2,没怎么思考,按y ,结果后悔了,
安装不成功,提示信息忘保存了。
结果,pkg 再也不能用了。
尝试安装低版本的pkg:
pkg-static install -f /var/cache/pkg/pkg-1.8.3.txz



结果提示:
pkg-static: warning: database version 34 is newer than libpkg(3) version 33, but still compatible
pkg-static: sqlite error while executing INSERT OR ROLLBACK INTO pkg_search(id, name, origin) VALUES (?1, ?2 || '-' || ?3, ?4); in file pkgdb.c:1544: no such table: pkg_search



利用ports安装也同样有这个问题,是不是pkg数据库出错了?怎么解决?

论坛徽章:
2
双子座
日期:2014-05-18 22:44:102015年迎新春徽章
日期:2015-03-04 09:58:11
发表于 2017-03-13 13:32 |显示全部楼层
pkg有个修复的命令 你可以尝试下

论坛徽章:
0
发表于 2017-03-13 23:04 |显示全部楼层
这个是因为官方已经停止对FB10.1、10.2的技术支持,即使退回到低版本,还是有很多问题。
彻底的解决这个,就是升级到10.3,或者11.0

论坛徽章:
0
发表于 2017-03-13 23:05 |显示全部楼层
我今天因为这个,和阿里云已经扯皮很久了
您需要登录后才可以回帖 登录 | 注册

本版积分规则

  

北京皓辰网域网络信息技术有限公司. 版权所有 京ICP证:060528号 北京市公安局海淀分局网监中心备案编号:1101082001
广播电视节目制作经营许可证(京) 字第1234号 中国互联网协会会员  联系我们:
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP