忘记密码   免费注册 查看新帖 |

ChinaUnix.net

  平台 论坛 博客 文库 频道自动化运维 虚拟化 储存备份 C/C++ PHP MySQL 嵌入式 Linux系统
最近访问板块 发新帖
查看: 1782 | 回复: 2

perl安装PDL模块的问题 [复制链接]

论坛徽章:
0
发表于 2017-11-20 11:09 |显示全部楼层
本帖最后由 skyheight 于 2017-11-20 11:11 编辑

我是windows系统,64位activeperl,按照PDL网站上的提示安装PDL模块。到安装OpenGL和PDL的时候安装不上去,见下。求教是什么原因啊?自学perl俩月,感觉自己真是啥都不懂,愁死了。。。

  1. C:\Users\61068>ppm install http://www.sisyphusion.tk/ppm/OpenGL.ppd
  2. ppm install failed: Can't find any package that provides PPM-Sisyphusion for OpenGL
  3. Can't find any package that provides PPM::Sisyphusion for OpenGL

  4. C:\Users\61068>ppm install http://www.sisyphusion.tk/ppm/PDL.ppd
  5. ppm install failed: Can't find any package that provides File-Map for PDL
  6. Can't find any package that provides File::Map for PDL
  7. Can't find any package that provides PPM-Sisyphusion for PDL
  8. Can't find any package that provides PPM::Sisyphusion for PDL
  9. Can't find any package that provides OpenGL for PDL
复制代码

http://pdl.perl.org/?page=install网站给出的安装方法:
        Easiest install - Windows                To install via ppm for Strawberry        Perl (32-bit only) and ActiveState        Perl (32-bit and 64-bit):
  1. ppm install Astro-FITS-Header
  2. ppm install Convert-UU
复制代码
Then install the OpenGL, PGPLOT and PDL modules from the sisyphusion repo by running:  For 32-bit builds of perl (versions 5.8 and later):
  1. ppm install http://www.sisyphusion.tk/ppm/OpenGL.ppd
  2. ppm install http://www.sisyphusion.tk/ppm/PGPLOT.ppd
  3. ppm install http://www.sisyphusion.tk/ppm/PDL.ppd
复制代码
For 64-bit builds of perl, ppm packages are provided only for perl versions 5.10 and later.  Also, there are no PGPLOT packages for these builds - so just run:
  1. ppm install http://www.sisyphusion.tk/ppm/OpenGL.ppd
  2. ppm install http://www.sisyphusion.tk/ppm/PDL.ppd
复制代码
For more detailssee InstallingPDL on Windows on the wikior win32/INSTALLfile in the PDL source distribution.


TIM截图20171120111010.png

论坛徽章:
11
子鼠
日期:2014-10-11 16:46:4815-16赛季CBA联赛之山东
日期:2017-11-10 14:32:142016科比退役纪念章
日期:2017-09-02 15:42:4715-16赛季CBA联赛之佛山
日期:2017-08-28 17:11:5515-16赛季CBA联赛之浙江
日期:2017-08-24 16:55:1715-16赛季CBA联赛之青岛
日期:2017-08-17 19:55:2415-16赛季CBA联赛之天津
日期:2017-06-29 10:34:4315-16赛季CBA联赛之四川
日期:2017-05-16 16:38:55黑曼巴
日期:2016-07-19 15:03:112015亚冠之萨济拖拉机
日期:2015-05-22 11:38:532016科比退役纪念章
日期:2018-03-16 10:24:05
发表于 2017-11-22 14:43 |显示全部楼层
回复 1# skyheight

改用 StrawberryPerl 吧
http://strawberryperl.com/releases.html

推荐 v5.24 PDL edition,OpenGL模块最好从metacpan下载压缩包,
然后打开strawberry perl的环境设置脚本portableshell.bat ,进入解压目录
perl makefile.pl
dmake
dmake install

其他参考:
http://www.code-by.org/viewtopic.php?f=17&t=272

论坛徽章:
0
发表于 2017-11-25 18:11 |显示全部楼层
回复 2# 523066680

好的,我去试试。谢谢啦~
您需要登录后才可以回帖 登录 | 注册

本版积分规则

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号 北京市公安局海淀分局网监中心备案编号:11010802020122
广播电视节目制作经营许可证(京) 字第1234号 中国互联网协会会员  联系我们:wangnan@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP