免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 1321 | 回复: 3

linux编译问题 [复制链接]

论坛徽章:
0
发表于 2006-08-29 16:18 |显示全部楼层
我们有一套 RH 2.4.0-8 内核的linux系统,在连接一个动态库时总是提示如下信息:

g++: installation problem, cannot exec `cc1plus': 没有那个文件或目录
g++: installation problem, cannot exec `cc1plus': 没有那个文件或目录
g++: installation problem, cannot exec `cc1plus': 没有那个文件或目录
g++: installation problem, cannot exec `cc1plus': 没有那个文件或目录
g++: installation problem, cannot exec `cc1plus': 没有那个文件或目录
g++: installation problem, cannot exec `cc1plus': 没有那个文件或目录
g++: installation problem, cannot exec `cc1plus': 没有那个文件或目录


请教如何处理,谢谢

编译命令行如下:


g++ -D_LINUX_ -I/usr/include -I$ORACLE_HOME/precomp/public  -L$ORACLE_HOME/lib -L/back/app_dll  -belf -o saps_ltts main.c dbfunc.c  dbconn.c dbverify.c  servfunc.c  trimstr.c dbfile.c -ltpm -ltpmapi -lconv -lclntsh  -lnbeq9 -lnhost9 -lnus9  -lnldap9 -lldapclnt9 -lnsslb9 -ln9 -lncrypt9 -lnoname9 -lntcp9  -lntcps9  -lntns9 -lnsgr9 -lnzjs9 -lnl9 -lnro9 -lclient9  -lvsn9 -lwtc9  -lcommon9 -lgeneric9 -lmm -lnls9 -lcore9 -ltrace9 -lm -lstd++


其中-ltpm -ltpmapi -lconv是我们自行开发的连接库。请各位高手帮忙,谢谢!!!!!!

论坛徽章:
0
发表于 2006-08-29 16:19 |显示全部楼层
自己顶一下:是否GCC编译器安装有问题?

论坛徽章:
0
发表于 2006-08-29 16:21 |显示全部楼层
更正:版本为 RedHat Linux 2.4.20-8 (Shrike),谢谢

论坛徽章:
0
发表于 2006-08-29 22:06 |显示全部楼层
原帖由 d_y_liu 于 2006-8-29 16:18 发表
我们有一套 RH 2.4.0-8 内核的linux系统,在连接一个动态库时总是提示如下信息:

g++: installation problem, cannot exec `cc1plus': 没有那个文件或目录
g++: installation problem, cannot exec `cc1plus' ...

>>
>>
>>估计是gcc的安装不匹配系统造成的。你是如何安装的?建议安装系统默认的发行版本
>>
>>
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP