- 论坛徽章:
- 0
|
![]()
R1#
R1#sho run
Building configuration...
Current configuration : 1631 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable password en
!
ip subnet-zero
!
!
ip cef
no ip domain-lookup
ip host R1 1.1.1.1
ip host R2 2.2.2.2
ip host R3 3.3.3.3
ip host R4 4.4.4.4
ip host R5 5.5.5.5
mpls label protocol ldp
mpls traffic-eng tunnels
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
no ip directed-broadcast
!
interface Tunnel0
ip unnumbered Loopback0
no ip directed-broadcast
tunnel destination 4.4.4.4
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 5 5
tunnel mpls traffic-eng bandwidth 100
tunnel mpls traffic-eng path-option 10 explicit name te-lab
tunnel mpls traffic-eng fast-reroute
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface POS1/0
ip address 10.10.0.1 255.255.255.0
no ip directed-broadcast
mpls traffic-eng tunnels
tag-switching ip
ip rsvp bandwidth 1000 1000
ip rsvp signalling hello
!
interface POS2/0
no ip address
no ip directed-broadcast
shutdown
!
interface POS3/0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 100
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
!
ip explicit-path name te-lab enable
next-address 10.10.0.2
next-address 10.10.1.2
next-address 10.10.2.2
!
!
tag-switching tdp router-id Loopback0
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
password en
login
!
no cns aaa enable
end
R1#
R2#sho run
Building configuration...
Current configuration : 1683 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable password en
!
ip subnet-zero
!
!
ip cef
no ip domain-lookup
ip host R1 1.1.1.1
ip host R2 2.2.2.2
ip host R3 3.3.3.3
ip host R4 4.4.4.4
ip host R5 5.5.5.5
mpls label protocol ldp
mpls traffic-eng tunnels
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
no ip directed-broadcast
!
interface Tunnel0
ip unnumbered Loopback0
no ip directed-broadcast
tunnel destination 3.3.3.3
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 explicit name te-lab
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface POS1/0
ip address 10.10.0.2 255.255.255.0
no ip directed-broadcast
mpls traffic-eng tunnels
tag-switching ip
ip rsvp signalling hello
!
interface POS2/0
ip address 10.10.1.1 255.255.255.0
no ip directed-broadcast
mpls traffic-eng tunnels
tag-switching ip
ip rsvp bandwidth 1000 1000
ip rsvp signalling hello
!
interface POS3/0
ip address 192.168.0.1 255.255.255.0
no ip directed-broadcast
mpls traffic-eng tunnels
tag-switching ip
ip rsvp signalling hello
!
router ospf 100
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
ip rsvp signalling hello
!
ip explicit-path name te-lab enable
next-address 192.168.0.2
next-address 192.168.1.1
!
!
tag-switching tdp router-id Loopback0
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
password en
login
!
no cns aaa enable
end
R2#
R3>en
Password:
R3#sho run
Building configuration...
Current configuration : 1364 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable password en
!
ip subnet-zero
!
!
ip cef
no ip domain-lookup
ip host R1 1.1.1.1
ip host R2 2.2.2.2
ip host R3 3.3.3.3
ip host R4 4.4.4.4
ip host R5 5.5.5.5
mpls label protocol ldp
mpls traffic-eng tunnels
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
no ip directed-broadcast
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface POS1/0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
mpls traffic-eng tunnels
tag-switching ip
ip rsvp signalling hello
!
interface POS2/0
ip address 10.10.1.2 255.255.255.0
no ip directed-broadcast
mpls traffic-eng tunnels
tag-switching ip
ip rsvp bandwidth 1000 1000
ip rsvp signalling hello
!
interface POS3/0
ip address 10.10.2.1 255.255.255.0
no ip directed-broadcast
mpls traffic-eng tunnels
tag-switching ip
ip rsvp bandwidth 1000 1000
ip rsvp signalling hello
!
router ospf 100
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
!
!
tag-switching tdp router-id Loopback0
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
password en
login
!
no cns aaa enable
end
R3#
R4>en
Password:
R4#sho run
Building configuration...
Current configuration : 1196 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
enable password en
!
ip subnet-zero
!
!
ip cef
no ip domain-lookup
ip host R1 1.1.1.1
ip host R2 2.2.2.2
ip host R3 3.3.3.3
ip host R4 4.4.4.4
ip host R5 5.5.5.5
mpls label protocol ldp
mpls traffic-eng tunnels
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
no ip directed-broadcast
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface POS1/0
no ip address
no ip directed-broadcast
shutdown
!
interface POS2/0
no ip address
no ip directed-broadcast
shutdown
!
interface POS3/0
ip address 10.10.2.2 255.255.255.0
no ip directed-broadcast
mpls traffic-eng tunnels
tag-switching ip
ip rsvp bandwidth 1000 1000
ip rsvp signalling hello
!
router ospf 100
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
ip rsvp signalling hello
!
!
tag-switching tdp router-id Loopback0
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
password en
login
!
no cns aaa enable
end
R4#
R5>en
Password:
R5#sho run
Building configuration...
Current configuration : 1227 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
enable password en
!
ip subnet-zero
!
!
ip cef
no ip domain-lookup
ip host R1 1.1.1.1
ip host R2 2.2.2.2
ip host R3 3.3.3.3
ip host R4 4.4.4.4
ip host R5 5.5.5.5
mpls label protocol ldp
mpls traffic-eng tunnels
!
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
no ip directed-broadcast
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface POS1/0
ip address 192.168.1.2 255.255.255.0
no ip directed-broadcast
mpls traffic-eng tunnels
tag-switching ip
ip rsvp signalling hello
!
interface POS2/0
no ip address
no ip directed-broadcast
shutdown
!
interface POS3/0
ip address 192.168.0.2 255.255.255.0
no ip directed-broadcast
mpls traffic-eng tunnels
tag-switching ip
ip rsvp signalling hello
!
router ospf 100
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
!
!
tag-switching tdp router-id Loopback0
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
password en
login
!
no cns aaa enable
end
R5#
收敛测试
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/37/84 ms
R1#ping
Protocol [ip]:
Target IP address: 4.4.4.4
Repeat count [5]: 10000
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 10000, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!...!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
本文来自ChinaUnix博客,如果查看原文请点:http://blog.chinaunix.net/u/25055/showart_197743.html |
|