免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 4893 | 回复: 7

perl5.6.1如何安装Encode模块? [复制链接]

论坛徽章:
0
发表于 2008-07-15 10:23 |显示全部楼层
Encode-1.20.tar.gz
Encode-1.27.tar.gz
Encode-1.50.tar.gz
Encode-1.98.tar.gz
Encode-1.99.tar.gz
Encode-2.26.tar.gz

下载了这几个版本的Encode,编译安装的时候提示:
Perl v5.7.3 required--this is only v5.6.1, stopped at makefile.pl line 1.
BEGIN failed--compilation aborted at makefile.pl line 1.

哪位有好的解决方法?谢谢。

论坛徽章:
1
2015年辞旧岁徽章
日期:2015-03-03 16:54:15
发表于 2008-07-15 10:26 |显示全部楼层

论坛徽章:
0
发表于 2008-07-15 10:31 |显示全部楼层
Encode模块不是5.6里就自带了吗?

论坛徽章:
0
发表于 2008-07-15 10:34 |显示全部楼层
感谢flw,在我发帖之前我PM过你,不过系统拒绝了我PM。

论坛徽章:
0
发表于 2008-07-15 10:37 |显示全部楼层
不行呀,还是提示这个。

C:\Perl\temp\Encode-1.97>perl makefile.pl
Perl v5.7.3 required--this is only v5.6.1, stopped at makefile.pl line 1.
BEGIN failed--compilation aborted at makefile.pl line 1.

请问是这样编译吗?

[ 本帖最后由 likeytom 于 2008-7-15 11:13 编辑 ]

论坛徽章:
1
荣誉会员
日期:2011-11-23 16:44:17
发表于 2008-07-15 11:33 |显示全部楼层
你要安装1.4的版本...才有支援Perl 5.6.1..
找找看吧...记得先看README有告诉你适用那个版本的Perl

刚刚查过..都不行....
sorry...
如果是要转换成UTF-8...
可以考虑用其他的Module
http://search.cpan.org/~ehood/MHonArc-2.6.16/
http://search.cpan.org/~snowhare ... /pod/MapUTF8.en.pod

[ 本帖最后由 apile 于 2008-7-15 11:55 编辑 ]

论坛徽章:
0
发表于 2008-07-15 11:59 |显示全部楼层
谢谢apile。

我想问一下我这样编译是不是正确?
perl Makefile.PL
Make
Make test

需要C环境吗?

论坛徽章:
1
荣誉会员
日期:2011-11-23 16:44:17
发表于 2008-07-15 17:38 |显示全部楼层
需要gcc...或你OS带的C/C++ compiler...例如
AIX的visual age c++
重点是要跟perl用同样的compiler 去编译才成..
perl -V可以看到你的perl是用什麽C++ 编译的...

[ 本帖最后由 apile 于 2008-7-15 17:44 编辑 ]
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP