- 论坛徽章:
- 0
|
Problem Description
给定一个日期,输出这个日期是该年的第几天。
Input
输入数据有多组,每组占一行,数据格式为YYYY/MM/DD组成,具体参见sample input ,另外,可以向你确保所有的输入数据是合法的。
Output
对于每组输入数据,输出一行,表示该日期是该年的第几天。
Sample Input
1985/1/20
2006/3/12
Sample Output
20
71
根据这道题下面的程序哪边错了??
#include<stdio.h>
int main()
{
int a,b,c;
int d[12]={31,28,31,30,31,30,31,31,30,31,30,31};
int e[12]={31,29,31,30,31,30,31,31,30,31,30,31};
while(scanf("%d/%d/%d",&a,&b,&c)!=EOF)
{
int t=0;
if((a%4==0&&a%100!=0)||a%400==0)
{
for(int i=1;i<b;i++)
{
t=t+e;
}
}
else
{
for(int j=1;j<b;j++)
{
t=t+d[j];
}
}
t=t+c;
printf("%d\n",t);
}
return 0;
} |
|