免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 1419 | 回复: 0

详细CSICO VTP协议配置及实验(图) [复制链接]

论坛徽章:
0
发表于 2009-09-11 10:31 |显示全部楼层


  Normal
  0
  
  7.8 磅
  0
  2
  
  false
  false
  false
  
   
   
   
   
   
   
   
   
   
   
   
   
  
  MicrosoftInternetExplorer4



st1\:*{behavior:url(#ieooui) }
/* Style Definitions */
table.MsoNormalTable
        {mso-style-name:普通表格;
        mso-tstyle-rowband-size:0;
        mso-tstyle-colband-size:0;
        mso-style-noshow:yes;
        mso-style-parent:"";
        mso-padding-alt:0cm 5.4pt 0cm 5.4pt;
        mso-para-margin:0cm;
        mso-para-margin-bottom:.0001pt;
        mso-pagination:widow-orphan;
        font-size:10.0pt;
        font-family:"Times New Roman";
        mso-ansi-language:#0400;
        mso-fareast-language:#0400;
        mso-bidi-language:#0400;}
               
丫丫网络
本博客地址:http://hi.baidu.com/52hack

详细CSICO VTP协议配置及实验(图)
2009年08月02日 星期日 上午 01:16

详细CSICO VTP协议配置及实验
实验名称 VTP配置

实验目的: 使其整个内部网络能够互相学习VTP协议实验要求:

1. 保证4台交换机能够学习到VTP协议

2. 将SW3交换机设置为透明模式且能够让其他交换机学习到VTP协议

3. 将SW3设置与其他交换属于不同的域并且其他交换机能够学习VTP协议;

实验拓扑

实验拓扑



实验步骤

S1配置:

Router>enable 进入特权模式

Router#config terminal

Enter configuration commands, one per line.
End with CNTL/Z.

Router(config)#hostname s1 命名为S1

s1(config)#exit 退出

s1#vlan database 进入配置VLAN模式

s1(vlan)#vtp domain zixu vtp域名为zixu

s1(vlan)#vtp server vtp模式为server

s1(vlan)#vtp password zixu 密码为zixu

s1(vlan)#vtp v2-mode vtp版本号为2

s1(vlan)#vtp pruning 配置修建s1(vlan)#exit

s1#config terminal 全局模式

s1(config)#interface f0/0 进入指定的端口号

s1(config-if)#switchport mode trunk 将0/0配置中继链路(trunk)

s1(config-if)#no shut 激活模式

s1(config)#interface f0/14

s1(config-if)#switchport mode trunk

s1(config-if)#no shuts1(config-if)#exit

s1(config)#interface f0/15

s1(config-if)#switchport mode trunk

s1(config-if)#no shut

s1(config-if)#exits1(config)#exit

s1#vlan database

s1(vlan)#vlan 2 创建VLAN

s1(vlan)#vlan 3

s1(vlan)#vlan 4

s1(vlan)#exit

S2配置:

Router>enable

Router#config terminal

Router(config)#hostname s2

s2(config)#exits2#vlan database

s2(vlan)#vtp domain zixu 指定域名

s2(vlan)#vtp client 配置为客户机

s2(vlan)#vtp password zixu 制定密码zixu

s2(vlan)#vtp v2-mode 配置一致的版本V2

s2(vlan)#exits2#config terminal

s2(config)#interface f0/0

s2(config-if)#switchport mode trunk

s2(config-if)#no shut

s2(config-if)#exit

s2(config)#interface f0/14

s2(config-if)#switchport mode trunk

s2(config-if)#no shut

s2(config)#interface f0/15

s2(config-if)#switchport mode trunk

s2(config-if)#no shut

s2(config-if)#exit

s2(config)#interface f0/14

s2(config-if)#switchport mode trunk

s2(config-if)#no shut

s2(config-if)#exit

s2(config)#exit

s2#show vlan-switch

S3配置:Router>enableRouter#config terminal

Router(config)#hostname s3

s3(config)#exits3#vlan database

s3(vlan)#vtp domain zixu

s3(vlan)#vtp client

s3(vlan)#vtp password zixu

s3(vlan)#vtp v2-mode

s3(vlan)#exits3#config t

s3#config terminal

s3(config)#interface f0/14

s3(config-if)#switchport mode trunk

s3(config-if)#no shut

s3(config-if)#exit

s3(config)#interface f0/15

s3(config-if)#switchport mode trunk

s3(config-if)#no shut

s3(config-if)#no shutdown

s3(config-if)#exit

s3(config)#exit

s3#show vlan-switch

S4配置:

Router>enable

Router#config terminal

Router(config)#hostname s4

s4(config)#exits4#vlan database

s4(vlan)#vtp domain zixu

s4(vlan)#vtp client

s4(vlan)#vtp password zixu

s4(vlan)#vtp v2-modes4(vlan)#exit

s4#config terminal

s4(config)#interface f0/14

s4(config-if)#switchport mode trunk

s4(config-if)#no shuts4(config-if)#exit

s4(config)#interface f0/15

s4(config-if)#switchport mode trunk

s4(config-if)#no shut

s4(config-if)#exit

s4(config)#exit

s4#show vlan-switch

实验要求2只需在S3交换机上做以下配置,其中在SW1交换机中创建vlan ,在其他交换机中能否学习到;

s3#

s3#vlan database

s3(vlan)#vtp transparent 透明模式

s3(vlan)#exit

s3#show vlan-switch 查看vlan信息

实验要求3只需在S3交换机上做以下配置,其中在SW1交换机中创建vlan ,在其他交换机中能否学习到;

s3#

s3#vlan database

s3(vlan)#vtp domain qien 配置域名为qien

s3(vlan)#exits3#show vlan-switch

实验结果分析: 通过以上三个要求及实验步骤完全可以实现学习VTP协议及配置

实验结论: Vtp协议分为三种模式:server、client、transparent

Server功能:可以创建、删除及修改vlan信息,可以学习及转发

Client功能:不可以创建、删除及修改vlan信息,可以学习及转发

Transparent功能:可以创建、删除及修改vlan信息(本地生效),可以转发,不学习其他VTP协议

VTP协议中有2种版本:v1、v2V2支持不同域可以转发其他交换机的信息

查询结果






上一篇:保护账号安全 巨盾网游安全盾(图...    下一篇:浅谈Eval解密之——工具篇2(图)


               
               
               

本文来自ChinaUnix博客,如果查看原文请点:http://blog.chinaunix.net/u/18309/showart_2050161.html
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

DTCC2020中国数据库技术大会

【架构革新 高效可控】2020年12月21日-23日第十一届中国数据库技术大会将在北京隆重召开。

大会设置2大主会场,20+技术专场,将邀请超百位行业专家,重点围绕数据架构、AI与大数据、传统企业数据库实践和国产开源数据库等内容展开分享和探讨,为广大数据领域从业人士提供一场年度盛会和交流平台。

http://dtcc.it168.com


大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP