忘记密码   免费注册 查看新帖 |

ChinaUnix.net

  平台 论坛 博客 文库 频道自动化运维 虚拟化 储存备份 C/C++ PHP MySQL 嵌入式 Linux系统
12下一页
最近访问板块 发新帖
查看: 6042 | 回复: 11

ActiveState Perl Dev Kit的perlapp生成exe就报错 [复制链接]

论坛徽章:
0
发表于 2011-02-15 18:50 |显示全部楼层
本帖最后由 qinglangee 于 2011-02-16 22:49 编辑

perlapp不知道有用过的没有

.pl脚本文件没问题,能运行
生成exe时勾上 Make dependent executable也没问题,跟脚本一样运行

但生成独立exe程序,就不能运行了
Can't locate object method "new" via package "HTML::TreeBuilder::XPath" at /<D:\temp\aaa.exe>Web/Scraper.pm line 124.


-------------------------
根据二楼的方子搞定了
use HTML::TreeBuilder;
use HTML::TreeBuilder::XPath;
两行都加上,又出了个找不到的模块,装上就好了

论坛徽章:
46
15-16赛季CBA联赛之四川
日期:2018-03-27 11:59:132015年亚洲杯之沙特阿拉伯
日期:2015-04-11 17:31:45天蝎座
日期:2015-03-25 16:56:49双鱼座
日期:2015-03-25 16:56:30摩羯座
日期:2015-03-25 16:56:09巳蛇
日期:2015-03-25 16:55:30卯兔
日期:2015-03-25 16:54:29子鼠
日期:2015-03-25 16:53:59申猴
日期:2015-03-25 16:53:29寅虎
日期:2015-03-25 16:52:29羊年新春福章
日期:2015-03-25 16:51:212015亚冠之布里斯班狮吼
日期:2015-07-13 10:44:56
发表于 2011-02-15 19:51 |显示全部楼层
加上 use HTML::TreeBuilder::XPath 这个模块估计是动态导入的,没被识别出来

论坛徽章:
0
发表于 2011-02-15 21:04 |显示全部楼层
试了下,加上也是不行

论坛徽章:
0
发表于 2011-02-15 21:35 |显示全部楼层
难道加过了还是同样的错误????

论坛徽章:
0
发表于 2011-02-15 21:38 |显示全部楼层
难道加过了还是同样的错误????
socyno 发表于 2011-02-15 21:35


是一样的

论坛徽章:
0
发表于 2011-02-15 22:06 |显示全部楼层
回复 5# qinglangee


    就这个错误来看似乎也确实不像是这个模块没有打包,而似乎找不到 new 这个方法, 我看了看源码

发现个怪怪的地方,不知道有没有关系, 可以尝试去掉第二个试试看会不会有用:

package HTML::TreeBuilder::XPath;
use List::Util qw( first);

use strict;
use warnings;

use vars qw($VERSION);

$VERSION = '0.12';

my %CHAR2DEFAULT_ENT= ( '&' => '&amp;', '<' => '&lt;', '>' => '&gt;', '"' => '&quot;');
my %NUM2DEFAULT_ENT= ( '38' => 'amp', '60' => 'lt', '62' => 'gt', '"' => '&quot;');

package HTML::TreeBuilder::XPath;
use base( 'HTML::TreeBuilder');

论坛徽章:
0
发表于 2011-02-15 22:38 |显示全部楼层
回复 6# socyno

试过了,也不行

论坛徽章:
46
15-16赛季CBA联赛之四川
日期:2018-03-27 11:59:132015年亚洲杯之沙特阿拉伯
日期:2015-04-11 17:31:45天蝎座
日期:2015-03-25 16:56:49双鱼座
日期:2015-03-25 16:56:30摩羯座
日期:2015-03-25 16:56:09巳蛇
日期:2015-03-25 16:55:30卯兔
日期:2015-03-25 16:54:29子鼠
日期:2015-03-25 16:53:59申猴
日期:2015-03-25 16:53:29寅虎
日期:2015-03-25 16:52:29羊年新春福章
日期:2015-03-25 16:51:212015亚冠之布里斯班狮吼
日期:2015-07-13 10:44:56
发表于 2011-02-16 11:42 |显示全部楼层
你 use HTML::TreeBuilder 了吗?这个模块的 new 应该是继承自它的

论坛徽章:
0
发表于 2011-02-16 19:59 |显示全部楼层
回复 8# zhlong8


    我想应该不是这个问题,既然 HTML::TreeBuilder 没有打包的话,那么程序运行到 use base ('HTML::TreeBuilder') 的时候就应该会报错的吧,而不是等到调用 HTML::TreeBuilder::XPath->new() 的时候才报错

论坛徽章:
0
发表于 2011-02-16 20:34 |显示全部楼层
回复 8# zhlong8


    我刚才自己试了下,还真是这个问题,挺奇怪的
您需要登录后才可以回帖 登录 | 注册

本版积分规则

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号 北京市公安局海淀分局网监中心备案编号:11010802020122
广播电视节目制作经营许可证(京) 字第1234号 中国互联网协会会员  联系我们:wangnan@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP