免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 3874 | 回复: 2

sqlserver不通 [复制链接]

论坛徽章:
0
发表于 2011-03-01 13:34 |显示全部楼层
提示错误 连接失败Sqlstate :'01000' Sql server错误:1326 [Microsoft][OD_sql ...
30 个帖子 - 5 个作者 - 新贴子:
登录远程SQL服务器
一 看ping 服务器IP能否ping通。

  这个实际上是看和远程sql server 2000服务器的物理连接是否存在。如果不行,请检查网络,查看配置,当然得确保远程sql server 2000服务器的IP拼写正确。

  二 在Dos或命令行下输入telnet 服务器IP 端口,看能否连通。

  如telnet 202.114.100.100 1433

  通常端口值是1433,因为1433是sql server 2000的对于Tcp/IP的默认侦听端口。如果有问题,通常这一步会出问题。通常的提示是“……无法打开连接,连接失败"。

  如果这一步有问题,应该检查以下选项。

  1 检查远程服务器是否启动了sql server 2000服务。如果没有,则启动。

  2 检查服务器端有没启用Tcp/IP协议,因为远程连接(通过因特网)需要靠这个协议。检查方法是,在服务器上打开开始菜单->程序->Microsoft SQL Server->服务器网络实用工具,看启用的协议里是否有tcp/ip协议,如果没有,则启用它。

  3 检查服务器的tcp/ip端口是否配置为1433端口。仍然在服务器网络实用工具里查看启用协议里面的tcp/ip的属性,确保默认端口为1433,并且隐藏服务器复选框没有勾上。

  事实上,如果默认端口被修改,也是可以的,但是在客户端做telnet测试时,写服务器端口号时必须与服务器配置的端口号保持一致。如果隐藏服务器复选框被勾选,则意味着客户端无法通过枚举服务器来看到这台服务器,起到了保护的作用,但不影响连接,但是Tcp/ip协议的默认端口将被隐式修改为 2433,在客户端连接时必须作相应的改变。

  4 如果服务器端操作系统打过sp2补丁,则要对windows防火墙作一定的配置,要对它开放1433端口,通常在测试时可以直接关掉windows防火墙(其他的防火墙也关掉最好)。

  5 检查服务器是否在1433端口侦听。如果服务器没有在tcp连接的1433端口侦听,则是连接不上的。检查方法是在服务器的dos或命令行下面输入

  netstat -a -n 或者是netstat -an,在结果列表里看是否有类似 tcp 127.0.0.1 1433 listening 的项。如果没有,则通常需要给sql server 2000打上至少sp3的补丁。其实在服务器端启动查询分析器,输入 select @@version 执行后可以看到版本号,版本号在8.0.2039以下的都需要打补丁。

  如果以上都没问题,这时你再做telnet 服务器ip 1433 测试,将会看到屏幕一闪之后光标在左上角不停闪动。恭喜你,你马上可以开始在企业管理器或查询分析器连接了。

  三 检查客户端设置

  程序->Microsoft SQL Server -> 客户端网络使用工具。像在服务器网络实用工具里一样,确保客户端tcp/ip协议启用,并且默认端口为1433(或其他端口,与服务器端保持一致就行)。

  四 在企业管理器里或查询那分析器连接测试

  企业管理器->右键SQlserver组->新建sqlserver注册->下一步->写入远程IP->下一步 ->选Sqlserver登陆->下一步->写入登陆名与密码(sa,password)->下一步->下一步-> 完成

  查询分析器->文件->连接->写入远程IP->写入登录名和密码(sa,password)->确定

  通常建议在查询分析器里做,因为默认情况下,通过企业管理器注册另外一台SQL Server的超时设置是4秒,而查询分析器是15秒。

  修改默认连接超时的方法:

  企业管理器->工具->选项->在弹出的"SQL Server企业管理器属性"窗口中,点击"高级"选项卡->连接设置->在 登录超时(秒) 后面的框里输入一个较大的数字

  查询分析器->工具->选项->连接->在 登录超时(秒) 后面的框里输入一个较大的数字

  通常就可以连通了,如果提示错误,则进入下一步。

  五 错误产生的原因通常是由于SQL Server使用了"仅 Windows"的身份验证方式,因此用户无法使用SQL Server的登录帐户(如 sa )进行连接。解决方法如下所示:

  1 在服务器端使用企业管理器,并且选择"使用 Windows 身份验证"连接上 SQL Server。

  2 展开"SQL Server组",鼠标右键点击SQL Server服务器的名称,选择"属性",再选择"安全性"选项卡。

  3 在"身份验证"下,选择"SQL Server和 Windows "。

  4 重新启动SQL Server服务。(在dos或命令行下面net stop mssqlserver停止服务,net start mssqlserver启动服务,也是一种快捷的方法)。

  附注:在连接本地服务器时,通常使用的是命名管道协议(在服务器网络实用工具里可以看到启用的协议有这个),默认端口是445,因此在本地能连通是不能说明什么问题的,连接远程服务器是完全不同的协议


修改完配置 应该重新启动db 就正常了

论坛徽章:
0
发表于 2011-03-01 13:35 |显示全部楼层
2010-03-10 13:21

1、sql2000 telnet 1433端口无法连接2008-12-31 21:521、数据库服务未启动。
2、防火墙屏蔽了对telnet的响应。
3、SQL服务未在1433端口上启动监听。  
如果你用查询分析器可以连接上,应用软件也连得上,只是Telnet 1433端口失败;并且也未改动过服务端口,其它都是正常的,那么这种问题在XP2+SQL SERVER 2000环境中最常见。解决办法几种:
1、反安装XP2的补丁,这样通常是不会出现SQL SERVER连不上的问题的。
2、XP2的操作系统安装SQL SERVER 2000的SP3补丁可解决Telnet SQL SERVER的1433端口无法打开的问题。
3、其它操作系统比如2003的,最好补一下SQL SP4的。
  
检查你的SQL有没有打补丁,没有的话要打上补丁,检查的方法是在查询分析器中运行:
select @@version
如果出来的版本号是8.00.2039以下,则表明你未安装sp4的补丁,要装上.
  
SQL补丁下载:
全部补丁的位置
http://www.microsoft.com/downloa ... p;displaylang=zh-cn
应该安装的是
http://download.microsoft.com/do ... 525-SP4-x86-CHS.EXE
注意下载后,执行的时候是解压,要在解压后的目录中执行setup.bat才是真正的安装
  
如果你的操作系统是xp,那么在安装xp sp2后,不管以前是否安装过sql sp4,都要再安装一次,并且在防火墙中开启1433端口,否则无法被其他电脑访问
  
如何检查1433是否在监听?或者检查有哪些端口在监听?
1、如果打了sql sp3,并且windows2003防火墙已经关闭, 在命令提示符下执行
netstat -na 应该可以看到tcp 1433在监听。
2、启动企业管理器查看SQL SERVER 2000 的系统日志,在日志中可以看到SQL SERVER 启动的是那些协议来等待远程连接的。
  
另外记得打完补丁,重新启动机器,或者重新启动服务。

远程连接sql server 2000服务器的解决方案  
     
     解决方案步骤:  
     一 看ping 服务器IP能否ping通。  
     这个实际上是看和远程sql server 2000服务器的物理连接是否存在。如果不行,请检查网络,查看配置,当然得  
     确保远程sql server 2000服务器的IP拼写正确。  
     二 在Dos或命令行下输入telnet 服务器IP 端口,看能否连通。  
     如telnet 202.114.100.100 1433  
     通常端口值是1433,因为1433是sql server 2000的对于Tcp/IP的默认侦听端口。如果有问题,通常这一步会出问  
     题。通常的提示是“……无法打开连接,连接失败"。  
     如果这一步有问题,应该检查以下选项。  
     1 检查远程服务器是否启动了sql server 2000服务。如果没有,则启动。  
     2 检查服务器端有没启用Tcp/IP协议,因为远程连接(通过因特网)需要靠这个协议。检查方法是,在服务器上  
     打开开始菜单->程序->Microsoft SQL Server->服务器网络实用工具,看启用的协议里是否有tcp/ip协议,如果  
     没有,则启用它。  
     3 检查服务器的tcp/ip端口是否配置为1433端口。仍然在服务器网络实用工具里查看启用协议里面的tcp/ip的属  
     性,确保默认端口为1433,并且隐藏服务器复选框没有勾上。  
     事实上,如果默认端口被修改,也是可以的,但是在客户端做telnet测试时,写服务器端口号时必须与服务器配  
     置的端口号保持一致。如果隐藏服务器复选框被勾选,则意味着客户端无法通过枚举服务器来看到这台服务器,  
     起到了保护的作用,但不影响连接,但是Tcp/ip协议的默认端口将被隐式修改为2433,在客户端连接时必须作相  
     应的改变。  
     4 如果服务器端操作系统打过sp2补丁,则要对windows防火墙作一定的配置,要对它开放1433端口,通常在测试  
     时可以直接关掉windows防火墙(其他的防火墙也关掉最好)。  
     5 检查服务器是否在1433端口侦听。如果服务器没有在tcp连接的1433端口侦听,则是连接不上的。检查方法是在  
     服务器的dos或命令行下面输入 netstat -a -n 或者是netstat -an,在结果列表里看是否有类似 tcp 127.0.0.1  
     1433 listening 的项。如果没有,则通常需要给sql server 2000打上至少sp3的补丁。其实在服务器端启动查询  
     分析器,输入 select @@version 执行后可以看到版本号,版本号在8.0.2039以下的都需要打补丁。  
     如果以上都没问题,这时你再做telnet 服务器ip 1433 测试,将会看到屏幕一闪之后光标在左上角不停闪动。恭  
     喜你,你马上可以开始在企业管理器或查询分析器连接了。  
     
     三 检查客户端设置  
     程序->Microsoft SQL Server-> 客户端网络使用工具。像在服务器网络实用工具里一样,确保客户端tcp/ip协议  
     启用,并且默认端口为1433(或其他端口,与服务器端保持一致就行)。  
     
     四 在企业管理器里或查询分析器连接测试  
     企业管理器->右键SQlserver组->新建sqlserver注册->下一步->写入远程IP->下一步-> 选Sqlserver登陆->下一  
     步->写入登陆名与密码(sa,password)->下一步->下一步->完成  
     查询分析器->文件->连接->写入远程IP->写入登录名和密码(sa,password)->确定  
     通常建议在查询分析器里做,因为默认情况下,通过企业管理器注册另外一台SQL Server的超时设置是4秒,而查  
     询分析器是15秒。  
     修改默认连接超时的方法:  
     企业管理器->工具->选项->在弹出的"SQL Server企业管理器属性"窗口中,点击"高级"选项卡->连接设置->在 登  
     录超时(秒) 后面的框里输入一个较大的数字  
     查询分析器->工具->选项->连接->在 登录超时(秒) 后面的框里输入一个较大的数字  
     通常就可以连通了,如果提示错误,则进入下一步。  
     五 错误产生的原因通常是由于SQL Server使用了"仅 Windows"的身份验证方式,因此用户无法使用SQL Server的  
     登录帐户(如 sa )进行连接。解决方法如下所示:  
      1 在服务器端使用企业管理器,并且选择"使用 Windows 身份验证"连接上 SQL Server。  
       2 展开"SQL Server组",鼠标右键点击SQL Server服务器的名称,选择"属性",再选择"安全性"选项卡。  
       3 在"身份验证"下,选择"SQL Server和 Windows "。  
       4 重新启动SQL Server服务。(在dos或命令行下面net stop mssqlserver停止服务,net start  
     mssqlserver启动服务,也是一种快捷的方法)。  
     
     注:在连接本地服务器时,通常使用的是命名管道协议(在服务器网络实用工具里可以看到启用的协议有这个)  
     ,默认端口是445,因此在本地能连通是不能说明什么问题的,连接远程服务器是完全不同的协议)。
http://tieba.baidu.com/f?kz=123471651

论坛徽章:
0
发表于 2011-03-03 18:46 |显示全部楼层
sa登陆失败 SQL Server错误18456的解决方法_SQL技巧
发布于:软件开发网 来源:互联网 作者:佚名 时间:2009-01-01 点击:


查找问题的过程:(注:用windows账号还是可以登录的)

第一步: 启动所有与SQL有关的服务,问题依旧;

第二步: 查看windows防火墙,被默认启动了,不启动选择项被Disabled

两个提示“由于安全考虑,某些设置由组策略控制”“Windows防火墙正在使用您的域设置”,先用gpedit.msc打组策略编辑器,机算机配置--管理模板--网络--网络连接--Windows防火墙--标准配置文件,查看右边各选项属性,都是未配置状态,问题不在这里。
软件开发网

另外一个提示中提到域设置,域设置不可能禁用SQL Server,并且我查看本地开放端口(netstart -an),25,1433,1434都是开发状态。


晕,会不会是密码错误?


第三步:用windows账号登录

连接成功后, 选择"属性"

右键实例,在"属性"窗口中, 转到"Security"(安全性)项, 查看"服务器身份验证"中设置确为"SQL Server和Windows身份验证模式",

然后执行下面的语句启用sa用户, 同时更改sa的密码

软件开发网

EXEC sp_password 'sa',null,'sa'

ALTER LOGIN sa ENABLE


执行出错:

消息 15116,级别 16,状态 1,第 1 行

密码有效性验证失败。该密码太短,不符合 Windows 策略要求。


哈哈,问题找到。


本地设置可能被域设置覆盖。而域设置中指定了安全策略,密码必须有一定的复杂性。重新更改sa密码,

EXEC sp_password 'sa','Uiop_098Mn','sa'

ALTER LOGIN sa ENABLE


问题解决!

http://topic.csdn.net/u/20091111 ... 9-10df1bbbd839.html
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP