免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 2455 | 回复: 4

我用VM装了Red hat9.0,现在不能够从主机telnet到Linux上? [复制链接]

论坛徽章:
0
发表于 2007-04-02 11:35 |显示全部楼层
我用VM5.0装了一个RedHat9.0. 现在网络是这样设置的:
1)使用了HostOnly方式的VMNET1.
Vmnet1设置如下:
IP: 192.168.1.2
mask: 255.255.255.0


2)主机网卡设置如下:
IP: 192.168.1.27
mask: 255.255.255.0
默认网关: 192.168.1.1
首选dns: 192.168.1.1

主机现在可以通以正常上网(internet)

3) Linux eth0设置如下:
IP: 192.168.1.123
MASK:255.255.255.0
默认网关: 192.168.1.2

现在用Ping命令
1)可以Ping通192.168.1.2
2)可以ping通192.168.1.123

但是不能够ping通主机的192.168.1.27

从主机ping 192.168.1.123也不能够ping通,这是什么原因呢?

哪里没有设置对呢?(现在ping不能,所以,也就不能够telnet了)

谢谢!

论坛徽章:
0
发表于 2007-04-02 13:02 |显示全部楼层

回复 #1 hs_49 的帖子

我是个菜鸟,我不知道我的猜测是否正确...我只想抛砖引玉,请不要见笑。
我觉得可能是两方面原因:
1、Linux的iptables;
2、telnet的服务是否被禁用。

论坛徽章:
0
发表于 2007-04-02 13:18 |显示全部楼层
其实VMNET1的IP地址不用去设置
只要你的eth0的IP地址设置好了就可以了,
还有你当时linux的IP是怎样配置的是在命令模式下敲"setup"吗?
在配置完IP后有用“ifdown eth0"和”ifup eth0“这两条命令吗?
最后就是你网关的指向应该是”192.168.1.1“吧怎么可能是"192.168.1.2"呢?
还有在服务里有开启telnet吗?就是在"setup"模式下有没有找到"service"或者是”server"之类的选项
也就是你有没有用到一条叫service xinetd restart 或者是service sshd restart; service telnet restart这样的命令吗?
我以上说的都是在命令行里敲的命令,你试一试吧,可能会有用的。

论坛徽章:
0
发表于 2007-04-02 14:39 |显示全部楼层
多谢!系统的sshd已经启动了。
现在是连ping都不行?(从linux ping host)
我想通过host上的client软件。telnet到linux上,或者通过ftp之类进行文件传送。现在ping不通。所以telnet及ftp都不能够用。

前提:
linux的ftp及telnet服务都已经是启动成功的。

配置ip是用的图型模式下的[网络]设置进行的。而且设置好后,也重新启动服务了:
/sbin/service network restart命令,重启了。

请指教什么地方有问题呢?

论坛徽章:
0
发表于 2007-04-02 18:06 |显示全部楼层
已经搞定了.
原因是Linux防火墙屏蔽了ssh,telnet及ftp三个功能的原因.
在x windos下的[系统设置]->[安全级别配置]选中SSH,TELNET,FTP功能,就可以了.
希望对有遇到这样的问题朋友能够有些帮助.
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP