免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
12下一页
最近访问板块 发新帖
查看: 4707 | 回复: 11

求助:SUN GigabitEthernet1000M网卡工作在半双工的问题 [复制链接]

论坛徽章:
0
发表于 2004-05-03 13:16 |显示全部楼层
单位两台小型机网卡升级,由原来的100M四网口网卡换为Sun GigabitEthernet 1000M网卡,一台加在装有Solaris 8系统的sun3500小型机上,加上后,启动完配置后即可使用,卡上的FDX灯是亮的,说明是工作在全双工模式,另一台是装有Solaris 7系统的sun3500小型机上,启动后需要手工安装驱动程序,装完后,配置完也可以用了,但FDX灯不亮,说明工作在半双工模式,请问是不是要在什么文件里配置一下? 谢谢!\r\n\r\n   另外如果只使用四网口网卡,每个网口都配置一个地址,这四个地址在一个网段里,请问这四个网口是如何工作?

论坛徽章:
0
发表于 2004-05-03 22:19 |显示全部楼层

求助:SUN GigabitEthernet1000M网卡工作在半双工的问题

1.dmesg |grep Link 查看网卡启动信息。\r\n\r\n2.强迫全双工1000M工作(是eri网卡吧?)\r\nndd -set /dev/eri instance 0 \r\nndd -set /dev/eri adv_1000fdx_cap 1 \r\nndd -set /dev/eri adv_autoneg_cap 0\r\n或者在/etc/system中修改\r\n如果修改生效后发现交换机灯灭了,就说明不能这么设置。\r\n\r\n3.也有可能是交换机或网线问题。如果连接在HUB上一般是工作在半双工模式。\r\nndd -set /dev/eri adv_autoneg_cap 0\r\n或者/etc/system\r\nset eri:eri_adv_autoneg_cap=0\r\n不与HUB协商网卡工作模式。

论坛徽章:
0
发表于 2004-05-03 23:57 |显示全部楼层

求助:SUN GigabitEthernet1000M网卡工作在半双工的问题

是GE网卡,我配置了hostname.ge0 hostname.ge0:1目前工作还是正常的,只是FDX灯不亮.\r\n 用dmesg |grep Link 信息如下:\r\nMay 1 16:59:39 mailserver unix:SUNW,sbus-gem0:Could not Establish Link --Check if the cable is plugged in.\r\nMay 1 17:02:10 mailserver unix:SUNW,sbus-gem0:Auto-Negotiated 1000 Mbps Full-Duplex Link up\r\n\r\n   另一台小型机 dmesg |grep Link居然什么信息都没有,但FDX灯是亮的,在交换机上看与之连接的千M模块,发现都是自动全双工模式!

论坛徽章:
0
发表于 2004-05-04 16:41 |显示全部楼层

求助:SUN GigabitEthernet1000M网卡工作在半双工的问题

好象在/kernel/drv/your_inet.conf中改

论坛徽章:
0
发表于 2004-05-05 15:24 |显示全部楼层

求助:SUN GigabitEthernet1000M网卡工作在半双工的问题

沒有用過,可能是硬件問題也可能是軟件問題.

论坛徽章:
0
发表于 2004-05-06 11:58 |显示全部楼层

求助:SUN GigabitEthernet1000M网卡工作在半双工的问题

我再顶,目前网卡工作正常,但FDX灯还是不亮,应该还是工作在半双工模式,另外我想把板子上自带的100M网卡也用起来,具体要配置哪几步?谢谢

论坛徽章:
0
发表于 2004-05-06 13:27 |显示全部楼层

求助:SUN GigabitEthernet1000M网卡工作在半双工的问题

先装网卡驱动,建/ETC/HOSTNAME。INT0,配/ETC/HOSTS。

论坛徽章:
0
发表于 2004-05-06 20:23 |显示全部楼层

求助:SUN GigabitEthernet1000M网卡工作在半双工的问题

楼上的,为什么要建 /etc/hostname.int0 为什么要后int0这个后缀?我装完后看着应该是ge0啊,现在只是FDX灯不亮,如何让这个灯亮起来,也就是让它工作在全双工模式!

论坛徽章:
0
发表于 2004-05-07 10:05 |显示全部楼层

求助:SUN GigabitEthernet1000M网卡工作在半双工的问题

先把PATCH 都打了。。

论坛徽章:
0
发表于 2004-05-07 10:27 |显示全部楼层

求助:SUN GigabitEthernet1000M网卡工作在半双工的问题

[quote]原帖由 \"wcq\"]楼上的,为什么要建 /etc/hostname.int0 为什么要后int0这个后缀?我装完后看着应该是ge0啊,现在只是FDX灯不亮,如何让这个灯亮起来,也就是让它工作在全双工模式![/quote 发表:\n\r\n\r\n我已经说了:在/kernel/drv/int.conf中改“全/半双工模式”\r\n\r\n“hostname.int0”中的“int”指代你网卡的设备名,当然要换成你网卡的实际名啊!
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP