免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 3150 | 回复: 1
打印 上一主题 下一主题

[C++] C++复数类对除法运算符 / 的重载 [复制链接]

论坛徽章:
0
跳转到指定楼层
1 [收藏(0)] [报告]
发表于 2015-05-26 09:21 |只看该作者 |倒序浏览
C8-1 复数加减乘除

(100.0/100.0 points)
题目描述
求两个复数的加减乘除。
输入描述

第一行两个double类型数,表示第一个复数的实部虚部

第二行两个double类型数,表示第二个复数的实部虚部


输出描述

输出依次计算两个复数的加减乘除,一行一个结果

输出复数先输出实部,空格,然后是虚部,


样例输入

1 1
3 -1

样例输出

4 0
-2 2
4 2
0.2 0.4
  1. #include <cstdio>
  2. 2 #include <cstring>
  3. 3 #include <iostream>
  4. 4 #include <algorithm>
  5. 5
  6. 6 using namespace std;
  7. 7
  8. 8 class Complex{
  9. 9 public:
  10. 10     Complex(double r = 0.0, double i = 0.0) : real(r), imag(i) {};
  11. 11     Complex operator+ (const Complex &c2) const;
  12. 12     Complex operator- (const Complex &c2) const;
  13. 13
  14. 14     /*实现下面三个函数*/
  15. 15     Complex operator* (const Complex &c2) const;
  16. 16     Complex operator/ (const Complex &c2) const;
  17. 17     friend ostream & operator<< (ostream &out, const Complex &c);
  18. 18
  19. 19 private:
  20. 20     double real;
  21. 21     double imag;
  22. 22 };
  23. 23
  24. 24 Complex Complex::operator+ (const Complex &c2) const {
  25. 25     return Complex(real + c2.real, imag + c2.imag);
  26. 26 }
  27. 27
  28. 28 Complex Complex::operator- (const Complex &c2) const {
  29. 29     return Complex(real - c2.real, imag - c2.imag);
  30. 30 }
  31. 31
  32. 32 Complex Complex::operator* (const Complex &c2) const
  33. 33 {
  34. 34     return Complex(real*c2.real - imag*c2.imag, real*c2.imag + imag*c2.real);
  35. 35 }
  36. 36
  37. 37 Complex Complex::operator/ (const Complex &c2) const
  38. 38 {
  39. 39     if (c2.imag == 0)
  40. 40         return Complex(real / c2.real, imag / c2.real);
  41. 41     else
  42. 42         return (*this)*Complex(c2.real, -c2.imag) / Complex(c2.real*c2.real + c2.imag*c2.imag, 0);
  43. 43 }
  44. 44
  45. 45 ostream & operator<< (ostream &out, const Complex &c)
  46. 46 {
  47. 47     out << c.real << " " << c.imag << endl;
  48. 48     return out;
  49. 49 }
  50. 50
  51. 51 int main() {
  52. 52     double real, imag;
  53. 53     cin >> real >> imag;
  54. 54     Complex c1(real, imag);
  55. 55     cin >> real >> imag;
  56. 56     Complex c2(real, imag);
  57. 57     cout << c1 + c2;
  58. 58     cout << c1 - c2;
  59. 59     cout << c1 * c2;
  60. 60     cout << c1 / c2;
  61. 61 }
复制代码

就是C++对操作符的重载。

有两个地方要注意:

1、对 << 的重载中,注意要返回 out,这样就可以实现 << 的级联输出(多项并列时);

2、对 / 的重载中,注意  return (*this)*Complex(c2.real, -c2.imag) / Complex(c2.real*c2.real + c2.imag*c2.imag, 0); 这一句是会继续调用这个重载函数本身的!它本身就是对 / 的重载,而你在这里又用到了 / ,所以会递归下去!所以必须加 return Complex(real / c2.real, imag / c2.real); 让递归归于平凡的情形(实际上只会递归一层)。

论坛徽章:
1
2015年辞旧岁徽章
日期:2015-03-03 16:54:15
2 [报告]
发表于 2015-05-29 14:34 |只看该作者
太高深了
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122 niuxiaotong@pcpop.com 17352615567
未成年举报专区
中国互联网协会会员  联系我们:huangweiwei@itpub.net
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP