免费注册 查看新帖 |

ChinaUnix.net

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 10441 | 回复: 3

[WebLogic] 为啥安装IBM jdk 1.7时提示先安装jre [复制链接]

论坛徽章:
3
CU大牛徽章
日期:2013-03-13 15:29:07CU大牛徽章
日期:2013-03-13 15:29:49CU大牛徽章
日期:2013-03-13 15:30:19
发表于 2015-06-19 10:53 |显示全部楼层
最近准备上线weblogic12,在安装IBM jdk 1.7时,即安装Java7_64.sdk总是提示要先安装jre,我之前的理解不是jdk还包含了jre了吗,记得之前安装1.6时没有这个要求啊?j.7之后变了吗?还有我只安装jre后,运行java -jar file.jar时提示没安装jdk,这又是为啥?请大神给解释下,谢谢。

论坛徽章:
28
ChinaUnix元老
日期:2015-02-02 08:55:392017金鸡报晓
日期:2017-01-10 15:13:29CU十四周年纪念徽章
日期:2018-08-29 22:12:2715-16赛季CBA联赛之深圳
日期:2018-09-20 12:21:09
发表于 2015-06-19 12:51 |显示全部楼层
  1. which java
复制代码
看看你执行的java命令是系统自带的那个还是你后来安装的那个

论坛徽章:
3
CU大牛徽章
日期:2013-03-13 15:29:07CU大牛徽章
日期:2013-03-13 15:29:49CU大牛徽章
日期:2013-03-13 15:30:19
发表于 2015-06-19 15:32 |显示全部楼层
回复 2# Shell_HAT

您是说执行java -jar不成功的?我查了java是我装的,我配置了环境变量了,配置的是jre/bin的路径的,不行,然后又装了sdk配置了环境变量就可以了。
我在官网下载了两个文件,只装sdk就不行,让我装jre,我装了jre,还不能运行java -jar命令,必须两个都装上才行,不知道为啥?
Java7_64.sdk.7.0.0.205.tar.gz
Java7_64.jre.7.0.0.205.tar.gz

   

论坛徽章:
2
IT运维版块每日发帖之星
日期:2015-10-06 06:20:00每日论坛发贴之星
日期:2015-10-06 06:20:00
发表于 2015-10-03 14:29 |显示全部楼层
真的不错的,来支持了呢
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

数据风云,十年变迁
DTCC 第十届中国数据库技术大会已启航!

2019年5月8日~5月10日,由IT168旗下ITPUB企业社区平台主办的第十届中国数据库技术大会(DTCC2019),将在北京隆重召开。大会将邀请百余位行业专家,就热点技术话题进行分享,是广大数据领域从业人士的又一次年度盛会和交流平台。与SACC2018类似,本届大会将采用“3+2”模式:3天传统技术演讲+2天深度主题培训。大会不仅提供超100场的主题演讲,还会提供连续2天的深度课程培训,深化数据领域的项目落地实践方案。
DTCC2019,一场值得期待的数据技术盛会,殷切地希望您报名参与!

活动入口>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP