忘记密码   免费注册 查看新帖 | 论坛精华区

ChinaUnix.net

  平台 论坛 博客 认证专区 大话IT HPC论坛 徽章 文库 沙龙 自测 下载 频道自动化运维 虚拟化 储存备份 C/C++ PHP MySQL 嵌入式 Linux系统
最近访问板块 发新帖
查看: 1675 | 回复: 2

编译除本机内核版本之外的其他内核版本的驱动 [复制链接]

论坛徽章:
0
发表于 2016-09-08 09:40 |显示全部楼层
请教各位大神:
我的电脑内核是3.11的,但是编译到板子的内核是2.6的,所以想编译生成2.6版本的ko文件,编译成功了,但是加载时还是说版本不匹配
OscPcie: disagrees about version of symbol module_layout                        
insmod: error inserting 'OscPcie.ko': -1 Invalid module format
如何解决呢?


论坛徽章:
0
发表于 2016-10-01 00:34 |显示全部楼层
你应该在板子里的内核源码里编译出.ko文件。和主机内核版本有什么关系?

论坛徽章:
0
发表于 2017-04-25 19:28 |显示全部楼层
用板子里跑的linux 源码来编译驱动。别用其他版本。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号 北京市公安局海淀分局网监中心备案编号:11010802020122
广播电视节目制作经营许可证(京) 字第1234号 中国互联网协会会员  联系我们:
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP