忘记密码   免费注册 查看新帖 | 论坛精华区

ChinaUnix.net

  平台 论坛 博客 认证专区 大话IT HPC论坛 徽章 文库 沙龙 自测 下载 频道自动化运维 虚拟化 储存备份 C/C++ PHP MySQL 嵌入式 Linux系统
最近访问板块 发新帖
查看: 1583 | 回复: 0

安装MacPorts遇到的奇葩问题 [复制链接]

论坛徽章:
0
发表于 2016-10-31 12:14 |显示全部楼层
本帖最后由 lunaest 于 2016-10-31 12:36 编辑

从官网上下载的pkg文件,安装完之后运行显示:
/opt/local/libexec/macports/lib/tcl8.5/init.tcl: version conflict for package "Tcl": have 8.5.13, need exactly 8.5.15
version conflict for package "Tcl": have 8.5.13, need exactly 8.5.15
    while executing
"package require -exact Tcl 8.5.15"
    (file "/opt/local/libexec/macports/lib/tcl8.5/init.tcl" line 19)
    invoked from within
"source /opt/local/libexec/macports/lib/tcl8.5/init.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $tclfile]"

按照网上说的打开这个文件:file "/opt/local/libexec/macports/lib/tcl8.5/init.tcl"
修改
if {[info commands package] == ""} {
    error "version mismatch: library\nscripts expect Tcl version 7.5b1 or later but the loaded version is\nonly [info patchlevel]"
}
package require -exact Tcl 8.5.15

变成
if {[info commands package] == ""} {
    error "version mismatch: library\nscripts expect Tcl version 7.5b1 or later but the loaded version is\nonly [info patchlevel]"
}
package require -exact Tcl 8.5.13

再运行又开始报错说:
/opt/local/libexec/macports/lib/tcl8.5/init.tcl: version conflict for package "Tcl": have 8.5.15, need exactly 8.5.13
version conflict for package "Tcl": have 8.5.15, need exactly 8.5.13
    while executing
"package require -exact Tcl 8.5.13"
    (file "/opt/local/libexec/macports/lib/tcl8.5/init.tcl" line 19)
    invoked from within
"source /opt/local/libexec/macports/lib/tcl8.5/init.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $tclfile]"

真是哭笑不得。
求大神赐教啊!!!
您需要登录后才可以回帖 登录 | 注册

本版积分规则

  

北京盛拓优讯信息技术有限公司. 版权所有 京ICP备16024965号 北京市公安局海淀分局网监中心备案编号:11010802020122
广播电视节目制作经营许可证(京) 字第1234号 中国互联网协会会员  联系我们:
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP