免费注册 查看新帖 |

ChinaUnix.net

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 1106 | 回复: 1

[ldap] Centos 7 上安装openldap 代理的配置问题 [复制链接]

论坛徽章:
0
发表于 2019-06-04 14:21 |显示全部楼层
本帖最后由 smallfish0 于 2019-06-04 14:40 编辑

需求:
公司代码服务器放在公网,需要用内网AD账号登录,准备用Centos 7搭建一台openldap服务器,用它做代理,然后在git上配置ldap,连接到这台机器上,通过这台机器连接到内网AD服务器,验证用户名密码,如果在内网直接在git服务器上配置AD服务器地址和389端口即可,但是在公网为了安全起见,使用openldap做代理。

openldap 版本是2.4.44,目前参考了一些文档配置后看起来好像没问题,但是在git服务器上配置测试总是提示:
Test basic connection : Failed
[LDAP: error code 49 - Invalid Credentials]; nested exception is javax.naming.AuthenticationException: [LDAP: error code 49 - Invalid Credentials]
LDAP 服务器这边错误日志:

Jun  4 14:09:25 ldap slapd[21076]: conn=1002 fd=11 ACCEPT from IP=192.168.100.12:29968 (IP=0.0.0.0:389)
Jun  4 14:09:25 ldap slapd[21076]: conn=1002 op=0 BIND dn="cn=ldap,cn=users,dc=company,dc=com" method=128
Jun  4 14:09:25 ldap slapd[21076]: conn=1002 op=0 RESULT tag=97 err=49 text=
Jun  4 14:09:25 ldap slapd[21076]: conn=1002 fd=11 closed (connection lost)


有类似相关文档可以参考下吗?
谢谢!

论坛徽章:
0
发表于 2019-06-05 11:42 |显示全部楼层
网上参考了下其他人的配置,现在我在git 上配置LDAP进行测试能够连接,但是用AD账号登录则后台提示:
Test retrieve user : Failed
User <ldap> does not exist

在Openldap 日志上显示:
Jun  5 10:41:48 ldap slapd[19740]: conn=1002 fd=14 ACCEPT from IP=192.168.1.103:30082 (IP=0.0.0.0:389)
Jun  5 10:41:48 ldap slapd[19740]: conn=1002 op=0 BIND dn="cn=ldap,cn=users,dc=mydomain,dc=com" method=128
Jun  5 10:41:48 ldap slapd[19740]: conn=1002 op=0 BIND dn="cn=ldap,cn=users,dc=mydomain,dc=com" mech=SIMPLE ssf=0
Jun  5 10:41:48 ldap slapd[19740]: conn=1002 op=0 RESULT tag=97 err=0 text=
Jun  5 10:41:48 ldap slapd[19740]: conn=1002 op=1 SRCH base="ou=company,dc=mydomain,dc=com" scope=2 deref=3 filter="(&(objectClass=inetOrgPerson)(cn=ldap))"
Jun  5 10:41:48 ldap slapd[19740]: conn=1002 op=1 SRCH attr=mail sn cn entryUUID givenName displayName objectClass javaSerializedData javaClassName javaFactory javaCodeBase javaReferenceAddress javaClassNames javaRemoteLocation
Jun  5 10:41:48 ldap slapd[19740]: conn=1002 op=1 SEARCH RESULT tag=101 err=0 nentries=0 text=

对比了其他人的配置,应该就是这个”filter="(&(objectClass=inetOrgPerson)(cn=ldap))"“有问题,正常应该是filter="(&(objectClass=Person)(cn=ldap))",就是不知道哪里修改这个过滤值。

参考网站:https://wiki.samba.org/index.php/OpenLDAP_as_proxy_to_AD
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

ITPUB技术栈

ITPUB技术栈是ITPUB企业打造的垂直于IT领域的知识社群平台,在这里,你既可以是创作者也可以是消费者。如果你的IT生涯丰富多彩,喷薄的个人价值尽可在小栈内体现;如果你渴望找到志同道合的伙伴,拓宽人脉,小栈比跑会场更快。 小栈特色:
1.极高的用户转化率,实现更直接的知识变现;
2.随时随地,刷个朋友圈的时间,实现更长效的信息沉淀;
3.戳痛、难点的专业咨询,更接近成功解决方案的时刻;
4.贴近意见领袖,个人高速成长,迈入更富有价值的人际圈。

----------------------------------------

技术小栈>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP