免费注册 查看新帖 |

Chinaunix

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 4898 | 回复: 1

[系统管理] Linux上安装libvirt-5.6.0时出现如下报错:You must install the gnutls >= 3.2.0 [复制链接]

论坛徽章:
5
程序设计版块每日发帖之星
日期:2016-04-15 06:20:00每日论坛发贴之星
日期:2016-04-15 06:20:0015-16赛季CBA联赛之八一
日期:2016-07-08 09:20:28操作系统版块每日发帖之星
日期:2016-08-03 06:20:002016科比退役纪念章
日期:2016-10-30 13:59:12
发表于 2019-09-10 09:20 |显示全部楼层
在xen Server 7.6的宿主机上安装libvirt-5.6.0时出现如下报错:

configure: error: You must install the gnutls >= 3.2.0 pkg-config module to compile libvirt

但是我已经安装了gnutls:
[root@xen11 libvirt-5.6.0]# rpm -qa|grep gnutls
gnutls-dane-3.3.29-9.el7_6.x86_64
gnutls-utils-3.3.29-9.el7_6.x86_64
gnutls-c++-3.3.29-9.el7_6.x86_64
gnutls-devel-3.3.29-9.el7_6.x86_64
gnutls-3.3.29-9.el7_6.x86_64


已经安装了pkg-config,如下所示:
[root@xen11 libvirt-5.6.0]# pkg-config --version
0.29.2


这两个软件都已经安装了,还是报这个错误:
configure: error: You must install the gnutls >= 3.2.0 pkg-config module to compile libvirt

请问下如何来解决?

论坛徽章:
137
2022北京冬奥会纪念版徽章
日期:2015-08-07 17:10:5719周年集字徽章-庆
日期:2019-08-27 13:28:5615-16赛季CBA联赛之福建
日期:2019-09-10 11:43:2519周年集字徽章-周
日期:2019-12-12 10:54:07
发表于 2019-09-10 17:55 来自手机 |显示全部楼层
gnutls-devel-3.3.29-9.el7_6.x86_64


不太懂,很久没有碰linux了
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

DTCC2020中国数据库技术大会 限时8.5折

【架构革新 高效可控】2020年8月17日~19日第十一届中国数据库技术大会将在北京隆重召开。

大会设置2大主会场,20+技术专场,将邀请超百位行业专家,重点围绕数据架构、AI与大数据、传统企业数据库实践和国产开源数据库等内容展开分享和探讨,为广大数据领域从业人士提供一场年度盛会和交流平台。

http://dtcc.it168.com


大会官网>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP