- 论坛徽章:
- 2
|
SunOS 5.8 Last change: 8 Dec 1999 7
Maintenance Commands in.ftpd(1M)
# but we need the bin -> usr/bin link
rm -f ${ftphome}/bin
ln -s usr/bin ${ftphome}/bin
# Ensure that the /usr/lib and /etc directories exist
if [ ! -d ${ftphome}/usr/lib ]; then
mkdir -p ${ftphome}/usr/lib
fi
chown root ${ftphome}/usr/lib
chmod 555 ${ftphome}/usr/lib
if [ ! -d ${ftphome}/usr/lib/security ]; then
mkdir -p ${ftphome}/usr/lib/security
fi
chown root ${ftphome}/usr/lib/security
chmod 555 ${ftphome}/usr/lib/security
if [ ! -d ${ftphome}/etc ]; then
mkdir -p ${ftphome}/etc
fi
chown root ${ftphome}/etc
chmod 555 ${ftphome}/etc
# a list of all the commands that should be copied to ${ftphome}/usr/bin
# /usr/bin/ls is needed at a minimum.
ftpcmd="
/usr/bin/ls
"
# ${ftphome}/usr/lib needs to have all the libraries needed by the above
# commands, plus the runtime linker, and some name service libraries
# to resolve names. We just take all of them here.
ftplib="`ldd $ftpcmd | nawk '$3 ~ /lib/ { print $3 }' | sort | uniq`"
ftplib="$ftplib /usr/lib/nss_* /usr/lib/straddr* /usr/lib/libmp.so*"
ftplib="$ftplib /usr/lib/libnsl.so.1 /usr/lib/libsocket.so.1 /usr/lib/ld.so.1"
ftplib="`echo $ftplib | tr ' ' '\n' | sort | uniq`"
cp ${ftplib} ${ftphome}/usr/lib
chmod 555 ${ftphome}/usr/lib/*
cp /usr/lib/security/* ${ftphome}/usr/lib/security
chmod 555 ${ftphome}/usr/lib/security/*
cp ${ftpcmd} ${ftphome}/usr/bin
chmod 111 ${ftphome}/usr/bin/*
# you also might want to have separate minimal versions of passwd and group
cp /etc/passwd /etc/group /etc/netconfig /etc/pam.conf ${ftphome}/etc
chmod 444 ${ftphome}/etc/*
SunOS 5.8 Last change: 8 Dec 1999 8
Maintenance Commands in.ftpd(1M)
# need /etc/default/init for timezone to be correct
if [ ! -d ${ftphome}/etc/default ]; then
mkdir ${ftphome}/etc/default
fi
chown root ${ftphome}/etc/default
chmod 555 ${ftphome}/etc/default
cp /etc/default/init ${ftphome}/etc/default
chmod 444 ${ftphome}/etc/default/init
# Copy timezone database
mkdir -p ${ftphome}/usr/share/lib/zoneinfo
(cd ${ftphome}/usr/share/lib/zoneinfo
(cd /usr/share/lib/zoneinfo; find . -print |
cpio -o) 2>/dev/null | cpio -imdu 2>/dev/null
find . -print | xargs chmod 555
find . -print | xargs chown root
)
# Ensure that the /dev directory exists
if [ ! -d ${ftphome}/dev ]; then
mkdir -p ${ftphome}/dev
fi
# make device nodes. ticotsord and udp are necessary for
# 'ls' to resolve NIS names.
for device in zero tcp udp ticotsord ticlts
do
line=`ls -lL /dev/${device} | sed -e 's/,//'`
major=`echo $line | awk '{print $5}'`
minor=`echo $line | awk '{print $6}'`
rm -f ${ftphome}/dev/${device}
mknod ${ftphome}/dev/${device} c ${major} ${minor}
done
chmod 666 ${ftphome}/dev/*
## Now set the ownership and modes
chown root ${ftphome}/dev
chmod 555 ${ftphome}/dev
# uncomment the below if you want a place for people to store things,
# but beware the security implications
#if [ ! -d ${ftphome}/pub ]; then
# mkdir -p ${ftphome}/pub
#fi
#chown root ${ftphome}/pub
#chmod 1755 ${ftphome}/pub
After running this script, edit the files in ~ftp/etc to
make sure all non-public information is removed.
SunOS 5.8 Last change: 8 Dec 1999 9
Maintenance Commands in.ftpd(1M)
ATTRIBUTES
See attributes (5) for descriptions of the following attri-
butes:
____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Availability | SUNWcsu |
|_____________________________|_____________________________|
FILES
/etc/default/ftpd
/etc/ftpusers
file listing users for whom ftp login privileges are
disallowed.
SEE ALSO
ftp(1), ld.so.1(1), ls(1), sh(1), aset(1M), inetd( 1M),
mknod(1M), syslogd(1M), chroot(2), getsockopt(3SOCKET),
pam(3PAM), ftpusers(4), group(4), inetd.conf(4), netcon-
fig(4), netrc(4), pam.conf(4), passwd(4), services(4),
attributes(5), pam_unix(5)
Allman, M., Ostermann, S., and Metz, C., RFC 2428, FTP
Extensions for IPv6 and NATs, The Internet Society, 1998.
Postel, Jon, and Joyce Reynolds, RFC 959, File Transfer
Protocol (FTP ), Network Information Center, SRI Interna-
tional, Menlo Park, Calif., October 1985.
Piscitello, D., RFC 1639, FTP Operation Over Big Address
Records (FOOBAR), Network Working Group, June 1994.
DIAGNOSTICS
in.ftpd logs various errors to syslogd, with a facility code
of daemon.
Info Severity
These messages are logged only if the -l flag is specified.
FTPD: connection from host at time
A connection was made to ftpd from the host host at
the date and time time.
FTPD: User user timed out after timeout seconds
at time" 6 The user user was logged out because they
had not entered any commands after timeout seconds;
the logout occurred at the date and time time.
SunOS 5.8 Last change: 8 Dec 1999 10
Maintenance Commands in.ftpd(1M)
Debug Severity
These messages are logged only if the -d flag is specified.
FTPD: command: command
A command line containing command was read from the
FTP client.
lost connection
The FTP client dropped the connection.
<--- replycode
<--- replycode-
A reply was sent to the FTP client with the reply code
replycode. The next message logged will include the
message associated with the reply. If a - follows the
reply code, the reply is continued on later lines.
NOTES
The anonymous ftp account is inherently dangerous and should
be avoided when possible.
The name service caching daemon /usr/sbin/nscd may interfere
with some of the functionality of anonymous ftp. The sublo-
gin feature does not work unless caching for passwd is dis-
abled in /etc/nscd.conf.
The server must run as the superuser to create sockets with
privileged port numbers. It maintains an effective user id
of the logged in user, reverting to the superuser only when
binding addresses to sockets. The possible security holes
have been extensively scrutinized, but are possibly incom-
plete.
The file /etc/ftpusers, which is now included as part of
Solaris, contains a list of users who cannot access the
system; the default list of users in /etc/ftpusers includes
all of the accounts in passwd(4). See ftpusers(4).
SunOS 5.8 Last change: 8 Dec 1999 11 |
|