- 论坛徽章:
- 7
|
Solaris package creation walkthroughs
The impatient will probably just want to dive into a direct "walk-through" of how to create packages for blastwave. We aim to please, with two alternative walkthrough guides:
A " you're so lucky, you get all the easy packages" walkthrough (Recommended!)
A " I like to control everything, even when it breaks horribly" walkthrough
However, when you get lost, or when curiosity finally gets the better of you, come back to this page, and read the rest of it, for details of what is going on under the covers.
Mechanics of Solaris/SysV pkg creation
SysV(Solaris) packages are controlled by a 'prototype' file, that defines which control files, datafiles, and directories will be contained in the package. A sample prototype file will look like
i pkginfo
i depend
i copyright
d none /opt/csw/bin
f none /opt/csw/bin/links
The "i" is a funny way of saying "this is a control file". Other entries are for "normal" files and directories.
Package control files
pkginfo definitions
At minimum, your pkginfo file should contain the following information:
PKG=CSWxxxx
NAME=shortname - Long name after dash
ARCH=("sparc", "i386", or "all")
CATEGORY=("application" or "system")
VERSION=x.y.z
VENDOR=url://where.you.got.source packaged for CSW by Your Name
HOTLINE=http://www.blastwave.org/bugtrack/
EMAIL=yourlogin@blastwave.org
DESC=[Optional extra info about software. Omit this line if you wish]
These fields are used by scripts to generate catalogs and things, so it is VERY IMPORTANT that you stick to the above format. Please note that "shortname" should be a single lowercase word. Also be sure that what you pick for PKG is going to last forever, because changing it is a very messy thing.
Note that you do not have to set ARCH in the pkginfo file itself: You can set it on the command line when you create the package, with "pkgmk -a". [or, the "createpkg" utility will do it automatically for you]. See the examples lower down for details.
Please note that whatever you put in the DESC field, will be exactly how the package is listed in the packages listing. If you do not wish to provide a customized value, it will fall back to whatever you have as the "long name" in the NAME field.
Final note: Please do not use any apostrophe in the fields. (It makes putting the info in a database trickier). Especially do not use "GNU's xyz". Typical usage; "GNU emacs", not "GNU's emacs".
depend definitions
If your package depends on certain shared libraries being installed, it should have a 'depend' file specified. "man depend" for format of the file. You will almost always need a depend file. Generally speaking, it will have entries like the following:
P CSWgtk GTK - The GIMP Toolkit
P CSWglib GLIB - Library of useful routines for C programming
If any packages in the depend file do not begin with "CSW", or "SUNW", go and read the "Build standards" section of this document.
EVERY SINGLE DYNAMICALLY LINKED LIBRARY used by your package, must have an appropriate entry in your depend file.
Generally speaking, it is best to use Solaris standard libraries and utilities. Unless there is an overriding reason, use the Sun ones. For example, unless there is a real benefit to using ncurses over curses, use the system standard curses library.
Many GNU programs use GNU gettext, and refuse to use Solaris standard gettext. Therefore, you should probably install CSWggettext, and declare a dependancy on it, for many programs, due to linkage of /opt/csw/lib/libintl.so.2
copyright file
Every package should have a basic copyright file detailing the author's intents.
Boot scripts
Some packages need boot scripts (auto-start scripts in /etc/rc*.d/ ). Some may only sometimes need boot scripts. It it up to the packager to decide whether the software is important enough to merit always starting it at boot-time or not. You should carefully consider which one is correct for your package.
Two opposite examples, are apache and rsync. Apache's sole purpose in life is to be a webserver. It makes no sense to install it, if you do not want it running as a demon. rsync, on the other hand, is commonly run manually, and only in certain cases is it desirable to run it as a demon. Correspondingly, CSWapache directly installs scripts in /etc/*, whereas CSWrsync does not.
If you choose to not to always start a demon at boot time, you should probably provide a sample boot-time script, in either the /opt/csw/share/progname/, or the /opt/csw/share/doc/progname/ directory.
If you do want to always start a demon, you will most likely want to create boot-time scripts the same way, whether you decide to create a relocatable package, or an absolute path package (see lower down for details). Here is an example of how you would do that, taken from CSWapache.
The following assumes that you have a 'pkgs' directory tree in your home directory where you keep pkginfo files, and other files relating to each package.
f none /etc/init.d/cswapache=/export/home/phil/pkgs/apache/cswapache 0744 root sys
s none /etc/rc3.d/S50cswapache=../init.d/cswapache
s none /etc/rc0.d/K16cswapache=../init.d/cswapache
s none /etc/rc1.d/K16cswapache=../init.d/cswapache
s none /etc/rc2.d/K16cswapache=../init.d/cswapache
s none /etc/rcS.d/K16cswapache=../init.d/cswapache
Note that there are links for both 'S' and 'K' names, which means the script must handle both 'start' and 'stop' arguments.
Nice start scripts will check for the presence of a config file, and not start the demon if it is not present.
Install/Remove scripts
Packages that need scripts to run when pkgadd or pkgrm are called, are the most complex to put together. They are also a potential security risk. Some people feel uncomfortable about pkgadding third party stuff that requires an anonymous script running as root. So if possible, it is best to avoid install scripts, if you can still stick with the "deliver a fully functional package" motto.
When they are required, however, very strict guidelines need to be followed.
For example, scripts should be written to be paranoid about the state of config files. A package may be in a partially installed state ; your script may be running for the second time on the same machine.
Additionally, when packaging demons, be aware of the fact that the demon may STILL BE RUNNING. Do not do anything that could potentially break services.
preinstall/postinstall scripts
Custom preinstall/postinstall scripts (and any other pkg scripts!) should be aware of altered root locations. This usually comes into play when installing via jumpstart. This can be done by taking advantage of the pkgadd supplied variable $BASEDIR. This is not entirely the same as the BASEDIR setting for a relocatable package
Let's say you have a file that your script needs to adjust, called /opt/csw/etc/configfile. If someone has called pkgadd with a different root directory (as would be done by jumpstart), then the full path to the file may actually be something like /a/opt/csw/etc/configfile.
In the above example, if your package is non-relocatable (does not normally have a "BASEDIR" set), then BASEDIR will be set for you as the prepended bit
BASEDIR=/a
If your package is a relocatable package, and would normally have its own BASEDIR=/opt/csw, then in the above example, BASEDIR would be set for your preinstall/postinstall/... scripts as
BASEDIR=/a/opt/csw
So, if you have a regular (non-relocatable) package, reference the above file in your scripts, as "$BASEDIR/opt/csw/etc/configfile".
For relocatable packages, reference it as "$BASEDIR/etc/configfile".
How to create the package file
AFTER you have created pkginfo, depend, and copyright files, you have to generate the "normal" part of the prototype file. You can do this by running a normal "install" of the software, then using the 'pkgproto' utility in one of the following ways:
#### Absolute-path package
touch /tmp/timestamp
##[make install]
(echo "i pkginfo"; echo "i depend" ;
echo "i copyright";
find /opt/csw -newer /tmp/timestamp
) > |pkgproto > prototype
strip /opt/csw/bin/*
pkgmk -r / -a `uname -p`
filename=software-ver-SunOS`uname -r`-`uname -p`-CSW.pkg
pkgtrans -s /var/spool/pkg /tmp/$filename CSWyourpkg
rm -r /var/spool/pkg/CSWyourpkg
#### Relocatable-path package
touch /tmp/timestamp
##[make install]
(echo "i pkginfo"; echo "i depend" ;
echo "i copyright";
cd /opt/csw ;
find . -newer /tmp/timestamp
) > |pkgproto > prototype
strip /opt/csw/bin/*
pkgmk -b /opt/csw -a `uname -p` BASEDIR=/opt/csw
filename=software-ver-SunOS`uname -r`-`uname -p`-CSW.pkg
pkgtrans -s /var/spool/pkg /tmp/$filename CSWyourpkg
rm -r /var/spool/pkg/CSWyourpkg |
|