ChinaUnix.net
相关文章推荐:

nginx 多 location 不生效

有些人�不督约旱挠蛎馕龅轿业姆衿鳎衷谙肴�nginx对那些域名不要做出反应(只绑定已经写在nginx.conf中的域名),还有就是对直接输入IP地址的也不作出反应,这个怎么搞啊? 是不是让第一个虚拟主机像下面这样: server_name _; 试了没效

by scc_166 - 服务器应用 - 2009-03-09 09:46:47 阅读(1923) 回复(0)

相关讨论

This directive allows different configurations depending on the URI. It can be configured using both conventional strings and regular expressions. To use regular expressions, you must use the prefix ~* for case insensitive match and ~ for case sensitive match. To determine which location directive matches a particular query, the conventional strings are checked first. Conventional strings match ...

by 剑心通明 - BSD文档中心 - 2008-11-04 10:51:32 阅读(1695) 回复(0)

文件路径在: /home/Public_Html/down 运行 ./manage.py runserver 这样的 http://127.0.0.1:8000 django工作,正常访问 启动nginx后访问却不行.. 应该是django没工作 .. 高手看看是不是哪配置错误了.. nginx.conf user www www; worker_processes 5; pid /var/run/nginx.pid; error_log /var/log/httpd/error.log warn; events {      worker_connections 10240; #use ; } http {   &...

by 猫搂鱼睡觉 - Python - 2009-08-16 17:55:14 阅读(1829) 回复(4)

启动nginx出现以下问题,麻烦大家帮忙看看。谢谢 the using of the regex "\.php$" requires PCRE library in /usr/local/etc/nginx/nginx.conf pcre已经安装。 [ 本帖最后由 smlxp 于 2009-4-16 17:44 编辑 ]

by smlxp - 服务器应用 - 2009-04-17 10:43:49 阅读(2150) 回复(7)

我的网站,现在输入http://ip/abc/5050/5050.jpg可以访问,但是如果http://ip/ABC/5050/5050.jpg 就报400错误。。 我在配置nginx的时候,已经指定不区分大小写,依然不行。 location ~* / { root html; } 如上,已经加了~*。

by lf2186 - 服务器应用 - 2009-07-25 00:59:27 阅读(12801) 回复(12)

nginx虚拟主机配置类似下面的结构,(放到sites-enabled目录下,一个站点建一个文件也一样) http{ server{ listen 80; server_name a.com; root /var/www/a; } server{ listen 80; server_name b.com; root /var/www/b; } server{ listen 80; server_name c.com; root /var/www/b; } } 重启nginx以后,总是最后一个server有效,前面...

by ringfox - 服务器应用 - 2009-02-22 21:54:15 阅读(2525) 回复(3)

我前几天配置了nginx+fastcgi(php-fpm),但是我这几天经过观查了一下tail -f access.log|grep " 400 ",发现服务器有好多400错误,large_client_header_buffers 4 32k;我也加上去了,但是400还是有很多,我在也问了几个朋友他们说这个是nginx正常的情况,说明nginx吃不消了,但是我感觉不大可能.我看了一下服务器的当前,包数才2000个,流量也只有2M左右,想请教一下,如果我这样配置是不是真的说明nginx吃不消了, 400错误日志如下 220.25...

by zzw45 - 服务器应用 - 2014-12-15 13:52:40 阅读(3103) 回复(4)

ZendOptimzer在FreeBSD7.1下与nginx不兼容? 没装ZendOptimzer时,能正常解析PHP,装后打开index.php显示 The page you are looking for is temporarily unavailable. 卸载后,则能正常解析PHP,还有没有谁遇到过类似问题,网上看了很多人遇到类似的问题,但似乎没谁讲到是不是与ZendOptimzer有关?

by tecer - BSD - 2009-05-19 12:27:33 阅读(2100) 回复(3)
by sfzzz - BSD - 2009-08-11 22:26:50 阅读(1641) 回复(2)

1