免费注册 查看新帖 |

ChinaUnix.net

  平台 论坛 博客 文库
最近访问板块 发新帖
查看: 22577 | 回复: 102

[Mail] Postfix_setup全自动安装包新版本发布 [复制链接]

论坛徽章:
1
金牛座
日期:2014-05-29 15:55:47
发表于 2011-04-19 10:45 |显示全部楼层
本帖最后由 iceblood 于 2011-04-19 11:50 编辑

支持平台:
FreeBSD
Linux(理论上所有Linux版本都支持)
历史事件:
2001年的时候我写了一个Qmail_setup-vxxxxx.tar.gz,每天都N多人下载,而Qmail
这玩意由于已经停止了更新,让我比较失望。在2003年后连我自己都没什么心情来更新
Qmail_setup了,在我用了长达8年的Qmail以后,我也开始转到postfix下了,所以顺便一
块推出Postfix_setup-vxxxxx.tar.gz,这个脚本比当年Qmail_setup要智能化很多。不过
由于时间关系我暂时没完整的写出Linux部分,当然这个脚本是自由的,公开的,而且我
决定谁都可以修改这个脚本,并且完善它。但是我希望的是,如果您真有心加入我的这个
行列,请一定找我要代码,因为只有我提供的代码才是最终的,修改完以后你可以在
README以及脚本的头信息里加上你的署名以及功能介绍和日期。然后把该软件发给我,由
我来统一发布。因为我不喜欢一个凌乱的版本,我希望的是统一。

2011年4月18号:
增加extmail的WEB mail系统,apache这样的软件请自行安装。

功能介绍:
1、软件自动下载,当然你可以自己下载了放到src目录里。
2、系统帐户、邮件帐户分离。
3、支持smtp/pop3。
4、支持虚拟域。
5、使用我写的脚本来管理域和用户。
6、扩展性强,如果你想增加其他功能,可以随时调整。
7、模块化安装和配置,让已经安装了一部分软件的朋友能自动跳过安装。

开始安装:
tar xzf postfix_setup-v.tar.gz
cd postfix_setup
chmod 755 setup

菜鸟安装:
如果你什么都不懂,那还是用以下方法吧:
安装所有模块:
./setup install ALL
配置所有模块:
./setup config ALL

中级安装:
如果你了解一部分,而且已经尝试过安装了一些东西,但是却不知道如何配置请使用
以下命令自己选择性操作:
帮助:
./setup
安装指定模块:
./setup install sasl
配置指定模块:
./setup config sasl
你还可以修改你的邮件存放路径:
vi setup
MAILBOX_BASE=/data/mailbox
修改这个路径就OK了。

高级安装:
你其实已经懂了,不过有点懒而已,那么你可以随便定制自己需要的啦。
MAILBOX_BASE=/data/mailbox
UID=60000
GID=60000
POSTFIX='postfix-2.7.2'
MYSQL='mysql-5.1.54'
SASL='cyrus-sasl-2.1.23'
AUTHDAEMON='courier-authlib-0.63.0'
IMAP='courier-imap-4.8.1'
当然对于软件版本的修改仅Linux有效,FreeBSD环境下软件版本由ports来决定。

======================================================================

下载地址:http://www.nettf.net/postfix/

评分

参与人数 1可用积分 +2 收起 理由
blueswxs + 2 原创内容

查看全部评分

论坛徽章:
0
发表于 2011-04-19 21:51 |显示全部楼层
这种好贴一定要顶!楼主辛苦了!

论坛徽章:
0
发表于 2011-04-19 23:46 |显示全部楼层
很好~

论坛徽章:
0
发表于 2011-04-20 16:24 |显示全部楼层
我试试哈

论坛徽章:
0
发表于 2011-04-22 09:18 |显示全部楼层
本帖最后由 czjin 于 2011-04-22 10:15 编辑

好东西,顶!可下载不了啊。
下载地址:http://www.nettf.net/postfix/   无法打开网页
可以打开了,已下载。立即测试。谢谢

论坛徽章:
1
金牛座
日期:2014-05-29 15:55:47
发表于 2011-04-22 09:36 |显示全部楼层
稍等……我的这个服务器在升级……

论坛徽章:
0
发表于 2011-04-22 11:53 |显示全部楼层
我下载安装结果报如下错误,我用的是FreeBSD8.0
QQ截图20110422114336.png

论坛徽章:
19
CU大牛徽章
日期:2013-04-17 11:48:262015年辞旧岁徽章
日期:2015-03-03 16:54:15羊年新春福章
日期:2015-03-10 22:39:202015年中国系统架构师大会
日期:2015-06-29 16:11:282015亚冠之平阳省
日期:2015-07-31 09:19:042015七夕节徽章
日期:2015-08-21 11:06:17IT运维版块每日发帖之星
日期:2015-09-30 06:20:002015亚冠之柏太阳神
日期:2015-10-19 20:29:5915-16赛季CBA联赛之天津
日期:2016-11-29 14:03:43双鱼座
日期:2015-01-12 20:58:532014年中国系统架构师大会
日期:2014-10-14 15:59:00CU大牛徽章
日期:2013-04-17 11:48:40
发表于 2011-04-22 12:22 |显示全部楼层
顶啊,LZ好人

论坛徽章:
1
金牛座
日期:2014-05-29 15:55:47
发表于 2011-04-22 12:58 |显示全部楼层
本帖最后由 iceblood 于 2011-04-22 13:06 编辑

把/var/db/ports/postfix里的options发出来给我看看。
看起来像是你取消了的脚本设置的一个选项。SPF。
导致编译失败。

论坛徽章:
0
发表于 2011-04-22 13:18 |显示全部楼层
fbsd8# cd /var/db/ports/postfix
fbsd8# vi options
_OPTIONS_READ=postfix-2.7.2,1
WITH_PCRE=true
WITH_SASL2=true
WITHOUT_DOVECOT=true
WITHOUT_DOVECOT2=true
WITHOUT_SASLKRB5=true
WITHOUT_SASLKMIT=true
WITH_TLS=true
WITHOUT_BDB=true
WITH_MYSQL=true
WITHOUT_PGSQL=true
WITHOUT_OPENLDAP=true
WITHOUT_CDB=true
WITHOUT_NIS=true
WITHOUT_VDA=true
WITHOUT_TEST=true
WITH_SPF=true
WITH_INST_BASE=true
~
~
~
您需要登录后才可以回帖 登录 | 注册

本版积分规则 发表回复

数据风云,十年变迁
DTCC 第十届中国数据库技术大会已启航!

2019年5月8日~5月10日,由IT168旗下ITPUB企业社区平台主办的第十届中国数据库技术大会(DTCC2019),将在北京隆重召开。大会将邀请百余位行业专家,就热点技术话题进行分享,是广大数据领域从业人士的又一次年度盛会和交流平台。与SACC2018类似,本届大会将采用“3+2”模式:3天传统技术演讲+2天深度主题培训。大会不仅提供超100场的主题演讲,还会提供连续2天的深度课程培训,深化数据领域的项目落地实践方案。
DTCC2019,一场值得期待的数据技术盛会,殷切地希望您报名参与!

活动入口>>
  

北京盛拓优讯信息技术有限公司. 版权所有 16024965号-6 北京市公安局海淀分局网监中心备案编号:11010802020122
中国互联网协会会员  联系我们:huangweiwei@it168.com
感谢所有关心和支持过ChinaUnix的朋友们 转载本站内容请注明原作者名及出处

清除 Cookies - ChinaUnix - Archiver - WAP - TOP